LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-21-2004, 03:35 PM   #1
fransemail
Member
 
Registered: Mar 2004
Posts: 72

Rep: Reputation: 15
Problem during startx


Hello to everybody! I've a problem with startx! When I try to start X by startx, X server crashes and display follow message. If I run X by X :0, XServer works and I can launch kde from a xterm window by startkde. Any ideas?


Release Date: 18 December 2003
X Protocol Version 11, Revision 0, Release 6.7
Build Operating System: Linux 2.6.7-0.rc1.1mdkenterprise i686 [ELF]
Current Operating System: Linux notebook 2.6.7 #1 Mon Jul 19 23:03:12 CEST 2004 i686
Build Date: 16 June 2004
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jul 21 22:07:43 2004
(==) Using config file: "/etc/X11/xorg.conf"
Using vt 7
Fulfilled via DRI at 8388608
Freed 8388608 (pool 2)
Synaptics DeviceInit called
SynapticsCtrl called.
Synaptics DeviceOn called

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error: Caught signal 11. Server aborting


Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

X connection to :0.0 broken (explicit kill or server shutdown).
X connection to :0.0 broken (explicit kill or server shutdown).
xinit: connection to X server lost.
 
Old 07-21-2004, 05:11 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
nothing that nasty there, so take the man's advice...
Quote:
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
 
Old 07-21-2004, 06:22 PM   #3
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
instead of startx..........

try using.........kdm
 
Old 07-24-2004, 01:11 PM   #4
fransemail
Member
 
Registered: Mar 2004
Posts: 72

Original Poster
Rep: Reputation: 15
xvt: unknown option "-n"

I've found that the problem comes from a bug. xvt is a symlink to konsole. I've trid to sym-link xvt to xterm and xinit now works! ( xinit -c fluxbox ) , but startx doesn't work... how can I do? ( It seems to a Mdk 10 bug )

Last edited by fransemail; 07-24-2004 at 01:31 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bug / Xwindows / startx : xinit works but startx crash www.rzr.free.fr Linux - Software 4 10-17-2004 08:06 AM
startx problem N_A_J_M Linux - General 14 02-06-2003 02:55 PM
another startx problem jleofad Linux - General 1 01-31-2003 02:08 PM
startx problem boo Linux - Networking 15 07-22-2002 08:03 AM
Startx problem HoRrIdPrObLeMs Linux - Newbie 9 03-05-2002 04:20 PM


All times are GMT -5. The time now is 03:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration