LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problem creating symlink with gcc to libgcc.a in LFS v6.7 (http://www.linuxquestions.org/questions/linux-software-2/problem-creating-symlink-with-gcc-to-libgcc-a-in-lfs-v6-7-a-862110/)

linuxpicaxe 02-11-2011 03:23 PM

Problem creating symlink with gcc to libgcc.a in LFS v6.7
 
Hi all!

First post here so hello! and hope i get this right :)

Right, I have been using linux for about 4 months now and decided i fancy the challenge of building a LFS system(Using book version 6.7). I have got all the way up to the point of gcc being installed and then have to create the symlink to libgcc.a

Now i have typed in the command and tried copy and pasting but i always get the following output:
Code:

lfs@experimental-OptiPlex-GX270:/mnt/lfs/sources/gcc-build$    ln -vs libgcc.a `$LFS_TGT-gcc -print-libgcc-file-name | \
> sed 's/libgcc/&_eh/'`
No command '-gcc' found, did you mean:
 Command 'cgcc' from package 'sparse' (multiverse)
 Command 'gcc' from package 'gcc' (main)
 Command 'gcc' from package 'pentium-builder' (universe)
-gcc: command not found
ln: creating symbolic link `./libgcc.a': File exists

Now it cannot find -gcc it appears but states at the bottom ./libgcc.a file exists.

Can anyone advise me on wheather to carry on, if its a fatal error or what I can do to possibly correct it!

Thanks all

Alex

Oliv' 02-12-2011 04:09 AM

Hello,

Quote:

No command '-gcc' found, did you mean:
Considering this error message and the command you try to run, I think that your $LFS_TGT environment variable is not set. So setting it up to a correct value should fix your problem.

Kind regards,

Oliv'

nuainkyeuh 02-28-2011 07:04 AM

Quote:

Originally Posted by Oliv' (Post 4255919)
Hello,


Considering this error message and the command you try to run, I think that your $LFS_TGT environment variable is not set. So setting it up to a correct value should fix your problem.

Kind regards,

Oliv'


where is setting up that environment??

druuna 02-28-2011 07:12 AM

Hi,

The LFS_TGT variable is set when you login using the lfs user. It is part of .bashrc and you created that file in this chapter: 4.4. Setting Up the Environment

To see if it is set: echo $LFS_TGT

Hope this helps.

linuxpicaxe 03-06-2011 12:24 PM

Hi all!

Thanks for the help. After running around in circles trying to reset variables and work out where gcc had run off to I figured it best to just start over again as something must have gone wrong somewhere. Doing that worked a treat so gcc must not have installed properly.

Cheers all :)

Alex


All times are GMT -5. The time now is 12:17 PM.