LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-23-2007, 07:58 PM   #1
DirkDiggler
Member
 
Registered: May 2007
Location: Florida/USA
Distribution: Ubuntu Feisty Fawn, Fedora 7, Windows XP
Posts: 91

Rep: Reputation: 16
Problem creating local Yum Repository


Hey,

Not sure if this is in the right forum, but it's related to software to it fits. I'm following the instructions from the website: www.city-fan.org/tips/YumRepoFromImages I perform the first five steps without error (after some fooling around, but I got it), but sixth step is where the problem lies. As the instructions list, a directory needs to be created for the mounting of the DVD iso that I have. I did that, and the chcon step is performed. I have very little understanding of this command, but I sort of get that it sets the security conext of the folder (as the man page states verbatim, I believe this is where the problem lies. Although, I do not know how to fix). I mount the DVD in the peviously created directory (I don't quite understand why the DVD needs to be mounted in two separate locations, but it's what the instructions say) with no problems. I change the directory, and I don't quite understand what the fifth step installs. Maybe it's a program that allows this directory to be a repository? Then, on the sixth step, createrepo . I get an error that says the directory needs to be writable. When I view the folder via nautilus, there is a pencil with a red circle and slash going through it.

Sorry for the extended explanation of what I did. I wanted to add my understanding of the process to detect a possible misunderstanding on my part. I tried going into the folder properties and setting read/write capabilities to the folder, but the settings don't stick. Which leads me to believe that the problem lies in the chcon command in step two.

Any help is greatly, greatly appreciated.

Regards,

Brandon
 
Old 05-25-2007, 12:04 AM   #2
DirkDiggler
Member
 
Registered: May 2007
Location: Florida/USA
Distribution: Ubuntu Feisty Fawn, Fedora 7, Windows XP
Posts: 91

Original Poster
Rep: Reputation: 16
*Bump*

Anything guys?

Regards,

Brandon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
want to set up local yum repository linmix Linux - Software 4 04-23-2013 03:42 AM
can i create a local yum repository? Sharaz Linux - General 5 01-21-2008 01:51 PM
how can i add a local Folder on local Hard Disk as Yum Repository ?? vahid_p Fedora 4 02-22-2007 10:43 AM
Creating YUM Repository Charles_In_Charge Linux - Newbie 6 09-07-2006 06:02 PM
Creating A Yum Repository SepitvaOra Linux - Newbie 1 04-04-2005 06:54 AM


All times are GMT -5. The time now is 02:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration