LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-18-2004, 11:25 AM   #1
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
problem changing file permissions on fat32 partition


Hi..

When I try to change file permissions on my mounted fat32 partition, I get an error "Operation not permitted"...

I am not sure if suffixing a '-w' in the options makes the vfat partition writable, but this is what i put in my /etc/fstab

/dev/hda1 /mnt/c: vfat rw,-w 0 0

Otherwise, I am able to create new files on my fat32 drive by manually mounting the windows partition-

mount -t vfat /dev/hda1 /mnt/c: -w

Let me know if the entry in /etc/fstab is incorrect..and if it is, whats the proper way to do that?

Second question is, that why am i not able to change file permissions? changing the umask also does not have any impact on newly created files......can anyone provide a solution?

Regards,

amit
 
Old 01-18-2004, 11:27 AM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
vfat filesystems have no support for these types of permissions. You need to decide what premssions you want all the files to have when you mount the partition.
 
Old 01-18-2004, 11:33 AM   #3
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Original Poster
Rep: Reputation: 31
Thanx david_ross..

what about this line in my /etc/fstab....is it correct?

/dev/hda1 /mnt/c: vfat rw,-w 0 0

So, can i enable uniform permission for the fat32 partition by using something like:

mount -t vfat /dev/hda1 /mnt/c: umask=777,-w


Regards,

amit
 
Old 01-18-2004, 01:01 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
I have no idea what permissions you are trying to achieve - try:
Code:
/dev/hda1        /mnt/c     vfat     defaults,umask=0000    0 0
This will let all users read, write and execute on that partition.
 
Old 01-18-2004, 01:44 PM   #5
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Original Poster
Rep: Reputation: 31
Thx david_ross....I got it now....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing permissions of FAT32 drive frogrocker Ubuntu 2 12-03-2005 04:51 PM
fat32 WinXP partition and permissions to use it, help!! KevinAlaska Fedora 1 06-06-2004 03:14 PM
Permissions on FAT32 Partition lcdial Linux - Newbie 3 03-28-2004 02:22 AM
Problem changing permissions on partition habitue Linux - Newbie 2 10-23-2003 08:56 AM
permissions and mounted fat32 partition ianunderwood Linux - Newbie 8 06-25-2003 05:17 AM


All times are GMT -5. The time now is 04:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration