LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-07-2003, 03:52 PM   #1
bubber
LQ Newbie
 
Registered: Dec 2002
Location: Aiken, SC
Distribution: Red Hat 8.0
Posts: 11

Rep: Reputation: 0
Problem accessing home share with Samba


I have a Win98 box called WS001 connected to a RH Linux 8.0 box called Bootle. Bootle is running Samba with the following config file:

[global]
workgroup = COMPUTERLAB
netbios name = MICRON
server string = Micron Samba Server
encrypt passwords = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printing = cups

[public]
path = /mnt/data
read only = No
guest ok = Yes

[homes]
read only = No
guest ok = No

[printers]
path = /var/spool/samba
guest ok = Yes
printable = Yes

User "Toad" has an account on Bootle and WS001, both with the password "zombie." Toad also has a Samba account password of "zombie." When Toad logs on WS001 he sees the following shares in Network Neighborhood:

\\Micron\public
\\Micron\homes
\\Micron\Laserjet
\\Micron\nobody

Toad can access public and print to the printer. No matter what he does, Toad can not seem to access his share /home/Toad that is on Bootle. If Toad tries to access //Micron/homes, the system requests a password. No known passwords satisfy the system. So, two questions:

1) What does Toad have to do to access his share /home/Toad on Bootle without explicity defining this share in smb.conf?

2) Who is nobody and why does he have a share?

Thanks for the help.
 
Old 03-07-2003, 06:53 PM   #2
bubber
LQ Newbie
 
Registered: Dec 2002
Location: Aiken, SC
Distribution: Red Hat 8.0
Posts: 11

Original Poster
Rep: Reputation: 0
OK, here is some more info. When Toad is on WS001 and has the public share open, smbstatus indicates that "nobody" is using the share. Evidently, Samba does not recognize Toad, even though he has an account on Bootle, WS001, and Samba -- all with the same user names and password.
 
Old 03-07-2003, 08:55 PM   #3
jamrock
Member
 
Registered: Jan 2003
Location: Kingston, Jamaica
Posts: 444

Rep: Reputation: 41
Interesting situation.

Is seems as if Toad is accessing public with the guest account. This is due to the fact that

guest ok= yes

on the public share.


We can assume then that there is something missing from the password logic.

Please post the commands used to create the Linux user account and the Samba user account.

BTW, a quick test would be to have

guest ok = yes

on the home share and see if Toad has access. You would want to change it back after the test for security reasons.
 
Old 03-08-2003, 10:23 AM   #4
bubber
LQ Newbie
 
Registered: Dec 2002
Location: Aiken, SC
Distribution: Red Hat 8.0
Posts: 11

Original Poster
Rep: Reputation: 0
I set up the users with the Red Hat 8.0 graphical utility (sorry,I am a Windows convert) and the Samba user name and password were set with the command smbpasswd -a Toad, at which point I entered the password. I have some other information that might help. When logged in as root, I can enter the command smbclient '\\Bootle\homes', at which point I am prompted for root's password. After entering the password I have access to /root, which is what I expect. When logged in as Toad, if I enter smbclient '\\Bootle\homes', I am prompted for Toad's password at which point I get the error NT_STATUS_WRONG_PASSWORD. In other words, Toad can't even access his home directory /home/Toad through Samba from Bootle. No wonder why things will not work from WS001. I assure you that the Linux and Samba user name and password for Toad are identical. Any ideas?
 
Old 03-08-2003, 06:00 PM   #5
bubber
LQ Newbie
 
Registered: Dec 2002
Location: Aiken, SC
Distribution: Red Hat 8.0
Posts: 11

Original Poster
Rep: Reputation: 0
I think I am making progress. WS001 and Bootle are connected with a crossover cable. I swapped WS001 (Win98) with WS002 (XP Home) and everything worked perfectly! Toad can automatically see his home share with no further fussing. So, Bootle must be set up properly. Switching back to WS001, Toad has to click on the homes share at which point he is asked to enter a password. No passwords on the system satisfy the request. This is starting to sound like a problem that would be discussed in the Network forum, but I can't seem to track it down. Can someone throw me a bone here and help me find where this problem and it solution are discussed? Thanks.
 
Old 03-09-2003, 10:46 AM   #6
bubber
LQ Newbie
 
Registered: Dec 2002
Location: Aiken, SC
Distribution: Red Hat 8.0
Posts: 11

Original Poster
Rep: Reputation: 0
Got it! Apparently Win98 converts all user names to uppercase when communicating with Samba. If I add

username level = 10

in smb.conf, Samba will try all different combinations of upper and lower case letters for 10 characters in a user name when it tries to match the Win98 user name with the Samba user name. Thus, with this setting in Samba, Toad is the same as TOAD, which is what Win98 is sending.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem accessing open office documents over samba share jonic Linux - Software 0 11-18-2005 10:46 AM
Accessing SAMBA Share via MS VC++ dhammika Programming 0 12-01-2004 10:14 PM
accessing ntfs share through samba GraemeK Linux - Software 2 01-26-2004 09:15 AM
Error while accessing samba share shankariyer Linux - Software 14 01-24-2004 04:16 AM
Accessing a Samba Share bkmesenbrink Linux - Software 2 07-31-2002 03:04 PM


All times are GMT -5. The time now is 07:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration