LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   pppd logging to /var/log/ppp.log problem (http://www.linuxquestions.org/questions/linux-software-2/pppd-logging-to-var-log-ppp-log-problem-133098/)

mrtwice 01-09-2004 11:43 AM

pppd logging to /var/log/ppp.log problem
 
I am trying to make pppd log to /var/log/ppp.log thorugh syslog:

Here is info:

Code:

root@gateway:/etc/ppp# tail /var/log/messages
Jan  9 11:40:15 gateway chat[2019]: ^M
Jan  9 11:40:15 gateway chat[2019]: +ER: LAPM^M
Jan  9 11:40:15 gateway chat[2019]: ^M
Jan  9 11:40:15 gateway chat[2019]: CONNECT
Jan  9 11:40:15 gateway chat[2019]:  -- got it
Jan  9 11:40:15 gateway pppd[2017]: Serial connection established.
Jan  9 11:40:15 gateway pppd[2017]: Using interface ppp0
Jan  9 11:40:15 gateway pppd[2017]: Connect: ppp0 <--> /dev/modem
Jan  9 11:40:20 gateway pppd[2017]: local  IP address xx.xxx.xxx.xxx
Jan  9 11:40:20 gateway pppd[2017]: remote IP address xxx.xxx.xxx.xxx

root@gateway:/etc/ppp# tail /var/log/ppp.log

root@gateway:/etc/ppp# cat /etc/syslog.conf
# /etc/syslog.conf
# For info about the format of this file, see "man syslog.conf"
# and /usr/doc/sysklogd/README.linux.  Note the '-' prefixing some
# of these entries;  this omits syncing the file after every logging.
# In the event of a crash, some log information might be lost, so
# if this is a concern to you then you might want to remove the '-'.
# Be advised this will cause a performation loss if you're using
# programs that do heavy logging.

# Uncomment this to see kernel messages on the console.
#kern.*                                                /dev/console

# Log anything 'info' or higher, but lower than 'warn'.
# Exclude authpriv, cron, mail, and news.  These are logged elsewhere.
*.info;*.!warn;\
        authpriv.none;cron.none;mail.none;news.none;pppd.log    -/var/log/messages

# Log anything 'warn' or higher.
# Exclude authpriv, cron, mail, and news.  These are logged elsewhere.
*.warn;\
        authpriv.none;cron.none;mail.none;news.none;pppd.none  -/var/log/syslog

# Debugging information is logged here.
*.=debug                                                -/var/log/debug

# Private authentication message logging:
authpriv.*                                              -/var/log/secure

# Cron related logs:
cron.*                                                  -/var/log/cron

# Mail related logs:
mail.*                                                  -/var/log/maillog

# Emergency level messages go to all users:
*.emerg                                                *

# This log is for news and uucp errors:
uucp,news.crit                                          -/var/log/spooler
# Uncomment these if you'd like INN to keep logs on everything.
# You won't need this if you don't run INN (the InterNetNews daemon).
#news.=crit                                    -/var/log/news/news.crit
#news.=err                                      -/var/log/news/news.err
#news.notice                                    -/var/log/news/news.notice

pppd.*                                          -/var/log/ppp.log

This seems like it should work from the syslog.conf man page. What am I donig wrong? Thanks

---- Update ----
I have now added pppd.none to the files above. Now, no messages show up in /var/log/messages, but no messages are showing up in /var/log/ppp.log either? Frustrating...

lyle_s 01-10-2004 05:38 PM

> pppd.* -/var/log/ppp.log

Can you use pppd as a facility?

I think there are a few different syslogd daemons, but on mine only auth, authpriv, cron, daemon, kern, lpr, mail, mark, news, security (same as auth), syslog, user, uucp, and local0 through local7 can be used where you used pppd.

pppd has a "logfile" option that could be used to achieve what you're trying to do.

Lyle


All times are GMT -5. The time now is 04:54 AM.