LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-31-2003, 04:17 PM   #1
linuxBill
Member
 
Registered: Mar 2003
Location: Pennsylvania
Distribution: RedHat 7.3
Posts: 40

Rep: Reputation: 15
ppp connect problem


I'm trying to setup a ppp server and client. I'm connecting these two systems via ttyS0 (direct). I've followed a linux HOWTO but when I try to start ppp over the link I get the following error:

/usr/sbin/pppd: bad local IP address 127.0.0.1

Can anyone help explain this error?

Thanks in advance for any help.

linuxBill
 
Old 03-31-2003, 04:33 PM   #2
AltF4
Member
 
Registered: Sep 2002
Location: .at
Distribution: SuSE, Knoppix
Posts: 532

Rep: Reputation: 31
you seem to have configured 127.0.0.1 as your ppp IP address, but the 127.x.x.x network is reserved for the loopback network.

better user 10.X.X.X or 192.168.X.X for your ppp connection if it's private (not connected to the internet)

Private IP address space has been allocated via RFC 1918.
10.0.0.0 10.255.255.255 alias 10.0.0.0/8
172.16.0.0-172.31.255.255 alias 172.16.0.0/12
192.168.0.0 192.168.255.255 alias 192.168.0.0/16
 
Old 04-01-2003, 07:48 AM   #3
linuxBill
Member
 
Registered: Mar 2003
Location: Pennsylvania
Distribution: RedHat 7.3
Posts: 40

Original Poster
Rep: Reputation: 15
The server is also connected to a network via ethernet. Does this make any difference?
 
Old 04-01-2003, 09:44 AM   #4
AltF4
Member
 
Registered: Sep 2002
Location: .at
Distribution: SuSE, Knoppix
Posts: 532

Rep: Reputation: 31
not concerning 127.X.X.X and RFC 1918 addresses
any private addresses should use RFC 1918 space
 
Old 04-03-2003, 01:56 PM   #5
linuxBill
Member
 
Registered: Mar 2003
Location: Pennsylvania
Distribution: RedHat 7.3
Posts: 40

Original Poster
Rep: Reputation: 15
AltF4,
Sorry, I've been off on a tangent. As a newbie, I'm not sure where to correct this problem. My /etc/hosts file is as follows:
# Do not remove the following line, or various programs
# that require network functionality will fail.
#127.0.0.1 localhost.localdomain localhost
127.0.0.1 localhost BillsSys
169.69.69.3 HPLaserJ2100
169.69.69.180 cds
169.69.69.181 cds2
169.69.69.200 KoreanUnit
169.69.69.150 john
169.69.69.179 bill
169.69.69.254 guest
10.0.0.3 ppp01
10.0.0.4 ppp02


What is wrong here? Am I looking in the right location?

Bill
 
Old 04-03-2003, 02:17 PM   #6
AltF4
Member
 
Registered: Sep 2002
Location: .at
Distribution: SuSE, Knoppix
Posts: 532

Rep: Reputation: 31
Suppose you used "BillsSys" somewhere in your ppp-config

you should use "real" addresses, 127.0.0.1 should not be used for anything but loopback
 
Old 04-04-2003, 08:21 AM   #7
linuxBill
Member
 
Registered: Mar 2003
Location: Pennsylvania
Distribution: RedHat 7.3
Posts: 40

Original Poster
Rep: Reputation: 15
The only places I can find that I used "BillsSys" is in options.ttyS0 and options.ttyS4. Those two files contain: BillsSyspp01 and BillsSyspp02 respectively. I got that input from the HOWTO file. What should be in there?

Bill
 
Old 04-04-2003, 09:48 AM   #8
linuxBill
Member
 
Registered: Mar 2003
Location: Pennsylvania
Distribution: RedHat 7.3
Posts: 40

Original Poster
Rep: Reputation: 15
I don't know how those smiley faces got in there. I'll try to clarify that, replace the smiley face with : and p. (). I'll do it again and hope the smiley faces don't appear, BillsSyspp01 and BillsSyspp02

Bill
 
Old 04-04-2003, 09:48 AM   #9
linuxBill
Member
 
Registered: Mar 2003
Location: Pennsylvania
Distribution: RedHat 7.3
Posts: 40

Original Poster
Rep: Reputation: 15
Damn!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with ppp connect please_die Red Hat 4 05-14-2005 04:07 AM
can't connect to internet through PPP dvm Slackware 11 09-14-2004 02:50 AM
Cannot connect via ppp 3.0r2 PsychosisNode Debian 2 08-01-2004 05:00 PM
Getting reject when trying to connect via ppp. Tarts Slackware 2 11-13-2003 06:40 AM
PPP won't Connect CalcAE Linux - Networking 1 06-16-2002 07:18 AM


All times are GMT -5. The time now is 09:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration