LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-30-2004, 03:33 PM   #1
biscristi
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 51

Rep: Reputation: 15
powersaved , suse 9.1 ???


i just installed suse 9.1 and all works great but power management. I can't seem to get it to work. First i wanted to use apm and set (for example) 10 minutes till standby in kde control center - power management, but when i did that it started to enter standby at random times, never when it should. So i disabled that and checked out the powersave feature. I don't really know what this is but it doesn't work. For instance i set it up to enter stanby when i push the sleep button,.. it did nothing. running powersave -u also nothing. I didn't have installed acpi, so no acpid running, no apmd running.
What should i do to get it running ?
..
Also for example gaim does not detect x usage (to set me away after a number of minutes of not using mouse or keyboard).
Please help, this is really imporrtant to me
 
Old 05-30-2004, 05:39 PM   #2
ultrabeam16
LQ Newbie
 
Registered: Mar 2004
Distribution: Debian Sarge
Posts: 7

Rep: Reputation: 0
I had a few problems with power management too, though they were different. Basically I just force ACPI on so that I can use the power management functions -- SuSE detected APM but I know my computer had ACPI.

THE INSTRUCTIONS BELOW ONLY WORK FOR THE GRUB BOOT LOADER!!

Log on as root and edit the /boot/grub/menu.lst file so that menu entry that boots Linux has "apm=off acpi=force" in the kernel string. See mine below:

Code:
title linux
    kernel (hd0,3)/boot/vmlinuz root=/dev/hda4 vga=0x342 splash=silent apm=off acpi=force desktop resume=/dev/hda3 showopts
    initrd (hd0,3)/boot/initrd
Then reboot. ACPI should now be active and all the power management stuff should work. To configure it use YaST. You're screensaver should work now too.

Thats it there must be some similar thing for the LILO boot loader but since I dont use it I dont really know how to configure it.
 
Old 05-31-2004, 03:20 AM   #3
biscristi
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
Didn't work. running powersave -u does exactly the same as before, nothing. And gaim still isn't aware of x usage.
Does acpi daemon need to be running ? At the moment neither acpid or apmd is running.
 
Old 06-09-2004, 04:38 PM   #4
Mr_C
Member
 
Registered: Jan 2004
Location: Trinidad & Tobago
Distribution: Slackware
Posts: 317

Rep: Reputation: 30
well I have acpi=on in my grub and I 'seem' to get a level of power management. My processor runs cooler and the fan switches of from time to time. My function keys work. I get the a message of powersave not running or you need to be in the powersave group. (I know its running cause I see the service startup during boot).

I can't go on standby/hibernation either. I suspect I have to recompile my kernel???
 
Old 07-31-2004, 09:02 AM   #5
dfowensby
Member
 
Registered: Dec 2003
Location: OceanView Virginia, gem of the Southern Shore
Distribution: Oz Unity Diamond IIB [x64 xfce]
Posts: 194
Blog Entries: 1

Rep: Reputation: 30
how do you make 9.1 Acoustic wait longer???

under lilo, enter acpi (or noacpi) in the append line. pick yer poison.

i have it working fine, got rid of the not running nag label by removing powersave from the boot conf, rebooting, then restarting the gui manually, no probs.
what i find aggravating is it's only set for 20 seconds. on-off-on-off. grrrrrrr.
i just want the hard drive to run for a little longer, before the Acoustic setting shuts it down. a half hour would be nice. anybody know what/where i can edit/butcher the idle timer on kpowersave?
-O.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
powersaved in SuSE 9.1 Pingus Suse/Novell 4 02-26-2006 07:35 AM
powersaved reiserfs biophysics Fedora 0 06-19-2005 10:50 AM
powersaved mattl Suse/Novell 6 03-15-2005 07:25 AM
ACPI Suspend with powersaved but KDE freezes after bootup Daumeier Linux - Software 0 12-01-2004 05:18 AM
SuSE 9.1 powersaved problem wiresquire Linux - Laptop and Netbook 0 08-06-2004 01:53 AM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration