LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Postfix problem (also using Cyrus IMAP) (http://www.linuxquestions.org/questions/linux-software-2/postfix-problem-also-using-cyrus-imap-288561/)

newtommy 02-10-2005 11:43 AM

Postfix problem (also using Cyrus IMAP)
 
Hi,

Thanks for reading this - I'm hoping someone out there can help me out. I havn't had luck searching the web for a solution. Here's my situation:

Running SuSE9.2 Linux, with Postfix installed and working for shell accounts. So I can send and receive mail anywhere when I am logged in and say using PINE.

Added CYRUS IMAP support for a new Squirrelmail implementation which is working nicely from the Web. I can send/receive mail normally when using Squirrelmail with my IMAP connection (Squirrelmail server is also located on the same box as my IMAP and Postfix)

Here's the problem:: When another computer on my local network wants to send mail from a mail program located off the server and connected to my IMAP, it can only send mail to local users! When I try to send mail to any user not hosted on my linux box I get an "unknown user" error and SMTP refuses to deliver the message to outside people. (how can it know they're unknown!)

So for example - using the normal mail application on a Macintosh on my network, I can receive all messages sent to me (which are delivered via IMAP) but can only send mail to people with accounts on my linux box.

Any idea how to fix this? I'm sure it has to do with some settings in postfix.?
also by the way I have MyNetworks = 192.168.1.1/70 , 127.0.0.1/7 so the Mac is within the networks defined in main.cf

Thanks, I really apprecaite any help you can offer.

Sincerely,
Tom

[GOD]Anck 02-10-2005 11:58 AM

Please post your postfix/main.cf.. I'd be happy to take a look.

newtommy 02-10-2005 12:52 PM

Apologies for the delay - Here is main.cf, Again thanks for the help:

Main.cf:
-------------------
queue_directory = /var/spool/postfix

command_directory = /usr/sbin

daemon_directory = /usr/lib/postfix

mail_owner = postfix

myhostname = gandalf.bostonst.com

mydomain = bostonst.com

myorigin = $mydomain

inet_interfaces = all
local_recipient_maps =

unknown_local_recipient_reject_code = 550



mynetworks = 192.168.1.1/300 , 127.0.0.1/8


debug_peer_level = 3

debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail

newaliases_path = /usr/bin/newaliases


mailq_path = /usr/bin/mailq


setgid_group = maildrop


html_directory = /usr/share/doc/packages/postfix/html


manpage_directory = /usr/share/man

sample_directory = /usr/share/doc/packages/postfix/samples


readme_directory = /usr/share/doc/packages/postfix/README_FILES
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient

program_directory = /usr/lib/postfix

masquerade_domains =
mydestination = $myhostname, localhost.$mydomain, $mydomain
defer_transports =
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport = cyrus
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = no
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000

[GOD]Anck 02-10-2005 02:16 PM

First off, I think you may have a typo in mynetworks = 192.168.1.1/300 , 127.0.0.1/8, as /300 isn't a valid network.

But for the real problem, I think you will need to set the relayhost parameter. It tells Postfix where it should send e-mail that is not destined for local machines. Specifying your ISP's SMTP server ip or DNS name should do the trick.

Remember to set up some security measures to prevent outsiders from sending e-mail through your Postfix server... this is a good HOWTO that will help you set up SMTP AUTH: http://postfix.state-of-mind.de/patr...tter/smtpauth/

Good luck. :)

newtommy 02-10-2005 02:40 PM

Hi,

Thanks for the pointers - I think what you're saying about relay host makes a lot of sense to me with your explanation. Also thanks for the security pointer - that was my next thing to attack in getting this stuff up and running.

Kind Regards,
Tom


All times are GMT -5. The time now is 01:08 AM.