LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-14-2005, 01:03 AM   #1
simonsez711
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Rep: Reputation: 0
Postfix, Dovecot, SquirrelMail Troubles?!


I just configured Postfix and Dovecot and have been at this for a couple of days now. I'm able to log into my mail server just fine. Problem is, I'm unable to see my mail sitting in my Inbox. When I check /var/log/maillog I get this:

Code:
Jul 11 22:11:35 simonsez imap-login: Login: simonsez [::ffff:127.0.0.1]
Jul 11 22:11:35 simonsez imap(simonsez): open() failed with file /home/simonsez/Maildir/new/1120932625.Vfd00I4b8475M698431.simonsez.homeunix.com: Permission denied
For some reason, my user "simonsez" is unable to open the new mail that is sitting at /home/simonsez/Maildir/new/ due to permissions denied. The newmail sitting in my Inbox is labelled "Unknown Unknown date (no subject)". When I try to view it or delete it, I get this error message:

Code:
Notice: Trying to get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.php on line 691

Notice: Trying to get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.php on line 691

Notice: Trying to get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.php on line 692

Notice: Trying to get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.php on line 692

Notice: Trying to get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.php on line 693
What do I need to configure to make this work?
 
Old 07-14-2005, 05:55 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
What's the permissions of these new mail?
 
Old 07-14-2005, 07:04 PM   #3
simonsez711
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by trickykid
What's the permissions of these new mail?
Thanks for the reply. The actual messages are chmoded at 700. The folder "new" is 700. And the folder Maildir is chmoded 700.
 
Old 07-15-2005, 12:51 PM   #4
simonsez711
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
Postfix, Dovecot, SquirrelMail Troubles?!

I just configured Postfix and Dovecot and have been at this for a couple of days now. I'm able to log into my mail server just fine. Problem is, I'm unable to see my mail sitting in my Inbox. When I check /var/log/maillog I get this:

Code:
Jul 11 22:11:35 simonsez imap-login: Login: simonsez [::ffff:127.0.0.1]
Jul 11 22:11:35 simonsez imap(simonsez): open() failed with file /home/simonsez/Maildir/new/1120932625.Vfd00I4b8475M698431.simonsez.homeunix.c om: Permission denied
For some reason, my user "simonsez" is unable to open the new mail that is sitting at /home/simonsez/Maildir/new/ due to permissions denied. The newmail sitting in my Inbox is labelled "Unknown Unknown date (no subject)". When I try to view it or delete it, I get this error message:

Code:
Notice: Trying to get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.php on line 691

Notice: Trying to get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.php on line 691

Notice: Trying to get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.php on line 692

Notice: Trying to get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.php on line 692

Notice: Trying to get property of non-object in /usr/share/squirrelmail/class/mime/Message.class.php on line 693
What do I need to configure to make this work?
 
Old 07-20-2005, 10:19 AM   #5
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 66
Merged your two threads so people can see what has been explored so far....
 
Old 07-20-2005, 12:30 PM   #6
Red Sparrow
LQ Newbie
 
Registered: Jul 2005
Distribution: Gentoo & Ubuntu
Posts: 3

Rep: Reputation: 0
Who is the owner and group of the mail message and who is the owner and group of /home/simonsez/Maildir/new/? How do you authenticate with dovecot (what are the settings for auth_userdb and auth_passdb in dovecot.conf)?

(- Steve -)
 
Old 07-20-2005, 12:43 PM   #7
simonsez711
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
The owner of mail is simonsez.
auth_userdb = passwd
auth_passdb = pam
 
Old 07-20-2005, 12:47 PM   #8
simonsez711
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
It's odd....I can see my mail when I use Evolution Mail but it's only when I use SquirrelMail that I have this problem.
 
Old 07-20-2005, 01:25 PM   #9
Red Sparrow
LQ Newbie
 
Registered: Jul 2005
Distribution: Gentoo & Ubuntu
Posts: 3

Rep: Reputation: 0
Just to clarify. Do you get the "permission denied" error when you connect with Evolution or just when you connect with Squirrelmail? It seems like this is a Squirrelmail problem.

(- Steve -)
 
Old 07-20-2005, 01:30 PM   #10
simonsez711
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
Just with squirrelmail.
 
Old 07-22-2005, 12:11 PM   #11
rioguia
Member
 
Registered: Jun 2002
Posts: 411

Rep: Reputation: 30
Is SE Linux enabled?

To see if SE linux is enabled on your machine, su root and type: /usr/sbin/sestatus. If you find that SE Linux is enabled, temporarily
disable it. You can temporarily turn it off by typing setenforce 0 (and type
setenforce 1 to temporarily restore enforcing mode after you have concluded your test).

IF SE Linux is the issue, you may want to try:

Step 1. vi /etc/selinux/targeted/booleans

Step 2. insert: httpd_can_network_connect=1

[EDITED]
Step 3. reboot

setsebool -P httpd_can_network_connect=1 and reboot should also work

Last edited by rioguia; 07-22-2005 at 04:15 PM.
 
Old 07-22-2005, 01:23 PM   #12
simonsez711
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
Re: Is SE Linux enabled?

Quote:
Originally posted by rioguia
To see if SE linux is enabled on your machine, su root and type: /usr/sbin/sestatus. If you find that SE Linux is enabled, temporarily disable it. You can temporarily turn it off by typing setenforce 0 (and type setenforce 1 to temporarily restore enforcing mode after you have concluded your test).

IF SE Linux is the issue, you may want to try:

Step 1. vi /etc/selinux/targeted/booleans

Step 2. insert: httpd_can_network_connect=1

Step 3. cd /etc/selinux/targeted/src/policy/

Step 4. make reload

OMG, I did what you posted and now my machine doesn't load right. It gets stuck at this on startup:

Code:
                 Welcome to Fedora Core
                 Press 'I' to enter interactive startup
Starting udev: MAKEDEV: mkdir: File exists
matchpathcon(/dev/nvidia0) failed Permission denied
matchpathcon(/dev/nvidiact1) failed Permission denied
                                                              [OK]
Initializing hardware..._

help!!!
 
Old 07-22-2005, 01:45 PM   #13
simonsez711
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
OK....I used FC4 disk with linux rescue mode and took out what you posted and now it reboots fine. What happened there? I'd like to know why it hangs with the settings you provided.
 
Old 07-22-2005, 02:25 PM   #14
rioguia
Member
 
Registered: Jun 2002
Posts: 411

Rep: Reputation: 30
what was the result of /usr/sbin/sestatus ?

what was the result of /usr/sbin/sestatus ?

I did this on FC3 and it fixed my similar problem. it comes from:

https://bugzilla.redhat.com/bugzilla....cgi?id=158181

You could also try setsebool -P httpd_can_network_connect=1 and see if that works.


Last edited by rioguia; 07-22-2005 at 02:30 PM.
 
Old 07-22-2005, 02:32 PM   #15
simonsez711
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
I just disabled SELinux and now I can use my Squirrelmail correctly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with Squirrelmail with Dovecot & Sendmail cojo Linux - Software 17 05-18-2006 06:15 AM
postfix dovecot Maildir Danny Regan Debian 3 11-15-2005 04:08 PM
Postfix Dovecot Help BigAppleFan Linux - Newbie 7 08-15-2005 05:08 PM
access denied on squirrelmail / dovecot / SE Linux policy rioguia Linux - Security 2 07-06-2005 11:25 PM
Postfix and Dovecot umbraeOtheisles Linux - Software 3 11-23-2004 07:36 AM


All times are GMT -5. The time now is 02:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration