LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-13-2004, 04:24 PM   #1
joseph_1970
Member
 
Registered: Jan 2003
Posts: 62

Rep: Reputation: 15
Postfix - amavisd (?) localhost.com


Hi, guys (and gals);

I am troublshooting a buddy's install of postfix w/ amavis, clam, and SA.

Problem:

handoff to amavis at localhost is resolving to localhost.com

Things work fine with the postfix normally, if I take out the line in main.cf and 2 lines in master.cf, which I will give you if you want them, although things seem to be up and running in terms of amavis. I can telnet into 10024 and 10025, so no problems there, the services are answering just fine.

I get the proper output from netstat.

hosts file is setup fine and resolv.conf is with local ns, which seems to be setup right, and host lookup of localhost resolves to 127.0.0.1 fine.

Somethings wacky here, but I can't figure it out. It seem the handoff to amavis never makes it there, but tries localhost.com instead of localhost (127.0.0.1).

Any ideas?

TIA.

-joseph

Last edited by joseph_1970; 02-13-2004 at 04:26 PM.
 
Old 02-13-2004, 06:42 PM   #2
joseph_1970
Member
 
Registered: Jan 2003
Posts: 62

Original Poster
Rep: Reputation: 15
Well, I really don't want to run it this way, although I don't mind too much. I would like to figure out how to fix this issue. It does work with the following change.

main.cf: changed the localhost to ip.

content_filter = smtp:127.0.0.1:10024

Anyone want to tell me whats the deallyO, please?

I checked the config with my NS, so it doesn't seem like it is my buddy's NS. Again, hosts and resolv are fine.

Wacky, Man!

Any comments or suggestions whould be greatly appreciated. I don't like doing a workaround on something like this, eh. I can see this creeping up again some time.

Thanks!

-j
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spamassassin setup with Postfix, Dovecot and Amavisd snurckle Linux - General 2 04-07-2005 01:16 PM
Postfix: localhost.domain.com iantri Linux - Networking 8 07-27-2004 12:21 PM
HELP: Postfix SMTP only seems to run for localhost lhoff Mandriva 1 02-29-2004 09:34 AM
Postfix/amavisd-new virus scaning only thesnaggle Linux - Software 0 12-16-2003 11:08 AM
postfix can't resolve localhost yapp Linux - Networking 2 12-02-2003 02:48 PM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration