LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Possible to hide KDE icons in Gnome 2.8? (http://www.linuxquestions.org/questions/linux-software-2/possible-to-hide-kde-icons-in-gnome-2-8-a-289366/)

tisource 02-12-2005 12:58 PM

Possible to hide KDE icons in Gnome 2.8?
 
Hello,

I have always preferred KDE (and still do), but am giving Gnome 2.8 a spin. One thing I notice is that my KDE icons are appearing on my Gnome desktop. I thought there might be a way to change the directory in which Gnome is looking for the icons (the ~/Desktop folder), but gnome-conf doesn't show such a folder.

Doing some research, it appears Gnome no longer handles desktop icons the same way KDE does (creating icon files in the desktop folder) - or at least that is my impression.

However, Gnome must be looking at the folder, or my KDE icons wouldn't be appearing there.

Is there a way to hide the KDE icons (don't care how it is done)? I'd love to give Gnome 2.8 a chance, but all of my KDE icons are very distracting when in Gnome.

I'm running Fedora Core 3 at the moment.

Thanks

bulliver 02-12-2005 02:54 PM

I don't think it is possible to have kde icons on a Gnome desktop. That doesn't make sense. Are you sure that you are not just seeing Fedora's "look the same for all desktops" icons?

Can you post a screenie?

reddazz 02-12-2005 05:52 PM

Actually it does happen on most distros. The reason for this is that KDE used to put stuff in ~/.Desktop, then the Gnomers decided to do the same due to FreeDesktop standards. The best way to remove this annoyance is to change the KDE PATHS using kcontrol. Instead of KDE storing it's icons and other desktop settings in ~/.Desktop, change it to something like ~/.Kdesktop, move the KDE icons to that directory and GNOME should work fine without the KDE icons.

Franklin 02-12-2005 06:11 PM

Quote:

Originally posted by reddazz
Actually it does happen on most distros. The reason for this is that KDE used to put stuff in ~/.Desktop, then the Gnomers decided to do the same due to FreeDesktop standards. The best way to remove this annoyance is to change the KDE PATHS using kcontrol. Instead of KDE storing it's icons and other desktop settings in ~/.Desktop, change it to something like ~/.Kdesktop, move the KDE icons to that directory and GNOME should work fine without the KDE icons.
I will second this as a good (the only) work around. Trash may act funky though. Gnome wants it in Desktop. KDE wants it in KDesktop (or whatever you pick) It will not act as a functional trash can in both DE's.

bulliver 02-12-2005 06:31 PM

Wow, learn something new everyday :)
I had no idea.

tisource 03-15-2005 03:48 PM

I changed the KDE path from ~/Desktop to ~/.kde/Desktop and it works fine.

So far, no probs with the trash can. My icons slide all over (never stay in place after a logoff), but that is another problem.

Thank you


All times are GMT -5. The time now is 09:43 AM.