LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-28-2003, 09:07 AM   #1
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 37
Poor Quality DVDs


Perhaps "poor" is too strong a word. I actually think that "not quite perfect" would be better, but then no-one would read the post.
I have Xine for playing DVDs on Linux. When they play, there's no lag or anything, but during times when things move quickly, it's just about discernible that instead of solid objects moving quickly, I am getting interlacing (I think that's the word - it means lots of little lines all mashed up together right?) . This is most obvious in my favourite DVDs - Futurama, due to the fact that it's mostly solid blocks of colour.
To illustrate a little better, using ASCII:

Instead of this three stage process:

------------++ -------+++++++ --++++++++++++
------------++ -------+++++++ --++++++++++++
------------++ -------+++++++ --++++++++++++
------------++ -------+++++++ --++++++++++++
------------++ -------+++++++ --++++++++++++
------------++ -------+++++++ --++++++++++++
------------++ -------+++++++ --++++++++++++
------------++ -------+++++++ --++++++++++++

I might get something like this:

------------++ ----++++++++++ --++++++++++++
------------++ ----------++++ --++++++++++++
------------++ ----++++++++++ --++++++++++++
------------++ ----------++++ --++++++++++++
------------++ ----++++++++++ --++++++++++++
------------++ ----------++++ --++++++++++++
------------++ ----++++++++++ --++++++++++++
------------++ ----------++++ --++++++++++++

Or maybe even this:

------------++ ------------++ --++++++++++++
------------++ --++++++++++++ --++++++++++++
------------++ ------------++ --++++++++++++
------------++ --++++++++++++ --++++++++++++
------------++ ------------++ --++++++++++++
------------++ --++++++++++++ --++++++++++++
------------++ ------------++ --++++++++++++
------------++ --++++++++++++ --++++++++++++


Obviously, there's only so much you can do with ASCII, but hopefully you get the idea.
Anyway, so my question is:
Is this anything fixable? Is it to do with DVD decryption not being perfect? My libdvdcss, libdvdread and libdvdnav are all pretty recent (very recent in fact - can't remember the version but they're less than a month old). Is it Xine? Am I just being over-sensitive? - my girlfriend can't tell, but she's not a vision perfectionist.
Thanks in advance
Guy

Last edited by guygriffiths; 10-28-2003 at 09:10 AM.
 
Old 10-28-2003, 11:50 AM   #2
krussell
Member
 
Registered: Jul 2003
Location: dhaka
Distribution: Slackware 11 (fixed), MEPIS
Posts: 241

Rep: Reputation: 30
that's a good post describing your problem.
but have you tried mplayer? you can download it from http://mplayerhq.hu.
 
Old 10-28-2003, 11:52 AM   #3
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
do you get the same effect if you play the DVD in a regular DVD player?

You don't mention what kind of machine you have so I cannot comment on whether it might be underpowered or not.

My laptop's a PII333 with 192 Megs of ram. Out of the box, DVDs are unwatchable, even though when I had win98 and powerDVD I could watch them flawlessly.

The things that saved me were 1) tweaking the machine to make sure I get the best performance I can get (ie: recompiling the kernel, turning on DMA for the DVD drives, things like that), 2) switching to Mplayer and 3) (most important) compiled Mplayer from source.

Even compiling from source I could never get DVDs to run in Xine...mplayer however handles them so well that I find the quality is even better than in Windows...the only thing I miss is having the DVD menus and such, which I never got to work.
 
Old 10-28-2003, 02:41 PM   #4
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Original Poster
Rep: Reputation: 37
I've been thinking about using MPlayer for a while now. I might give it a go. My machine is almost certainly not underpowered (2GHz with 1GB of RAM) and it plays fine in normal DVD players and also on Windows. My system is built from scratch (http://www.linuxfromscratch.org - highly recommended) so there shouldn't be anything stopping it. Have you installed libdvdnav? That will help with DVD menus
Guy
 
Old 10-28-2003, 02:46 PM   #5
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
No that's certainly not underpowered. I find that strange tho...
I mean I have an athlon 1ghz also...and that plays DVDs just fine using Xine.

I won't say DON'T try mplayer...its great...I'm just saying that the problem probably lies elsewhere.

Do you have DMA enabled on your DVD drive?
 
Old 10-29-2003, 03:08 AM   #6
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Original Poster
Rep: Reputation: 37
Yes, I have DMA enabled. Personally I think the problem lies with libdvdcss not being perfect, but if no-one else has had this problem...
 
Old 10-29-2003, 08:13 AM   #7
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
is there any specific reason you think libdvdcss is the problem?
 
Old 10-29-2003, 08:36 AM   #8
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Original Poster
Rep: Reputation: 37
Xine works fine for other formats (avi, mpeg, rm is all I've tried). Also, I know that libdvdcss is not the "true" way of decoding DVDs and has to "sort of crack the encryption". The other reason I think this is because when I have used transcode to rip dvds in the past, it had the same problem.
Guy
 
Old 12-03-2003, 09:48 AM   #9
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Original Poster
Rep: Reputation: 37
Bump!
Also, I have tried MPlayer to no avail - the exact same problem occurs. I have tried different output plugins on both, and the ones that work at all all work the same, i.e. not very well (if that makes sense)
Firstly, had ANYONE else had this problem.
Secondly, does anyone use an onboard SiS graphics card with Thomas Winischhofer's drivers (and DRI enabled)? Do you have this problem?
Thanks
Guy
 
Old 12-03-2003, 10:17 AM   #10
RolledOat
Member
 
Registered: Feb 2003
Location: San Antonio
Distribution: Suse 9.0 Professional
Posts: 843

Rep: Reputation: 30
Well, one thing to try, start it as root, with
nice --20 Xine
(note TWO minus signs)

If that fixes the problem, or makes it less noticeable, then it is a horsepower problem. My guess would be that it is the video driver. While windows has optimized drivers for your onboard SIS card, you are using the reverse engineered driver that simply takes too much CPU.

R.O.
 
Old 12-03-2003, 12:46 PM   #11
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,219

Rep: Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627
Guygriffiths, all you need to do to solve your problem is to press the "i" key when you're watching your DVD. That will turn Xine's deinterlacing mode on. Press "i" again if you want to turn deinterlacing off. Xine's default deinterlacing algorithm drops one field (and half your video quality) but you can choose other algorithms from Xine's menus.

I've posted a somewhat more detailed reply to the following thread:
Non-interlaced DVD playback? No encryption-probs? Is this possible?

This problem has nothing, and I repeat, NOTHING to do with your computer's performance.
 
Old 12-03-2003, 12:50 PM   #12
Hiper
Member
 
Registered: Aug 2003
Location: Portugal
Distribution: Slackware 10.0
Posts: 100

Rep: Reputation: 15
I don't even have a DVD player but that effect seems to me the so called "tearing", which happens when the graphics card starts sending pixels to the screen but it's not coordinated with the screen.

anyway, check for option like "vertical sync" and activate them, look in your video drivers and such.
I think there are also some issues with double buffering and activating vertical sync.

Not a very useful post, but at least now you have one name for the problem

Good luck
 
Old 12-03-2003, 01:12 PM   #13
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,219

Rep: Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627Reputation: 2627
No offence, Hiper, but you're not correct. Here's the deal.

NTSC countries have 60Hz power, alternating current. NTSC signals, therefore, are composed of two sets of horizontal lines, called fields. One field shows every even line of the image; the other shows every odd line of the image. How often do we switch between fields? 60 times per second. Televisions look smooth and uniform because their images take time to fade, and one field therefore remains onscreen when the TV switches to the next. Watch an NTSC signal on a computer monitor, however, and it's normal to see where the fields are.

PAL countries have 50Hz power. The numbers are different but the same principals apply.

There are various "deinterlacing" algorithms that will show an interlaced signal on a progressive monitor without showing these artifacts. In Xine, you turn them on by pressing "i". Using MPlayer? Specify one on the command-line ("mplayer -vf help").

Last edited by dugan; 12-03-2003 at 01:54 PM.
 
Old 12-03-2003, 01:37 PM   #14
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Original Poster
Rep: Reputation: 37
dugan: Thank-you. You are spot on with this. I wonder why it's not enabled by default, and why I've never seen it mentioned before.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
poor sound quality slackware_03 Linux - Distributions 10 09-23-2004 04:17 PM
Poor display quality in Linux heesi Linux - Hardware 5 09-17-2003 11:12 PM
Poor VHS quality niidea Linux - Hardware 8 09-16-2003 07:26 PM
Poor TV Card video quality fourwood Linux - Software 5 09-16-2003 11:59 AM
two soundcards and poor sound quality joemamma Linux - Hardware 0 02-23-2003 11:00 PM


All times are GMT -5. The time now is 06:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration