LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-27-2007, 04:23 PM   #1
moljac024
Member
 
Registered: May 2007
Location: Serbia, Europe
Distribution: Arch Linux
Posts: 54

Rep: Reputation: 15
plugging in headphones or speakers doesn't disable my laptop's built in speakers


When i plug in my speakers or headphones in the jack on my laptop i expect the laptop's own small speakers to stop playing sound. However i get double sound output, both through the plugged in headphones/speakers and the laptop's speakers. Is this normal laptop behavior ? I don't think it should be... I'm running fedora 8 with KDE, pulseaudio and Kmix. How could i fix this ?
 
Old 11-28-2007, 10:48 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
It is a hardware function to disable the laptop speakers. When you poke the speaker plug in, it should open the circuit to your laptop speakers. This has nothing to do with the OS.

Are you sure you are plugging in the speakers in the correct hole? You might need to look in the hardware documentation to verify.
 
Old 11-28-2007, 11:20 AM   #3
moljac024
Member
 
Registered: May 2007
Location: Serbia, Europe
Distribution: Arch Linux
Posts: 54

Original Poster
Rep: Reputation: 15
It's not a hardware malfunction as i checked another laptop of the same model and it does the same thing....so must be two sound controllers or something like that...

Last edited by moljac024; 11-28-2007 at 11:28 AM.
 
Old 11-28-2007, 11:40 AM   #4
kotnik
Member
 
Registered: Nov 2004
Location: Novi Sad, Serbia
Distribution: Debian, Slackware, Gentoo, openSuSE
Posts: 254

Rep: Reputation: 31
Well, there are some laptops (as mine is) where nothing happens if you plug headphones in. And I've heard that 'that other' operating system doesn't have that problem. I never had anything on my laptop except GNU/Linux, so I can't confirm that. But, when I plug headphones, speakers are still on. I just got used to it
 
Old 11-28-2007, 03:13 PM   #5
moljac024
Member
 
Registered: May 2007
Location: Serbia, Europe
Distribution: Arch Linux
Posts: 54

Original Poster
Rep: Reputation: 15
The other laptop i tried it on was running that other OS I guess it's laptop related...thanks, though!

Last edited by moljac024; 11-28-2007 at 03:14 PM.
 
Old 12-08-2007, 08:49 PM   #6
heffo_j
Member
 
Registered: Jan 2005
Location: Caboolture, Oz
Distribution: Deepin 2013 64bit
Posts: 142

Rep: Reputation: 16
Hi there,

this is a perennial problem, depending on the thoroughness of the kernel testers I believe. I solved this With ALSA driver 1.0.14 and an older kernerl. I was able to get all the functions working properly. Since my latest kernel upgrade, and trying an even newer ALSA driver, The problem remains.

I am running Linux Mint on an HPdv2000t series laptop.

IN short, yes it can be finxed. No, my usual trick of updating the ALSA driver did not fix the problem this time.

Cheers
John H
 
Old 12-11-2007, 08:22 AM   #7
kotnik
Member
 
Registered: Nov 2004
Location: Novi Sad, Serbia
Distribution: Debian, Slackware, Gentoo, openSuSE
Posts: 254

Rep: Reputation: 31
I'll try to upgrade my alsa drivers (I use Etch's 1.0.13), and we'll see...

Thanks for the hint Heffo
 
Old 12-11-2007, 10:09 AM   #8
the_ultimate_samurai
Member
 
Registered: Jan 2006
Distribution: debian-lenny
Posts: 37

Rep: Reputation: 15
i have this "problem" on my pc. i like it because i can plug in 2 sets of speakers and have it output to both. the pc had windows but under windows it didnt do this. i just thought it was a cool feature unique to linux (ive been trying to get the two to output as suround sound...not sure if i can but it would be cool)

either way, just mute the audio on your laptop speakers, that will allow it to output exclusively to the pluged in speakers...
 
Old 12-18-2007, 08:42 AM   #9
moljac024
Member
 
Registered: May 2007
Location: Serbia, Europe
Distribution: Arch Linux
Posts: 54

Original Poster
Rep: Reputation: 15
There is a fix for this here http://www.mepislovers.org/forums/showthread.php?t=9446

It says it's for acer laptops but it works on my msi. I now have a headphone switch in kmix and turning it off mutes the laptop speakers.

I also mentioned this in my previous post: This also happens with windows on this laptop model, so it's not a linux bug. Maybe it's a bug that you can't mute the speakers but i believe windows won't let you do it as well....

Last edited by moljac024; 12-18-2007 at 08:46 AM.
 
Old 12-18-2007, 10:38 AM   #10
kotnik
Member
 
Registered: Nov 2004
Location: Novi Sad, Serbia
Distribution: Debian, Slackware, Gentoo, openSuSE
Posts: 254

Rep: Reputation: 31
I'll try this, since my laptop's sound card is snd_hda_intel powered
 
Old 04-12-2008, 04:02 PM   #11
silin
Member
 
Registered: Sep 2005
Location: Germany
Distribution: Mandriva free 2007
Posts: 39

Rep: Reputation: 15
I also have this problem on my Samsung X11 laptop running mandriva one 2007 spring. I have alsamixer v1.0.14rc2. I read somewhere that in alsamixer one can set the headphone jack, but I can't find the way to do this. The info page is also not really enlightening. When I go to the sound mixer under the setting tab I see:

Mix
Caller ID
External Amp
Off-hook

Is any of these related to the issue. My own playing around a bit didn't make a difference on anything. Does anyone know what could be done to solve the problem?

Last edited by silin; 04-12-2008 at 04:05 PM.
 
Old 02-18-2009, 10:24 AM   #12
Zibi1981
Member
 
Registered: Dec 2006
Location: Poland
Distribution: Arch Linux, Mandriva
Posts: 52

Rep: Reputation: 15
I also have this problem on my MSI MegaBook GX600P. My audio chip is using snd_hda_intel module and is Sound Blaster compatible. At the moment I'm using kernel version 2.6.28.4 and ALSA ver. 1.0.19. Every time I plug-in my headphone on my Arch Linux machine, I can hear voice from both, the built-in speakers and the headphones. This problem doesn't exist on Vista.
Any help appreciated
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Headphones Don't Override Speakers tsunamikitsune Ubuntu 1 04-11-2007 11:35 PM
Sound from speakers not from headphones crimsontide Linux - Hardware 2 12-21-2006 09:55 AM
Laptop speakers off when plug in headphones garyozzy Linux - Hardware 8 02-04-2006 03:44 PM
USB headphones / Speakers ShuttleAU Linux - Hardware 1 04-18-2005 02:48 AM
Can get sound from laptop speakers but not from headphones thetremorchrist Linux - Hardware 4 02-14-2004 04:43 AM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration