-   Linux - Software (
-   -   plugging in headphones or speakers doesn't disable my laptop's built in speakers (

moljac024 11-27-2007 03:23 PM

plugging in headphones or speakers doesn't disable my laptop's built in speakers
When i plug in my speakers or headphones in the jack on my laptop i expect the laptop's own small speakers to stop playing sound. However i get double sound output, both through the plugged in headphones/speakers and the laptop's speakers. Is this normal laptop behavior ? I don't think it should be... I'm running fedora 8 with KDE, pulseaudio and Kmix. How could i fix this ?

camorri 11-28-2007 09:48 AM

It is a hardware function to disable the laptop speakers. When you poke the speaker plug in, it should open the circuit to your laptop speakers. This has nothing to do with the OS.

Are you sure you are plugging in the speakers in the correct hole? You might need to look in the hardware documentation to verify.

moljac024 11-28-2007 10:20 AM

It's not a hardware malfunction as i checked another laptop of the same model and it does the same must be two sound controllers or something like that...

kotnik 11-28-2007 10:40 AM

Well, there are some laptops (as mine is) where nothing happens if you plug headphones in. And I've heard that 'that other' operating system doesn't have that problem. I never had anything on my laptop except GNU/Linux, so I can't confirm that. But, when I plug headphones, speakers are still on. I just got used to it :)

moljac024 11-28-2007 02:13 PM

The other laptop i tried it on was running that other OS :D I guess it's laptop related...thanks, though!

heffo_j 12-08-2007 07:49 PM

Hi there,

this is a perennial problem, depending on the thoroughness of the kernel testers I believe. I solved this With ALSA driver 1.0.14 and an older kernerl. I was able to get all the functions working properly. Since my latest kernel upgrade, and trying an even newer ALSA driver, The problem remains.

I am running Linux Mint on an HPdv2000t series laptop.

IN short, yes it can be finxed. No, my usual trick of updating the ALSA driver did not fix the problem this time.

John H

kotnik 12-11-2007 07:22 AM

I'll try to upgrade my alsa drivers (I use Etch's 1.0.13), and we'll see...

Thanks for the hint Heffo ;)

the_ultimate_samurai 12-11-2007 09:09 AM

i have this "problem" on my pc. i like it because i can plug in 2 sets of speakers and have it output to both. the pc had windows but under windows it didnt do this. i just thought it was a cool feature unique to linux (ive been trying to get the two to output as suround sound...not sure if i can but it would be cool)

either way, just mute the audio on your laptop speakers, that will allow it to output exclusively to the pluged in speakers...

moljac024 12-18-2007 07:42 AM

There is a fix for this here

It says it's for acer laptops but it works on my msi. I now have a headphone switch in kmix and turning it off mutes the laptop speakers.

I also mentioned this in my previous post: This also happens with windows on this laptop model, so it's not a linux bug. Maybe it's a bug that you can't mute the speakers but i believe windows won't let you do it as well....

kotnik 12-18-2007 09:38 AM

I'll try this, since my laptop's sound card is snd_hda_intel powered :)

silin 04-12-2008 03:02 PM

I also have this problem on my Samsung X11 laptop running mandriva one 2007 spring. I have alsamixer v1.0.14rc2. I read somewhere that in alsamixer one can set the headphone jack, but I can't find the way to do this. The info page is also not really enlightening. When I go to the sound mixer under the setting tab I see:

Caller ID
External Amp

Is any of these related to the issue. My own playing around a bit didn't make a difference on anything. Does anyone know what could be done to solve the problem?

Zibi1981 02-18-2009 09:24 AM

I also have this problem on my MSI MegaBook GX600P. My audio chip is using snd_hda_intel module and is Sound Blaster compatible. At the moment I'm using kernel version and ALSA ver. 1.0.19. Every time I plug-in my headphone on my Arch Linux machine, I can hear voice from both, the built-in speakers and the headphones. This problem doesn't exist on Vista.
Any help appreciated :)

Stéphane Ascoët 07-13-2017 06:01 AM

Now get this problem too
It was working flawlessly until yesterday, when I upgraded from Debian Wheezy to Devuan Jessie and now I can't find any solution anywhere on the Web... Would I be forced to disconnect internal speaker cable?

kilgoretrout 07-13-2017 07:46 AM

This may be solvable using the pulse audio volume control. If it's not installed already, install it with:


# apt-get install pavucontrol
then launch the application, click on the "Output Devices" tab and see if you can mute the speakers there.

Stéphane Ascoët 07-13-2017 08:01 AM

Not sure I'm using Pulse
Thanks, but when I launch it in command line or in X it tells me there isn't any Pulse server... and I didn't find any reliable way to know witch sound server the system is using

All times are GMT -5. The time now is 05:06 PM.