LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-16-2003, 08:08 AM   #1
Anmar
Member
 
Registered: Mar 2003
Location: Earthan
Distribution: UBUNTU | Linux
Posts: 213

Rep: Reputation: 30
Question Playing Audio CDs


Well,,,I installed Mandrake 8.2 some months ago and then alternatively
installed Mandrake 9.0,Red Hat 8.0, And Finally Red Hat 8,2

The problem is I never played an audio cd in any of these cool systems,

I just didn't k'now how to play it.

I tried many many time to do it but I couldn't . SO,,,

CAN ANYONE HELP PLEASE ?????
I REALLY LIKE MUSIC,,, I NEED THEM.

I'll Be Thanking.



 
Old 03-16-2003, 08:38 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
1) mplayer cddb:// -cdrom-device /dev/hdX

2) load xmms, check the settings in the cd audio plugin are correct (check them against /etc/fstab if you don't actually know where the cdrom is conencted to your system and make sure that the plugin is enabled. then just go to play an entire directory and choose the directory where you mount the cd drive, should play.

3) loads of others.
 
Old 03-16-2003, 09:35 AM   #3
Anmar
Member
 
Registered: Mar 2003
Location: Earthan
Distribution: UBUNTU | Linux
Posts: 213

Original Poster
Rep: Reputation: 30
I K'NOW.
I saw the steps..They are not enough...

I said please try to simplify the steps
I made somethingt made xmms display the track list and play the tracks.
But I couldn't hear anything.

WHAT EXACTLY SHOULD I DO ?
 
Old 03-16-2003, 10:10 AM   #4
silver810212
LQ Newbie
 
Registered: Mar 2003
Posts: 8

Rep: Reputation: 0
have you insert audio line?

i have not it,but how can i play cd like window media player?it play cd no need audio line.
 
Old 03-16-2003, 10:14 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
if it loaded the trackllistings and all that then as silver7356895634 said, make sure you have a sound cable coming from the drive to your sound card. linux does not yet support direct audio extraction (personally i think it's a horrible waste of cpu power anyway...) if you do have the cable then use a mixer like aumix or xmixer or i think kmix under kde, and check the volume levels.
 
Old 03-16-2003, 10:23 AM   #6
Anmar
Member
 
Registered: Mar 2003
Location: Earthan
Distribution: UBUNTU | Linux
Posts: 213

Original Poster
Rep: Reputation: 30
If Window media player doesn't need an audio line,,,Why should we?
I mean I don't think it's the breaking problem here...Come on people.I'll be making a huge project for nothing...I'm sorry but it seems to me like this.
Anyways,,,I'll just try
Thanks you guys.
 
Old 03-16-2003, 11:04 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
what? aiether you have a cable or you don't... this isn't a suitable palce to start trying to challenge Linux developement... it's a pretty petty thing... have you got the cable or not?
 
Old 03-16-2003, 12:10 PM   #8
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
I use mandrake 9.0 and KDE as my gui.

to play audio cd's, I have to make sure that kscd or grip are pointing at the correct device.

Try opening kscd, then click on the button that has a hammer/screwdriver image on it, then at the bottom of the subsequent dialogue box, there is a box marked "cdrom device". I have to put /dev/scd0 in it and click apply. Though you would have to sus out what your system is calling the cd playing device, albeit a cdrom or cdrw - one of my problems was that I have a dvd and cdrw, my dvd is labelled as cdrom on the desktop, but the system see's it as "hdb" and the cdrw is called cdrom2 on the desktop, but scd0 by the system.

The bit about having an audio cable, relates to which device is connected to the soundcard/chip, I understand that wind0w$ media player picks it's sound imput via the ide cables (well, that's how it was explained to me) whereas linux needs an audio cable from the device to the card/chip. My cdrw is the one that has the cable, and while someone told me that some soundcards can have more than one device connected, I haven't bothered to open the box to see.

The "pointing the app at the correct device" that I have mentioned above should work for kscd and grip - though I had to "enable freedb" for kscd to give me a full song names and everything tracklist (instead of a "audio cd track 1 4:30 type listing).

regards

John
 
Old 03-16-2003, 12:20 PM   #9
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
I also found XMMS to be a tricky little f****r to get going.

To point that in the right direction, I have to open it, then click "load playlist" and when the window is open, right click on the "player" and click "play directory", a filetree type view of possible directories comes up, and I have to select /dev/scsi/host0/bus0/target2/lun0 cd in the "selection" box and then ok. That usually gets me a track list and the ability to play a disc.

Though sometimes I have to the stuff above to get the file tree, then select /mnt/cdrom2 and then I get the play list.

I suspect that all this is to do with xmms being a vvv clever bit of software (too clever for a tit like me to get sorted easily), but after quite a few questions, I got it sorted.

Oh, and make sure that sound levels are turned up - e.g. kmix - as I understand that some distro's are muted by default.

Hope these help.

regards

John
 
Old 03-16-2003, 02:35 PM   #10
TwistedCranium
LQ Newbie
 
Registered: Jan 2003
Distribution: RedHat 7.3
Posts: 11

Rep: Reputation: 0
Audio CDs, RedHat 7.3 and Autostart

In the installation of RedHat 7.3 that I just installed I wasn't able to play audio CD's as any user other than root. I got a stalled player in kscd and in xmms. I examined the running processes and killed the autostart process and I was then able to play audio CDs.

I then went to the package manager to kinda find out where the autostart files are looking for a readme or something, and in the info on the package manager it recommended adding something to a file in etc. I haven't done that yet or anything else since this is my first setup of linux (newbie actually).

Check to see if you have autostart running, note whether it works in root only, and that is probably worth checking into.

((Linux, to me at least, seems to be a learning process, and that's what we're all in it for))
 
Old 03-16-2003, 05:26 PM   #11
Anmar
Member
 
Registered: Mar 2003
Location: Earthan
Distribution: UBUNTU | Linux
Posts: 213

Original Poster
Rep: Reputation: 30
bigjohn,,,When I right click the play button to select the directory that I you put "/dev/scsi/host0/bus0/target2/lun0 cd",,,,,There was no "/dev/scsi" folder,
I mean the path was not right in my system,

Actually I use Gnome as my gui,Don't k'now if there are some differants
So what to do ?
 
Old 03-16-2003, 05:29 PM   #12
Anmar
Member
 
Registered: Mar 2003
Location: Earthan
Distribution: UBUNTU | Linux
Posts: 213

Original Poster
Rep: Reputation: 30
And if KSCD is better than xmms in reading cds,,,Where to find it.
I didn't even heared about it.
Any link,site, or an uploaded file, Please ?
 
Old 03-17-2003, 03:51 AM   #13
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
The kscd is in KDE, but if you are using gnome as your gui (not being a dead rat user, I forget that they use gnome by default) use "grip", it's a cd player as well as a cd ripper.

I am presuming that you should find it in a multimedia or sound directory from your start bar. Then you follow similar steps to point it toward your device (hence you will need to try and find out what your system calls your cd playing device) - it just happens that I installed grip as well as kscd and xmms - and it's not a case that kscd is better, I just found it easier to configure.

If you look here you will find a thread that 322bnh started for the same problem (admittedly using mandrake), but it spells out in a clearer way some of the directions that I took.

regards

John
 
Old 03-17-2003, 04:20 AM   #14
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
Just as a bit of digging around, I have logged out of kde and into gnome - the problem being that because I use mandrake, I still get a "mandrakised" version of the menu and when I look in the "gnome menu" I can't find grip either, but in the top line you have a console/shell/terminal/whatever the correct name is (it's the icon that looks like a tv screen) and if you open it, and when you get the $ prompt, just type [grip] and enter (don't type the square brackets/parenthesis/whatever you call them) grip will open, you will have to minimise the console/shell/terminal/whatever the correct name is, but under the "config" tab, is where you will find the input box for your device.

Oh, and I use kde because it's default with mandrake and personally I find it easier/more straight forward, but as you use red hat, you would have to surf for advice as how you could change, if you wanted to (you see I also use opera as my browser as I find it faster, and I prefer the look/how it works to mozilla).

Anyway, you will still have to dig round and find out what your system calls your cd playing device, and then try my suggestion above - I have a disc playing as I type this and that was by changing the /dev/cdrom in the device box to /dev/scd0 - but you system/distro hence you couldn't find the "scsi" on the file tree with xmms.

maybe this helps??

regards

john
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Playing audio cds (again...sorry) Oholiab Slackware 13 10-16-2005 03:26 PM
Playing audio CDs evilmonkey Linux - Software 7 11-28-2004 10:16 PM
playing audio cds with mplayer foustware Linux - Software 6 10-27-2004 09:21 PM
Playing audio cds iantri Slackware 5 07-25-2003 05:10 PM
playing audio cds chlee Linux - Software 4 06-08-2003 10:00 AM


All times are GMT -5. The time now is 10:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration