LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-13-2007, 09:01 PM   #1
gentoonix
LQ Newbie
 
Registered: Aug 2007
Posts: 3

Rep: Reputation: 0
Pkg-config error during install


checking for BASE_DEPENDENCIES... configure: error: The pkg-config script could not be found or is too old. Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config. <<< this is the error if more info is needed let me know ... the program im attempting to install is GTK ... but for some reason its not picking up my pkg-config ... any help will be appreciated
 
Old 08-13-2007, 09:16 PM   #2
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 964

Rep: Reputation: 34
which distro? it is easy enough to install...
 
Old 08-14-2007, 04:05 AM   #3
gentoonix
LQ Newbie
 
Registered: Aug 2007
Posts: 3

Original Poster
Rep: Reputation: 0
this is going to sound crazy ... but!

the distro isnt linux ... in fact it is Mac Os x ... but it is unix nonetheless ... so the rules still apply ... but bleh ... dont like hate on me for using mac ... i do have a gentoo box ... but yea ... it is mac ... blah!
 
Old 08-14-2007, 06:37 AM   #4
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 964

Rep: Reputation: 34
http://pkg-config.freedesktop.org/wiki/

wow, it is amazing what i can find using google...
 
Old 08-15-2007, 12:10 AM   #5
gentoonix
LQ Newbie
 
Registered: Aug 2007
Posts: 3

Original Poster
Rep: Reputation: 0
thats where i downloaded the PKG from ...

google is my god ... for everything ... my linux boxes homepages are www.google.com/linux ... im not an idiot ... cmon now ... that wiki doesnt tell me anything ... other than it can be installed on winblows and Mac Os x ... which i already knew ... i posted my configure error ... i have the packages already installed ... its just not locating them ... so instead of attempting to laugh at me ... some advice would actually be nice ... if i wanted to hear someone laugh ... id post "windows vista is god" in here ... but we all know that isnt true
 
Old 08-15-2007, 12:34 AM   #6
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 964

Rep: Reputation: 34
just add the path to the ./configure <parameters> like --with-/usr/lib/pkgconfig
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install ethereal, I get the error: 'pkg-config --modversion glib-2.0' retur abefroman Linux - Security 5 07-09-2007 12:09 PM
canīt install pkg-config?? synergy2 Linux - Newbie 1 06-17-2006 02:12 AM
pkg-config error hotstyle765 Linux - Software 6 01-31-2005 04:46 PM
pkg-config error. eye Linux - Software 2 08-29-2003 11:01 AM


All times are GMT -5. The time now is 07:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration