LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-05-2005, 10:00 AM   #1
CooManChu
Member
 
Registered: Dec 2004
Location: Chicago, IL
Distribution: Ubuntu 10
Posts: 46

Rep: Reputation: 15
pkg-config and glib: Uninstalling Old and Installing New


Hi,

I'm installing the latest GTK+ version and it's dependencies. I have earlier version of the dependencies and they are conflicting with the new ones when I try to install them (apparent from messages I get during configuration and installation).

These earlier versions would have to be from my Red Hat 9.0 distribution, so I don't know much about them. I could find the directories where they exists, but I'd like to be sure to completely clean them off. There must be a cleaner way of removing them.

How do I locate a particular component (like pkg-config or glib) and completely clean it off so that I can install the new version?

Thanks for any help.
 
Old 09-05-2005, 10:48 AM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,525

Rep: Reputation: 177Reputation: 177
"How do I locate a particular component (like pkg-config or glib) and completely clean it off so that I can install the new version?"

The location of all of the components is stored in the rpm data base. So you completely clean the package by removing the package using rpm:

rpm -e glib

Since you know you will have dependency problems you first test the removal:

rpm --test -e glib

That gives you the dependency errors. Then you test removing the dependencies. Eventually you end up with a tree of everything that needs to be removed in order to remove glib. See:
man rpm

---------------------------
Steve Stites
 
Old 09-05-2005, 07:03 PM   #3
CooManChu
Member
 
Registered: Dec 2004
Location: Chicago, IL
Distribution: Ubuntu 10
Posts: 46

Original Poster
Rep: Reputation: 15
Thanks - Since I'm removing glib to install the newest version, do I really need to worry about the dependency issues?

Along the same lines, would I need to remake all the packages that use the older glib after the new one is installed? There are quite a few and nearly all the dependencies came with my distribution, but I do have the source CD's in addition to the install CD's.

Scott
 
Old 09-06-2005, 09:40 AM   #4
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,525

Rep: Reputation: 177Reputation: 177
"Since I'm removing glib to install the newest version, do I really need to worry about the dependency issues?"

Partially. Some of the dependencies may have to be upgraded to a later version to remain compatible with the latest glib version.

"Along the same lines, would I need to remake all the packages that use the older glib after the new one is installed? "

Probably not.

----------------------
Steve Stites
 
Old 09-06-2005, 02:36 PM   #5
CooManChu
Member
 
Registered: Dec 2004
Location: Chicago, IL
Distribution: Ubuntu 10
Posts: 46

Original Poster
Rep: Reputation: 15
Thanks Steve. Well, this will probably turn into a nice learning experience, so I'll get started... : )
 
Old 09-06-2005, 03:16 PM   #6
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
If you're trying to remove gtk-1.2 to install something like 2.6 then don't bother because they are totally different libraries that can happily co exist and you don't need to remove 1.2 before installing a 2.x version.
 
Old 09-06-2005, 03:35 PM   #7
CooManChu
Member
 
Registered: Dec 2004
Location: Chicago, IL
Distribution: Ubuntu 10
Posts: 46

Original Poster
Rep: Reputation: 15
Well, actually the problem I'm trying to get around is with glib. I can install it just fine, but then when I go to atk (part of gtk) and install it, the atk config haults because it sees that I have glib 2.8.3 and 2.0. The message I get says to remove the older glib (or edit a resource file, which I didn't want to do).

The whole thing started mainly because I simply need gtkcombobox.h and gtkcelllayout.h so that the gtk-meta process can build gtk. My version of glib is old enough to not have these two header files.

I'm open to any suggestions, but I'm trying to keep things as clean and tidy as possible if it doesn't cause too much extra work.

Scott
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install ethereal, I get the error: 'pkg-config --modversion glib-2.0' retur abefroman Linux - Security 5 07-09-2007 11:09 AM
Problem installing Bluefish. pkg-config missing Rodotheos Linux - Software 5 04-15-2005 04:54 AM
installing pkg-config minm Linux - Software 1 08-23-2004 11:54 AM
Installing Glib, ATK, GTK, Pkg Config, and Pango! LinuZ Linux - Newbie 9 10-26-2003 02:58 PM
installing pkg-config...where did it go?!?!? crispy Linux - Newbie 1 10-23-2003 09:45 AM


All times are GMT -5. The time now is 09:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration