i was trying to ./configure a program and i got this error...
checking for pkg-config... no
*** The pkg-config script could not be found. Make sure it is
*** in your path, or set the PKG_CONFIG environment variable
*** to the full path to pkg-config.
*** Or see 'the web address.. i cant paste it cuz i dont have 5 posts' to get pkg-config.
configure: error: Library requirements (
) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
i then went to the link and downloaded and installed the pkg-config ... but i downloaded it to my 'home' dir and just installed it there .. so the directory is ' /home/sinXposed/pkgconfig-0.15.0' .. i tried to ./configure again and it gave me the same error .. do i need to install pkconfig to another folder.. or can i change something so where the link is to where i installed it to.
suse 9.2 ... im running GNOME 2.6
linux:/home/sinXposed/Documents/gTweakUI-0.4.0 # echo $PKG_CONFIG_PATH
in that folder there is like 10 .pc files ... like gaim gconf .. etc ... if it helps at all
check with Yast and make sure you have pkg-config installed, according to configure you don't have it ( notice it is asking for the PKG_CONFIG env. variable not PKG_CONFIG_PATH) or type "pkg-config" in a terminal, if you get a command not found error, most likely you are missing it. you can compile it (pkg-config) from source, but you need to install it somewhere that the system can pick it up ( or set your environmental variables to point to it - there are always multiple ways of doing things so sorry if I sound a little confusing). The easiest way would be use Yast, if you have to configure it, Suse probably puts it in /opt/gnome ( e.g. ./configure --prefix=/opt/gnome) with all of the rest of gnome.
i downloaded pkg-config ... and then it was in my home dir.. extracted it.. and then ran
im not sure if everything worked or not.. it didnt say ERROR.. but i dont know how its suppose to look.. what does this all mean..
linux:/home/sinXposed/Documents/gTweakUI-0.4.0 # pkg-config
bash: pkg-config: command not found
im retarted guys... sorry
i tried to use YAST .. but to import a file in there it has to be like a .sel .. and i couldnt find pkg-config as an rpm or .sel or anything else besides a .tar.gz ...
when i still search in yast for "pkg" .. nothing shows up
forget that last post.. if i would have searched for 2 more seconds i found a pkgconfig rpm ... but i now get another error..
i went to yast and it shows i have libgnomeui-2.0 installed...
but when i goto /opt/gnome/lib/pkgconfig .. i have a lot of files but libgnomeui-2.0.pc .. can i just download that file somewhere and stick it in there or does it have important info that is signifigant to each comp.. i dont know why it shows that i have it installed in yast but the .pc file isnt there..??
on rpm distro's, packages are split into two parts. you already have the libgnomeui-x.x.x package, it contains the libgnomeui libraries needed by programs to run. there will be another package called libgnomeui-x.x.x-devel - thats the one you need, it will have the headers, pkg-config files, any scripts etc... needed for compiling against the libgnomeui libraries.
edit: for your pkg-config problem above where you did ./configure, make, make install, some distro's don't have /usr/local/bin set in the PATH by default, so even though it was installed the system wouldn't know. echo your PATH and see if /usr/local/bin shows in the list.
i tired to use a libgnomeui devel ifound on rpmfind... and this is what happened..
linux:/home/sinXposed # rpm -ivh libgnomeui-devel-2.6.2-1.i386.rpm
warning: libgnomeui-devel-2.6.2-1.i386.rpm: V3 DSA signature: NOKEY, key ID 30c9ecf8
error: Failed dependencies:
GConf2-devel >= 2.3.0 is needed by libgnomeui-devel-2.6.2-1
ORBit2-devel >= 2.6.0 is needed by libgnomeui-devel-2.6.2-1
esound-devel is needed by libgnomeui-devel-2.6.2-1
esound-devel >= 1:0.2.27 is needed by libgnomeui-devel-2.6.2-1
glib2-devel >= 2.2.0 is needed by libgnomeui-devel-2.6.2-1
gnome-vfs2-devel >= 2.5.3 is needed by libgnomeui-devel-2.6.2-1
gtk2-devel >= 2.2.0 is needed by libgnomeui-devel-2.6.2-1
libart_lgpl-devel >= 2.3.8 is needed by libgnomeui-devel-2.6.2-1
libbonobo-devel >= 2.3.6-2 is needed by libgnomeui-devel-2.6.2-1
libbonoboui-devel >= 2.3.6 is needed by libgnomeui-devel-2.6.2-1
libglade2-devel >= 2.0.0 is needed by libgnomeui-devel-2.6.2-1
libgnome-devel >= 2.2.0 is needed by libgnomeui-devel-2.6.2-1
libgnomecanvas-devel >= 2.0.0 is needed by libgnomeui-devel-2.6.2-1
libgnomeui = 2.6.2 is needed by libgnomeui-devel-2.6.2-1
libxml2-devel >= 2.5 is needed by libgnomeui-devel-2.6.2-1
pango-devel >= 1.2.0 is needed by libgnomeui-devel-2.6.2-1
zlib-devel is needed by libgnomeui-devel-2.6.2-1
thanks for the paitance and help all..
whats the difference between all the
and all the other versions?
which should i be running since i just have a 32bit 1.2GHz processor ... basically its a typical stock machine...
would that be apart of all the problems im having?
i'm almost positive i have i386 installed... and what would you guys suggest the best distro of linux is for basically newbies..
This means that the libraries have dependencies that need installed before it can be.
You'll need to use something such as Yun to install the package
personally I don't recommend rpmfind for a package that comes with a distro like this..
I'd try to either use Yast or look on your install cd's/dvd and get the package, use Yast to install it.
you probably have i386 installed by default, i586 will work for you also with that processor ( and i686).
Thank you kindly. This information is very usefull for me. Great site! Thanks again!
i am trying to compile pfg-config-0.22 for arm9 board . the native system im working on is fedora-2.6.21
i have glib-2.17.3 already installed in a path /root/usr and while ./configure i give --prefix=/root/usr
now when i try to build pkg-config-0.22 i get the error
checking for i686-linux-gcc... (cached) arm-linux-gnu-gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether arm-linux-gnu-gcc accepts -g... (cached) yes
checking for arm-linux-gnu-gcc option to accept ISO C89... (cached) none needed
checking dependency style of arm-linux-gnu-gcc... (cached) gcc3
checking for arm-linux-gnu-gcc option to accept ANSI C... none needed
checking for a BSD-compatible install... /usr/bin/install -c
checking for extra flags to get ANSI library prototypes... configure: error: cannot run test program while cross compiling
See `config.log' for more details.
configure: error: ./configure failed for glib-1.2.8
could anyone help me solve this issue .
|All times are GMT -5. The time now is 07:46 PM.|