LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-30-2006, 11:30 PM   #1
joseph_k
Member
 
Registered: Aug 2001
Location: North Dakota (USA)
Distribution: Ubuntu
Posts: 43

Rep: Reputation: 15
phpMyAdmin: you have chosen to open PHTML


I upgraded to Ubuntu 5.10, and I've been regretting it ever since. To make a long story short, a bunch of programs stopped working.

When I go to (the previously working) 127.0.0.1/phpMyAdmin, I get prompted to Open or Save a PHTML file. Why am I being prompted for this and how do I fix this?

As per another thread, I tried adding this to apache2.conf and restarted apache:
AddType application/x-httpd-php .phtml

But that didn't work.
 
Old 01-31-2006, 03:06 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,962

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Taking a look at the installation directory of phpMyadmn I didn't found any .phtml files. So edit your httpd.conf and look for something similar to these lines:
Code:
LoadModule php4_module        modules/libphp4.so
AddType application/x-httpd-php  .php .phtml
If you use php 5.x, then it should be: LoadModule php5_module modules/libphp5.so
 
Old 05-27-2010, 04:08 PM   #3
pe7er
LQ Newbie
 
Registered: May 2010
Distribution: Ubuntu
Posts: 2

Rep: Reputation: 0
I tried to edit my httpd.conf, reinstalled phpmyadmin, php5, apache2 (and of course rebooted my system & restarted Apache) but nothing worked.

Finally I read a tip at ubuntuforums.org which said "empty your FireFox browser cache", which worked!

From now on I will check weird issues like this with a second browser (e.g. Opera) first...

Last edited by pe7er; 05-27-2010 at 04:12 PM.
 
  


Reply

Tags
phpmyadmin


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Video BIOS modes for chosen depth nutthick Slackware - Installation 3 07-20-2005 11:09 AM
I810(0) No video BIOS for chosen depth bpellet314 Linux - Newbie 2 12-25-2004 02:13 PM
Governments which have chosen opensource newpenguin General 1 10-02-2003 07:49 PM
lilo hangs when other OS is chosen tsoroka Linux - General 1 02-01-2002 03:28 AM
lilo hangs when other OS is chosen tsoroka Linux - Software 0 01-31-2002 09:26 PM


All times are GMT -5. The time now is 12:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration