LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-10-2004, 11:16 AM   #1
kaplan71
Member
 
Registered: Nov 2003
Posts: 716

Rep: Reputation: 39
php page will not load


HI there --

I am running Apache server 1.3.31 with PHP 4.3.8 installed from source. I have followed the directions in installing the php.ini file in the default directory as well as confirmed the additions to the httpd.conf file. Apache has been restarted after the changes were made.

When I type in the URL for a php file, I get the source code of the file on the screen, but not the web page it is supposed to display. What should I check for and change to correct this? Thanks.
 
Old 09-10-2004, 11:34 AM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi

there is php-module for apache,
u need to install that
which OS u r used

regards
 
Old 09-11-2004, 06:36 AM   #3
netboy_541
Member
 
Registered: Jul 2003
Location: Hamilton, OH
Distribution: Redhat 9, SuSE 10.1 & 10.2, Kubuntu
Posts: 173

Rep: Reputation: 30
make sure you have install the php libraries for apache. I had this same problem and it about drove me crazy.

make sure you install libphp.

another thing you will need to do is go into httpd.conf and set it to parse the *.php files as pages and run them instead of displaying the code..
 
Old 09-11-2004, 07:15 AM   #4
jamaas
Member
 
Registered: Mar 2004
Location: Melton Mowbray England
Distribution: Ubuntu
Posts: 37

Rep: Reputation: 15
having same problem

I'm having the same problem and just about to crack up....

How does one check to see if libphp is present and/or available?

If it is not where can I get it for PHP 4.3.8 and Apache 1.3.29 ?

thanks a bunch

jamaas btinternet com
 
Old 09-11-2004, 07:30 AM   #5
netboy_541
Member
 
Registered: Jul 2003
Location: Hamilton, OH
Distribution: Redhat 9, SuSE 10.1 & 10.2, Kubuntu
Posts: 173

Rep: Reputation: 30
if you have apt-get installed, it's a breeze


apt-get update

apt-get install phplib

away it goes...

make sure you are super user first tho..

if you don't have apt-get -- go to http://apt.freshrpms.net

if you are running RH9, you may have to track it down yourself...
 
Old 09-11-2004, 07:36 AM   #6
jamaas
Member
 
Registered: Mar 2004
Location: Melton Mowbray England
Distribution: Ubuntu
Posts: 37

Rep: Reputation: 15
fixed it ....

Thanks a bunch, help is appreciated and I finally cracked it ....

The book I am using failed to mention one little step ..... which I did find on the PHP web page......

but I'm not bitter or annoyed ...

I might be back for more....

Jim
=====
11. make
12. make install

If you decide to change your configure options after installation,
you only need to repeat the last three steps. You only need to
restart apache for the new module to take effect. A recompile of
Apache is not needed.

Note that unless told otherwise, 'make install' will also install PEAR,
various PHP tools such as phpize, install the PHP CLI, and more.

13. Setup your php.ini file:

cp php.ini-dist /usr/local/lib/php.ini
 
Old 09-11-2004, 07:37 AM   #7
netboy_541
Member
 
Registered: Jul 2003
Location: Hamilton, OH
Distribution: Redhat 9, SuSE 10.1 & 10.2, Kubuntu
Posts: 173

Rep: Reputation: 30
ahh yes --

when building from source, that is a requirement!!

I can't belive a book would forget to mention that... LOL

well there you go!

Take care...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
firefox fails to load page mikemrh9 Linux - Software 2 12-30-2004 12:48 PM
linux doesn't load page with - jizzyjesus Linux - General 17 09-25-2004 02:17 AM
page won't load (apache2+php on TSL 2.1) restless Linux - Software 1 08-13-2004 09:54 PM
Web page does not load CyberEd Linux - Newbie 3 11-05-2003 12:56 AM
page load emulation aizkorri Linux - Software 4 06-25-2003 04:55 AM


All times are GMT -5. The time now is 03:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration