LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-28-2004, 08:17 PM   #1
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Rep: Reputation: 51
php not taking arguments when passed through URLs


I'm migrating a webserver. The new server is up and running with apache 2.0.40-21.9 and php 4.2.2-17.2. The pages seem to be working, but when I send an argument to a php script through the URL, the script is not getting the argument. As an example:

http://192.168.0.60/customer_service/report.php
http://192.168.0.60/customer_service...ext=2004_March

both do the exact same thing, when, in fact, they should do something different being that one gets an argument and one doesn't.

Could it be a problem with apache or the apache config? problem with a php config? Something else?

Thanks.
 
Old 03-28-2004, 09:35 PM   #2
Kovacs
Member
 
Registered: Jul 2003
Distribution: FreeBSD 8.2 RELEASE
Posts: 607

Rep: Reputation: 30
Does your new server have register globals turned off in php.ini?
 
Old 03-29-2004, 11:38 AM   #3
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Original Poster
Rep: Reputation: 51
Quote:
Originally posted by Kovacs
Does your new server have register globals turned off in php.ini?
yes. I'm not a php guy at all - Is this causing the problem? Is that what a global is in php?

ahhh... found the old php.ini file & copied it over to the new machine. Everything is working now.

Thanks!

Last edited by BrianK; 03-29-2004 at 12:02 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IPW2200 Make error macro "create_workqueue" passed 2 arguments, but takes just 1 jplev22 Linux - Wireless Networking 2 09-16-2005 11:34 AM
PHP Can't read from passed headers uuplunkeruu Programming 5 03-24-2004 04:38 PM
Can parameters passed to a php be hide ? cjagdish69 Linux - Software 1 11-11-2003 07:09 AM
php variables not being passed on tpat Linux - Software 1 01-11-2003 03:11 PM
PHP -> parsing urls DJFauß Programming 14 08-07-2001 01:33 PM


All times are GMT -5. The time now is 02:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration