LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-29-2003, 02:16 AM   #1
sashhoney
Member
 
Registered: Jul 2003
Distribution: Red Hat, Fedora, Debian
Posts: 85

Rep: Reputation: 15
php mail() problem


hi,
i m facing a small prob while attempting to write a mail client.
i m using different machine as web server and mail server.
dns is configured at web server.
now my problem is when i use mail() function to transfer mails, my mails r not delivered at all.
1)in my /var/log/maillog of web server i can see the entry saying DSN:Service not available
2)/var/log/maillog of mail server says: no mail/vrfy is issued by web server.
3) web server root receives a mess from sendmail which says:
helo >>"webserver name"
501: Invalid domain name

i checked my dns, its working properly.
if i use same machine as web server and mail server it runs properly
but my boss asked me to imp it separately.
i m tryin for 3 days but couldnt figure out any prob in configurtion of any server
thnx in advance
 
Old 09-29-2003, 05:22 AM   #2
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
Re: php mail() problem

Quote:
Originally posted by sashhoney
hi,
i m facing a small prob while attempting to write a mail client.
i m using different machine as web server and mail server.
dns is configured at web server.
now my problem is when i use mail() function to transfer mails, my mails r not delivered at all.
1)in my /var/log/maillog of web server i can see the entry saying DSN:Service not available
2)/var/log/maillog of mail server says: no mail/vrfy is issued by web server.
3) web server root receives a mess from sendmail which says:
helo >>"webserver name"
501: Invalid domain name

i checked my dns, its working properly.
if i use same machine as web server and mail server it runs properly
but my boss asked me to imp it separately.
i m tryin for 3 days but couldnt figure out any prob in configurtion of any server
thnx in advance
What have you done in php.ini ? There's a part to configure, to work with external mail-servers. Have a look at that line. Then restart apache and try again ...

Hope this helps,
 
Old 09-30-2003, 05:59 AM   #3
sashhoney
Member
 
Registered: Jul 2003
Distribution: Red Hat, Fedora, Debian
Posts: 85

Original Poster
Rep: Reputation: 15
thnx for the reply daveo
well i will try that but i saw that yesterday.
in php.ini 'smtp' and 'smtp-port' settings can only be configured in Windows env.
anyway i will try that.

there is another prob-
i m using two separate server for authentication-one is NIS and second is LDAP server
i need to write a php script for changing the password.
is there any way to change the password directly from web page?
i will really appreciate if anyone can give me proper idea
 
Old 09-30-2003, 06:06 AM   #4
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
Quote:
Originally posted by sashhoney
thnx for the reply daveo
well i will try that but i saw that yesterday.
in php.ini 'smtp' and 'smtp-port' settings can only be configured in Windows env.
anyway i will try that.

there is another prob-
i m using two separate server for authentication-one is NIS and second is LDAP server
i need to write a php script for changing the password.
is there any way to change the password directly from web page?
i will really appreciate if anyone can give me proper idea
Sorry can't help you with this one, try droping your question in www.phpfreaks.com forums ... good luck ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP Mail() Problem w/ Sendmail jusme Linux - Software 6 08-18-2012 03:35 PM
Squerril mail login.php path problem tkmuthuvel Linux - Networking 1 10-13-2005 11:26 PM
php mail problem czarherr Programming 4 09-08-2005 12:03 AM
coding problem on php auto send mail after a period akamaru607 Programming 12 09-01-2005 08:48 AM
Cannot send mail with mail() command in PHP 4.3.4, Apache 2.0.48, Mandrake Linux 10 arcanum Linux - General 3 06-27-2004 07:06 PM


All times are GMT -5. The time now is 06:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration