LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-20-2003, 05:15 PM   #1
PaulC24
LQ Newbie
 
Registered: Apr 2003
Location: Brighton, England
Distribution: RedHat 7.2
Posts: 8

Rep: Reputation: 0
PHP 4.3 accessing Interbase 7 on Linux


Hi Guys,

A PHP oddity that I have not been able to get to the bottom of.

This script runs without error on a Windows 98 platform BUT not on Linux.

I am running Linux RedHat 7.2 with PHP 4.3.1 (which I rebuilt yesterday to include InterBase support). My webserver is Apache 1.3.

I have some PHP scripts writing entries - successfully - into an InterBase 7 database (on Linux). CREATE TABLE, INSERT and UPDATE commands all work as records are appearing.

However, when I run a PHP script that issues a simple "SELECT *", the web-browser returns a "Page not found" screen. Through some trial and error, I have determined that it is this statement that is causing the problem.


This does NOT work:

$dbh = @ibase_connect($baseHost, $dblogin, $dbpass);

if ($dbh == true)
{ $sth = ibase_query ("SELECT * FROM xyz");

... etc.


This does work:

$dbh = @ibase_connect($baseHost, $dblogin, $dbpass);

if ($dbh == true)
{ $sth = ibase_query ("SELECT fieldname FROM xyz");

...etc


Furthermore, selecting more than one field also produces the problem.

I have already tried:

...using an ibase_prepare / execute / commit combination, but this just produces the same error.
...using a table without a BLOB field (mine has one), but the problems persists no matter how simple the table.

Is this a problem with PHP or the database? As I say, all works happily on Windows, and every single example of ibase_query I have seen on the Internet uses the statement SELECT *, so I cannot see that there is a syntax error.

Any help would be greatly appreciated.

Many thanks,

PaulC
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[php] accessing command line dtra Linux - Software 1 04-26-2005 07:19 PM
PHP & InterBase can not create interbase.so vinsky2002 Linux - Software 0 01-12-2005 11:42 PM
Accessing http header in PHP artois_val Programming 1 08-07-2004 10:20 AM
ModPerl 5.6 accessing InterBase 7 on Linux RH 7.2 PaulC24 Linux - Software 0 04-20-2003 05:17 PM
Firebird (or Interbase) and PHP? neillans Linux - General 0 03-07-2003 01:03 PM


All times are GMT -5. The time now is 09:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration