LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-18-2011, 05:45 AM   #1
Mig42
LQ Newbie
 
Registered: Feb 2011
Posts: 5

Rep: Reputation: 0
Personalising vim after fresh install


Hi,

I am having trouble getting my vim settings back after having made a new install of my GNU/Linux distro. I have a copy of my old .vimrc file and a complete recursive directory copy of my old .vim directory.
I have placed the copy of .vimrc and the directory .vim at /home/me/, but I am eg. unable to use my old color files now in /home/me/.vim/colors/

Hints ?
 
Old 02-18-2011, 06:29 AM   #2
redgoblin
Member
 
Registered: Jun 2005
Location: UK
Distribution: Debian
Posts: 189

Rep: Reputation: 41
Are any of the settings from your vimrc taking effect or is it just the colour that's a problem?

Could you post a copy of your vimrc file. You should have a reference to

Code:
colorscheme [name of colorschene]

Last edited by redgoblin; 02-18-2011 at 06:30 AM.
 
Old 02-18-2011, 06:57 AM   #3
Mig42
LQ Newbie
 
Registered: Feb 2011
Posts: 5

Original Poster
Rep: Reputation: 0
Hi again,

it seems that there is only trouble with colours. Other things in my .vimrc like abbreviations do work. I do have the line
Code:
colorscheme zenburn
in my .vimrc but it has no effect and when I do
Code:
:color nameOfScheme
from within .vim I dont get the appropriate results (sometimes depending on what scheme there is change to the colours/highlighting but not the expected ones !)
 
Old 02-18-2011, 07:40 AM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

You mention a new install, does that also mean you have a newer vim version? If so did you look for and change entries that possibly still point to the old vim version? Example:

/usr/share/vim/vim70/syntax/syntax.vim vs /usr/share/vim/vim73/syntax/syntax.vim

Also, where does runtimepath point to? (:set runtimepath).

Hope this helps.
 
Old 02-18-2011, 10:12 AM   #5
Mig42
LQ Newbie
 
Registered: Feb 2011
Posts: 5

Original Poster
Rep: Reputation: 0
:set runtimepath shows
Code:
runtimepath=~/.vim,/var/lib/vim/addons,/usr/share/vim/vimfiles,/usr/share/vim/
vim72,/usr/share/vim/vimfiles/after,/var/lib/vim/addons/after,~/.vim/after
I am not completely sure, but I think it is still the same major version (7.2) as before i installed a new distro. What files related to vim would be candidates to include in them a hardcoding of the version number ?
 
Old 02-18-2011, 10:49 AM   #6
Mig42
LQ Newbie
 
Registered: Feb 2011
Posts: 5

Original Poster
Rep: Reputation: 0
I tried adding a new colour scheme newScheme.vim in /usr/share/vim/vim72/colors/ (added permissions to other for x and r)
and starting vim. The scheme shows up from within vim when toggling using :color, but it has no effect.
 
Old 02-18-2011, 11:11 AM   #7
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

I've just downloaded this zenburn theme and tried it on vi versions 7.0, 7.2 and 7.3 (LFS and Debian) as a normal user and it does not work on my side on Debian.

Ok, this fixed the problem for me: export TERM=xterm-256color.

Weird thing is that LFS has TERM set to xterm and it works, Debian also has it set to xterm and it doesn't work (it does when setting the xterm-256color).

Hope this helps.
 
Old 02-18-2011, 12:11 PM   #8
Mig42
LQ Newbie
 
Registered: Feb 2011
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for the new tip, druuna. It didn't change things, however trying yet another color scheme, vim displayed a message
asking to
Code:
set t_Co=256
in my .vimrc and this made all the colour schemes work.
 
Old 02-18-2011, 12:46 PM   #9
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

I was still interested and just found this, which confirms both our solutions (just noticed you already found the alternative): the The Official Zenburn Page (see the Notes).

Have a nice weekend.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Editor comparison: vim VS vim-lite, Cleaning vim Ruler2112 *BSD 4 04-13-2009 05:26 PM
Personalising Fedora 10 conormacaoidh Linux - Software 3 03-24-2009 08:50 PM
FC6 fresh install won't start from XP CD to install XP 2nd ask_save Fedora 2 11-17-2006 07:23 AM
On a Fresh install of 10.1, the Nforce drivers refuse to install.. K@rl` Slackware 2 02-25-2005 03:55 AM
fresh install (fresh headache) powadha Slackware 2 03-06-2004 02:03 PM


All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration