LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Persistant Nvidia X86 Problems (http://www.linuxquestions.org/questions/linux-software-2/persistant-nvidia-x86-problems-169511/)

deft 04-13-2004 07:11 AM

Persistant Nvidia X86 Problems
 
Hi All,

I am having reoccurring problems problems with my Nvidia X86 driver. I have successfully installed the driver, works fine. ( sometimes ) What is happening is that when I reboot my machine maybe 2 or 3 times, it fails in booting X, and says that it can not find my "nvidia" driver . It then takes me through the RH utility that deals with X, it does not find the "nvidia" driver and it then creates the new X86 file upon probing my Graphics card ( I think ). Here is the /etc/X86/X86config file:


# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Flatron915FT"
DisplaySize 360 270
HorizSync 30.0 - 107.0
VertRefresh 50.0 - 200.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv" <------ ###### I usually change this to nvidia !!!!!!
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 GTS (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


In the secton I have marked above, I replace the "nv" with "nividia" which works fine when I reboot The problems start maybe once or twice in shutting down and restarting. I am at a total loss on this.... Help!

Many thanks in advance for any help..


deft...

rberry88 04-13-2004 07:22 AM

Yes, change the driver from "nv" to "nvidia" and also you need to comment (##) out the last lines about DRI.
It should look like this:
Code:

#Section "DRI"
#Group 0
#Mode 0666
#EndSection

rberry88

deft 04-13-2004 09:10 AM

Thanks rberry88, that appears to have done the trick. I had done everything you said with the exception of commenting out DRI section.

Again, Many thanks.


deft...

rberry88 04-13-2004 09:41 AM

Hey no problem, glad I was able to help.

rberry88


All times are GMT -5. The time now is 11:12 AM.