LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 06-21-2007, 01:58 PM   #1
Yaakov
LQ Newbie
 
Registered: Jun 2007
Posts: 2

Rep: Reputation: 0
"Permissions on the password database may be too restrictive"


I am a new user and I created a new xxx.sh file in the bin directory. When I tried to use it I had a message permission denied. I went to bin and instead of typing “chmod 777 xxx.sh” I typed “chmod 777 *” now when I try to use su I get a message "Permissions on the password database may be too restrictive". As of now I have a session opened as root. I cannot close my computer because I cannot signon as root again.

Does anybody know how or what I need to do to restore to the proper restrictions.
 
Old 06-21-2007, 02:06 PM   #2
Randux
Senior Member
 
Registered: Feb 2006
Location: Siberia
Distribution: Slackware & Slamd64. What else is there?
Posts: 1,705

Rep: Reputation: 54
Quote:
Originally Posted by Yaakov
I am a new user and I created a new xxx.sh file in the bin directory. When I tried to use it I had a message permission denied. I went to bin and instead of typing “chmod 777 xxx.sh” I typed “chmod 777 *” now when I try to use su I get a message "Permissions on the password database may be too restrictive". As of now I have a session opened as root. I cannot close my computer because I cannot signon as root again.

Does anybody know how or what I need to do to restore to the proper restrictions.
If you want to make a shell script executable for the user who wrote it you can just do

chmod +x name

What you did, "chmod 777 *" says "give read, write, and execute permissions to this user, to everyone in the same group as this user, and to everyone in the world, for every file in the world."

You thereby screwed up the permissions on system files and you probably need to reinstall unless someone can give you a shell script to fix all the permissions.

Which distro are you using?

Last edited by Randux; 06-21-2007 at 02:08 PM.
 
Old 06-21-2007, 02:24 PM   #3
SkyEye
Member
 
Registered: Sep 2005
Location: Sri Lanka
Distribution: Fedora (workstations), CentOS (servers), Arch, Mint, Ubuntu, and a few more.
Posts: 441

Rep: Reputation: 40
Welcome to LQ!

Boy, are you in a soup? Yes, you are. I just can't imagine why you had to be such careless.

I assume you did the chmod in /bin/. So that means all the files in /bin are now with the permissions rwxrwxrwx. What a mess! Luckily most binaries in /bin usually have rwxr-xr-x which is equal to 755 (except the links). But su, mount, umount and ping binaries usually have the permissions set to rwsr-xr-x

So these should bring your file permissions back to normal. (There's no easy way to be certain, but I'm pretty sure these following should reverse the changes you did)
Code:
cd /bin
chmod 755 *
chmod u+s su mount umount ping
Next time be careful. Unix systems do what they are asked to do.

Last edited by SkyEye; 06-21-2007 at 02:26 PM.
 
Old 06-21-2007, 03:27 PM   #4
Yaakov
LQ Newbie
 
Registered: Jun 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by SkyEye
Welcome to LQ!

Boy, are you in a soup? Yes, you are. I just can't imagine why you had to be such careless.

I assume you did the chmod in /bin/. So that means all the files in /bin are now with the permissions rwxrwxrwx. What a mess! Luckily most binaries in /bin usually have rwxr-xr-x which is equal to 755 (except the links). But su, mount, umount and ping binaries usually have the permissions set to rwsr-xr-x

So these should bring your file permissions back to normal. (There's no easy way to be certain, but I'm pretty sure these following should reverse the changes you did)
Code:
cd /bin
chmod 755 *
chmod u+s su mount umount ping
Next time be careful. Unix systems do what they are asked to do.
Thank you. I'm back in business.
BTW I was that careless because it is a personal box, so about the permission I could care less.
 
Old 06-21-2007, 04:23 PM   #5
SkyEye
Member
 
Registered: Sep 2005
Location: Sri Lanka
Distribution: Fedora (workstations), CentOS (servers), Arch, Mint, Ubuntu, and a few more.
Posts: 441

Rep: Reputation: 40
Good to hear your problem is solved. Wish you good luck with your Linux experience.

Quote:
Thank you. I'm back in business.
Anytime, LQ is here to help.
 
Old 04-09-2009, 05:55 PM   #6
gumph
LQ Newbie
 
Registered: Apr 2009
Posts: 4

Rep: Reputation: 0
The Beat Goes On

I tried to change the root password from a previous owner. I did this via the init=/bin/sh route. I left the 'New Password' blank and the system seemed to accept this.
I re-booted, entered my Username and Password, and received the message 'permissions on the password database may be too restrictive'. I have since managed to repeat these steps and add a root password but still cannot log on. I have seen your solution but do not know where to type the commands. I have never used Linux before.
Can one not leave the root and user passwords blank?
Thx
Gumph

Quote:
Originally Posted by SkyEye View Post
Welcome to LQ!

Boy, are you in a soup? Yes, you are. I just can't imagine why you had to be such careless.

I assume you did the chmod in /bin/. So that means all the files in /bin are now with the permissions rwxrwxrwx. What a mess! Luckily most binaries in /bin usually have rwxr-xr-x which is equal to 755 (except the links). But su, mount, umount and ping binaries usually have the permissions set to rwsr-xr-x

So these should bring your file permissions back to normal. (There's no easy way to be certain, but I'm pretty sure these following should reverse the changes you did)
Code:
cd /bin
chmod 755 *
chmod u+s su mount umount ping
Next time be careful. Unix systems do what they are asked to do.
 
Old 04-10-2009, 03:14 AM   #7
SkyEye
Member
 
Registered: Sep 2005
Location: Sri Lanka
Distribution: Fedora (workstations), CentOS (servers), Arch, Mint, Ubuntu, and a few more.
Posts: 441

Rep: Reputation: 40
Welcome to LQ!

Quote:
Originally Posted by gumph View Post
I tried to change the root password from a previous owner. I did this via the init=/bin/sh route. I left the 'New Password' blank and the system seemed to accept this.
I re-booted, entered my Username and Password, and received the message 'permissions on the password database may be too restrictive'. I have since managed to repeat these steps and add a root password but still cannot log on. I have seen your solution but do not know where to type the commands. I have never used Linux before.
Can one not leave the root and user passwords blank?
Thx
Gumph
This depends on the security settings of the distribution you are using, but usually you can't have a blank rot password. Even if you could, never do that. Linux/Unix root account is nothing like you have in Windows OSs. Which means the user root have total power to do anything (that includes damage). In a live Linux system sysadmins tend to create a normal user account and work using su and sudo commands. The root account it used only if it's a must. You can apply this practice to desktop Linux systems too. For example I haven't logged into my desktop (running Fedora) ever after I installed. And distros like Ubuntu and Mint have the root account disabled by default. Because security is not something only critical servers need.

That's some advice, which will not fix your problems. So try to boot into the superuser more using GRUB and change your password from there. Giving specific steps is not possible since you haven't mentioned the distribution you are using. But follow the steps in here and see.

Good luck!

PS: I'm assuming that your bootloader is grub, which is the case in most of the common distros.

Last edited by SkyEye; 04-10-2009 at 03:17 AM.
 
Old 04-11-2009, 03:21 PM   #8
gumph
LQ Newbie
 
Registered: Apr 2009
Posts: 4

Rep: Reputation: 0
Thank you SkyEye

I hope the sun is shining in SL. thank you for your welcome and your reply.
The HP2133 netbook on which Linux is installed is brand new. I got it from someone who set it up, installed a root and used password, and sold it to me. My intention is to give it to my girlfriend in a new, pristine condition. Thus I tried to 'undo' the setup passwords of the original buyer. I have never used Linus before. I managed to change the user password, the option to not have a password at all did not seem to exist.
I tried,regretfully, to eliminate the root password, but, as I mentioned, although it seemed to take, the next time I tried to log in, I received the permissions error message.
Since then I returned to the root password area and entered a new password(not the original one though). This also seemed to work and I have since used it to return to protected areas. However, I still have the permissions problem.
The Linus system is SUSE Enterprise SP10.1, if that is what you mean by distribution system. There are only default security settings as nothing has been added or changed on the computer other than this password business. If it is easier I could reinstall SUSE as I have no programs, files, etc to lose. However,it came pre-installed and I have no recovery disc. I believe to download Enterprise would incur an update fee?
AS I mentioned I am a Linux neophyte so words like Fedora, distros(various Linux versions/distributions?), Ubuntu, Mint, superuser mean nothing to me. I do not even know what su means though, from discussion groups, it seems to be a basic term. Grub, I assume, is the early stage boot sequence which, by holding down F2, I can get the blue screen that gives me a choice of normal or Failsafe options and Boot Options where I can write commands. This is how I changed the root password to blank(and later added a root password).
I am sorry but the link you included did not help me as it referred to Fedora which seems as if it is different from SUSE Enterprise so I did not try those solutions(not that I could follow them well)
Thanks for the help
Gumph
 
Old 04-11-2009, 09:21 PM   #9
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.6, Centos 5.10
Posts: 16,324

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Sounds like a re-install would be simplest in this particular case.
JUst FYI, there are various versions (distributions) of Linux, known for short as 'distros', as you guessed.
You could load any one you like. The usual recommendation is to try any of the the top 5 or 10 at www.distrowatch.com. See the list on the right hand side of the page.
For a complete newbie, used to MS, popular recommendations include Ubuntu, Kubuntu, Mandriva, Fedora, Suse etc. See many many threads about this in the Newbies forum here.
Here are a couple of good reads:
http://linux.oneandoneis2.org/LNW.htm
http://rute.2038bug.com/index.html.gz

I would also ask if this is a wise move to give Linux to your gf when you don't understand it yourself? If she doesn't either, then she will be asking you to maintain/fix it regularly....
 
Old 04-12-2009, 01:42 PM   #10
gumph
LQ Newbie
 
Registered: Apr 2009
Posts: 4

Rep: Reputation: 0
Thank you Chris. The 1st link was a good read and has me keen on learning Linux. The second link will be part of that process.
How would I re-install, from where, is there a cost if I want to end up with Suse Enterprise 10?
On the other hand, I am not afraid to try to write commands to reverse the error and correct the permissions problem. I would need to know(at least) how to get to where the commands are to be written and what to write. I am a Linux Newbie but screw us/somehow recover XP on a regular basis.
I have since found something that may be relevant. In the Setup Utility/Security it states: 'Adminstrator Password :Not Installed'. Perhaps my attempt to change the password from blank to something did not work. When I typed the New Password I saw no place holders. I suppose returning to the original root password would be moot.
I assume that Administrator and Root are the same as is, if I have learnt correctly, superuser.
Good point on trying to make my gf a Linux co-pilot before I have taking flying lessons myself. In the interim perhaps I should overwrite(if possible) the Suse Linux I have messed up with XP(sorry if that is offensive in the Linux community). Is it possible? Will Suse be overwritten or remain as a parralel OS? As my HP 2133 has no disc drive, could I connect it to my PC and install XP onto what would be(I think) seen as an external drive?
Thanks again
gumph
 
Old 01-18-2010, 02:41 PM   #11
potillobytes
LQ Newbie
 
Registered: Jan 2010
Posts: 1

Rep: Reputation: 0
Similar issue

I recently took over a small business account that was abandoned by it's former admin. Not having any of the passwords to anything, I used a knoppix live cd to remove the root password.


However, it seems that OpenSuse 10.3 doesn't like having it's password removed, so I am now receiving that same error message: "Permissions on the password database may be too restrictive."

I am trying to contact the former admin but failing that I'm going to need to be able to fix this issue. Any help greatly appreciated!
 
Old 01-18-2010, 02:52 PM   #12
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,652

Rep: Reputation: 536Reputation: 536Reputation: 536Reputation: 536Reputation: 536Reputation: 536
Use the same LiveCD to set it to something instead? (chroot in)

Also check the permissions on /bin/su as said earlier in this topic
 
Old 12-02-2011, 10:32 AM   #13
ComWT
LQ Newbie
 
Registered: Dec 2011
Distribution: Debian
Posts: 2

Rep: Reputation: Disabled
Exclamation Permissions on the password database may be too restrictive

Hi LQ,

I have experienced the same issue on a SLES 11 box and need some extra wheels turning to help figure this out.

Here's what I've done to troubleshoot:

- Compared /etc/passwd and /etc/shadow to a working box (looks the same)

- Compared /bin/* to a working box (looks the same)
#used "ls -l | grep -v 'rwxr-xr-x'"

- Compared /etc/sysconfig/security to a working box (looks the same)

- Mounted the root LV to /mnt in rescue mode (on the failing system) to perform all comparisons

- Mounted the var LV over /mnt/var and reviewed /mnt/var/log/messages
#nothing helpful, all mounts look good, no details about the failure

- Captured the log timestamp (i.e. '17:29:46') for a failed login attempt and
performed a "grep '17:29:4[0-9]' /mnt/var/log/*" to see if there were any
correlated messages in other logs around the same time frame.
No relevant entries were found.

Got any ideas? Your help is greatly appreciated.

Last edited by ComWT; 12-02-2011 at 10:34 AM. Reason: added title - I did not know if it would carry if left blank
 
Old 12-02-2011, 06:34 PM   #14
ComWT
LQ Newbie
 
Registered: Dec 2011
Distribution: Debian
Posts: 2

Rep: Reputation: Disabled
Thumbs up SOLVED: Permissions on the password database may be too restrictive

Well it turns out that corrupt /etc/passwd and /etc/shadow files cause the exact same error.

Mine had carriage returns (CR) in them since they were stored in a git repository on a Windows system and scp'd over.

Running the following command fixed the problem:

dos2unix /etc/passwd /etc/shadow
 
  


Reply

Tags
chmod, mount, permissions, ping, su, suid, umount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Permissions on the password database may be too restrictive" hcgrant Linux - Software 5 05-26-2007 04:27 AM
"Permissions on the password database may be too restrictive" hcgrant Suse/Novell 1 05-23-2007 09:42 AM
permissions on password database too restrictive Intermove Linux - Security 5 06-18-2006 12:00 PM
Open gl programs quit, nvidia driver "permissions are too restrictive." sirbrett Slackware 4 10-26-2004 09:48 PM


All times are GMT -5. The time now is 03:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration