LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-16-2006, 04:34 AM   #1
academik
LQ Newbie
 
Registered: Jan 2006
Posts: 9

Rep: Reputation: 0
permission for FAT32 partition


Hello,

So, I'm a noob, and I just managed to setup a dualboot system with WinXP and SUSE 10.0 on my laptop. Afterwards, I tried to set up a logical partition using the FAT32 filesystem so I can share files between the two OS's. I mounted this partition at /SharedFiles.

Unfortunately, I can only modify the files in this partition (write permission) using root. I tried to change it in Yast and it won't allow me to change my permissions.

My question is: How do I change permissions (or change partition or mount point) to allow wrx on /SharedFiles for all users (so I don't have to log in as root to modify these files)?

Here is my current partition setup:
Device Size Type Mount
/dev/hda1 12.6GB HPFS/NTFS /windows/C
/dev/hda2 2.1GB swap swap
/dev/hda3 15.0GB Linux native /
/dev/hda4 26.0GB Extended
/dev/hda5 16.3GB Win95 FAT32 /SharedFiles

Thanks in advance.
 
Old 01-16-2006, 04:59 AM   #2
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 746

Rep: Reputation: 31
You'll want to mount the fat32 partitions with the "rw" (read/write) option set. By default, most distributions won't set it up this way. Why? Because fat32, on it's own, doesn't have any internal permissions scheme. For Windows users, this isn't something they're used to caring about. For Linux users, this is a headache waiting to happen. Essentially, once mounted rw, there's the potential for anyone to write to it, even somebody down the street who you normally link up with to play a network game, especially if you give them their own account. So, linux has to become a little overprotective, or bad things can happen.

From the distro's point of view, the last thing they want is to make something "easy", then have a hundred ticked off customers call because "linux ruined my windows stuff!" That it's a defect in windows isn't something they'd be likely to convey to an upset user, so they just avoid the problem. The handful of people that might not like linux because of this probably aren't ready for it.

For you, however, you can easily fix this. Just check out the man pages relevant to it:

"man fstab" and "man mount" at the command line should explain it for you.
 
Old 01-16-2006, 05:48 AM   #3
guedellas
Member
 
Registered: Dec 2005
Location: Espaņa
Distribution: Fedora Core 8 + Debian 4.0 + Vista
Posts: 61

Rep: Reputation: 15
I guess that if you add umask=0000 to the line of your /etc/fstab you can get it to rw on your fat32 partition, but it will affect to all the partition, an not to only one directory, as pointed out by scott_R

Something like:
Code:
/dev/hda5 /SharedFiles vfat user,umask=0000 0 0
 
Old 01-16-2006, 06:01 AM   #4
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Just adding another example
Code:
/dev/hda5 /SharedFiles vfat auto,uid=500,gid=502,umask=007 0 0
This make the user with uid 500 the owner and gives him/her as well as members of the group with gid 502 full rights. Other users can't touch it.

Last edited by Wim Sturkenboom; 01-16-2006 at 06:10 AM.
 
Old 01-16-2006, 07:45 AM   #5
academik
LQ Newbie
 
Registered: Jan 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Hey, thanks for the quick replies.

I tried to modify /etc/fstab as above, then :wq and mount -t vfat /dev/hda5 /SharedFiles.

Checked the permissions, still read-only for the user. I can't even save a file there as user, and if I move it there as root, the owner becomes root.

I checked the man pages as suggested, but I am very new to linux, so its hard to understand the command line interface. Do I have to mount this partition under /mnt (ie. /mnt/SharedFiles)?

Also, I wonder if there is a problem with my user accounts. During suse10 installation, at the very end where you are supposed to login for the first time, I got a black screen with and x in the middle. I fixed this by logging in failsafe mode, then changing xorg.conf from 'ATI' to vesa, then startx, which seemed to work. However, NOW, when I try logging in to SUSE 10.0 (not failsafe), it will just freeze-up, it won't go to any login screen or GUI. The only way to get into the system is failsafe, login at command line, then 'startx' at command line. Any ideas as to whats going on? could these problems be connected?
 
Old 01-16-2006, 07:52 AM   #6
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Smile My fstab entry for fat23

My fstab entry for fat23 partition.

I use it for the same thing, to swap between windows and linux

/dev/sda6 /mnt/win_d2 vfat umask=0,iocharset=iso8859-15,codepage=850 0 0

And, yes you will mount it on the cli, mount /mnt/SharedFiles

Make sure you don't use spaces, and use uppercase letters where they are used. ( a space is seen as a directory / .)

The video problem is probably not connected to the drive setting.

xf86config is the cli command for configuring video, mouse, kb and monitor settings, fonts too, for the x-server.

Last edited by GlennsPref; 01-16-2006 at 07:58 AM.
 
Old 01-16-2006, 09:20 AM   #7
jimvin
Member
 
Registered: May 2004
Posts: 71

Rep: Reputation: 15
Don't forget that changes to /etc/fstab won't take effect until you remount the filesystem.

unmount /SharedFiles
mount /SharedFiles

I prefer the group ownership method of allowing access. For example, if your music collection is stored in /mnt/music and you want members of the group music to be able to write to it:

/dev/hdb7 /mnt/music vfat umask=0002,gid=music,iocharset=iso8859-15,codepage=850 0 0

Regards,
Jim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 07:54 PM
fat32 permission problem neverwhere Slackware 3 11-04-2004 06:03 AM
Partition mounting/KDE errors after creating Fat32 Partition BertBert Linux - General 1 07-07-2004 10:59 AM
Formating a FAT32 partition, putting the partition correctly into FSTAB, and more. squall14716 Linux - General 14 10-27-2003 10:16 PM
Fat32 permission tr0gd0O0r Linux - General 2 10-15-2003 12:32 AM


All times are GMT -5. The time now is 01:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration