LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-09-2012, 09:33 AM   #1
zuzoa
Member
 
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Rep: Reputation: 35
Perl DBI version does not match


I am trying to install ZoneMinder, and it fails during configure here:
Quote:
checking for perl module DBI... no
configure: error: zm requires DBI
==> ERROR: A failure occurred in build().
Aborting...
So I query perl and get this:
Quote:
$ perl -MDBI
Perl API version v5.14.0 of DBI does not match v5.16.0 at /usr/lib/perl5/core_perl/DynaLoader.pm line 213.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/DBI.pm line 266.
Compilation failed in require.
BEGIN failed--compilation aborted.
Perl is indeed v5.16.0 as noted by these:
Quote:
$ perl --version

This is perl 5, version 16, subversion 0 (v5.16.0) built for x86_64-linux-thread-multi
Quote:
$ pacman -Q perl
perl 5.16.0-2
And perl-dbi is the latest version as noted here:
Quote:
$ pacman -Q perl-dbi
perl-dbi 1.618-2
Quote:
$ sudo perl -MCPAN -e shell
Terminal does not support AddHistory.

cpan shell -- CPAN exploration and modules installation (v1.9800)
Enter 'h' for help.

cpan[1]> install DBI
Reading '/root/.cpan/Metadata'
Database was generated on Sat, 09 Jun 2012 12:39:03 GMT
DBI is up to date (1.622).
I have zero experience with Perl, so can anyone tell me what I'm doing wrong here? It does look like there is a difference in versions (1.622 from CPAN and 1.618-2 from pacman) but I don't know how to go about fixing it.

Thank you in advance.

Last edited by zuzoa; 06-09-2012 at 09:37 AM. Reason: typo
 
Old 06-10-2012, 03:47 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,522

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
Perl 5.16 was released a "few days ago" : 20 May 2012.

Suggest : Revert to perl-5.14, or whatever stable you had before.

Version 5.16 may still be considered experimental.
Not included in any (other) Linux OS. AFAIK.
 
1 members found this post helpful.
Old 06-12-2012, 05:31 PM   #3
zuzoa
Member
 
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Original Poster
Rep: Reputation: 35
Thank you very much. I rolled back to 5.14.2-7 and it's working perfectly.
 
Old 06-24-2012, 08:37 PM   #4
CTM
Member
 
Registered: Apr 2004
Distribution: Slackware64 13.37 / 14.0
Posts: 127

Rep: Reputation: 45
Perl 5.16 is perfectly stable. This problem is occurring because the version of DBI installed on your machine contains XS (essentially C) code that was compiled against Perl 5.14, which DynaLoader is trying to load in Perl 5.16 (which doesn't work). Either the DBI packager for your distro needs to rebuild DBI against the (newer) Perl in the distro's repository, or you can rebuild it yourself by installing it from CPAN:

Code:
# cpanp -i --force DBI
(The latter technique will probably overwrite files installed by your DBI package, which might cause inconsistencies in the installed package database - I don't know how much pacman cares about those things. If you're doing to do this, remove the DBI package first.)
 
  


Reply

Tags
perl


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Perl DBI error cannot locate object method "require -version" nanda22 Programming 0 08-26-2009 08:32 AM
perl dbi:mysql shows error syntax error dbi:mysql ?? haxpak Linux - Server 4 02-26-2009 11:09 PM
perl dbi module error "error at dbi:" dbi-> connect statement mysql haxpak Linux - Newbie 1 02-25-2009 08:22 AM
Perl DBI Queries baddah Programming 1 05-13-2008 05:56 PM
Error using DBI with Perl bostonantifan Ubuntu 0 11-11-2007 01:47 PM


All times are GMT -5. The time now is 03:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration