LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-30-2010, 03:07 AM   #1
Doug Hutcheson
Member
 
Registered: Jun 2009
Location: Queensland
Distribution: Fedora 19 i686
Posts: 143

Rep: Reputation: 17
Package requires earlier version of an installed package


Trying to yum install http://sourceforge.net/projects/spee...6.1.x86_64.rpm, but it complained that it needed libqt4 < 4.7.0. Tried using --skip-broken, but of course that didn't work.

Any solution, short of installing from source? I don't really want to do that if I can help it.

Happy New Year,
Doug
 
Old 12-30-2010, 10:03 AM   #2
tshikose
Member
 
Registered: Apr 2010
Location: Kinshasa, Democratic Republic of Congo
Distribution: RHEL, Fedora, CentOS
Posts: 134

Rep: Reputation: 30
Hi,

Try this
rpm -ivh --test --force --aid --nodeps http://sourgeforge.net/...rpm
then, if you are ok with it
rpm -ivh --force --aid --nodeps http://sourgeforge.net/...rpm

Regards,

Tshimanga.
 
1 members found this post helpful.
Old 12-30-2010, 10:49 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,947

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
The package works OK on Fedora 14 ( tested so far with i386.)

This will do : # rpm -Uvh --nodeps simon-0.3.0-56.1.<arch>.rpm


..
 
1 members found this post helpful.
Old 12-30-2010, 09:55 PM   #4
Doug Hutcheson
Member
 
Registered: Jun 2009
Location: Queensland
Distribution: Fedora 19 i686
Posts: 143

Original Poster
Rep: Reputation: 17
Thank you, Tshimanga. I was a bit nervous of using --force, until I knew a bit more about the problem
Quote:
Originally Posted by knudfl View Post
This will do : # rpm -Uvh --nodeps simon-0.3.0-56.1.<arch>.rpm
Of course! (slaps forehead). I had to install portaudio as a dependency first, then ran rpm with --nodeps and it installed fine.

Thank you both for taking the time to reply. Happy New Year.

Cheers,
Doug
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
list installed package files and how to know which package a file belongs bujecas Slackware 3 01-09-2010 03:14 PM
LXer: Pretending a Package is Installed by Creating an Empty Package with Checkinstal LXer Syndicated Linux News 0 05-03-2009 03:10 PM
using an earlier version of a package radiodee1 Debian 0 01-08-2008 05:45 PM
message "Problem during installation: x package needed for (installed) x package frayed2 Linux - Newbie 1 04-24-2005 07:05 PM
How to know the version of a package installed ? rockwell_001 Linux - Newbie 1 04-12-2005 03:25 PM


All times are GMT -5. The time now is 03:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration