LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 01-25-2006, 12:18 AM   #1
kahlil88
Member
 
Registered: May 2005
Location: Mendocino, CA
Distribution: Arch Linux
Posts: 169

Rep: Reputation: 30
Question Package gtkmm-2.4 was not found


I've been trying to install VisualBoyAdvance, and when I ran the configure script, I got an error. I used APT to install GTKMM, LibGladeMM and all their dependencies and it STILL complains!
Quote:
checking for gtkmm-2.4 >= 2.0.0 libglademm-2.4 >= 2.1.0... Package gtkmm-2.4 was not found in the pkg-config search path. Perhaps you should add the directory containing `gtkmm-2.4.pc' to the PKG_CONFIG_PATH environment variable No package 'gtkmm-2.4' found
configure: error: Library requirements (gtkmm-2.4 >= 2.0.0 libglademm-2.4 >= 2.1.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
I only found one folder where gtkmm seemed like it could be installed, in /opt/gnome/lib/gtkmm-2.0 but there is no gtkmm-2.4.pc
 
Old 01-26-2006, 10:02 AM   #2
caspervn
Member
 
Registered: Jul 2005
Location: Vietnam
Distribution: Fedora Core 2
Posts: 55

Rep: Reputation: 15
I think you should get source code (gtkmm) and compile it, may be it generate file .pc for you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Package libgnome-menu found yewchong Linux - Newbie 3 12-07-2008 03:59 PM
Installing gtranslator Package gtkspell-2.0 was not found samomaw Linux - Software 2 05-29-2005 08:12 AM
install gtkmm >=1.2 & < 2.0 package?? Cyber Maid Linux - Software 8 03-30-2005 07:04 PM
package libdv-0.103-0.pm.2.i586 was not found ... SlowMindThinkin Suse/Novell 0 12-23-2004 09:38 PM
Package not found.. hammerstein02 Linux - Newbie 1 12-02-2002 05:35 PM


All times are GMT -5. The time now is 12:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration