LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-09-2004, 10:01 PM   #1
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Rep: Reputation: 15
Opera browser... little help


I downloaded the Opera browser and it will only load from the command line. I enter the same command in the execution field when I set up a new "link to application" but the hourglass just spins until it eventually times out... why won't it load when the icon is clicked?
 
Old 03-09-2004, 10:40 PM   #2
kuhn
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Rep: Reputation: 0
I know in order to get my desktop links to work correctly in KDE i have to name them "linkname".desktop where linkname is the name of the link. Also opera should make a link for itself in the /bin dir when it installs, so the execution path needs only to be 'opera' as this is already in your PATH environment variable.

Hope this helps.
 
Old 03-09-2004, 11:11 PM   #3
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
But I downloaded the tar.gz and when I run it out of the terminal I do a ./opera in the Opera directory and it opens.... I tried what you said and that didn't work.
 
Old 03-09-2004, 11:15 PM   #4
kuhn
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Rep: Reputation: 0
Yeah sorry i installed from the rpm file for mandrake 9.2. Well the path to your opera dir should work...have you got the path in single quotes? e.g. '/usr/share/opera/opera'
 
Old 03-09-2004, 11:20 PM   #5
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
I put it in quotes and tried again... it's funny because it will come up in my taskbar with an hourglass like it is going to load but then it just dissapears off my taskbar and nothing ever loads.... it's the exact same command i put in the terminal...
 
Old 03-10-2004, 08:18 AM   #6
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
Anyone have any ideas?
 
Old 03-10-2004, 08:27 AM   #7
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Try making a link. As root, type:

ln -s /path to where opera executable is.bin /usr/bin/opera

Then do as you did to create a the desktop icon: "link to application" yadda yadda yadda... but put only opera on the execution field

Good luck!
 
Old 03-10-2004, 08:53 AM   #8
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
Thanks...

What am I doing wrong here?

[root@localhost steve]# ln -s/home/steve/Opera/./opera.bin /usr/bin/opera
ln: invalid option -- /
Try `ln --help' for more information.
[root@localhost steve]# ln-s/home/steve/Opera.bin/usr/bin/opera
bash: ln-s/home/steve/Opera.bin/usr/bin/opera: No such file or directory
[root@localhost steve]# ln-s/home/steve/Opera.bin /usr/bin/opera
bash: ln-s/home/steve/Opera.bin: No such file or directory
[root@localhost steve]#
 
Old 03-10-2004, 09:14 AM   #9
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
cool. Try:

ln -s /home/steve/Opera/opera /usr/bin/opera

you might, in time, like to install programs in a better folder, like at /usr/local, to keep the system more organized, plus every user will be able to run programs located at /usr/local. (e.g: opera could be installed at /usr/local/opera )
 
Old 03-10-2004, 09:44 AM   #10
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
Is there anyway that I can just redownload it and make it go into the usr/bin directory so that I can just type "opera" and have it work?
 
Old 03-10-2004, 09:46 AM   #11
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
I'm not familiar with Opera (I've used with Libranet, but did not like it). But the above procedure would work. Basically, download it, uncompress to /usr/local, make a link with ln -s /usr/local/opera/opera /usr/bin/opera and it should start by typing opera only
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't install the Opera browser Gins Linux - General 3 03-04-2005 03:53 PM
the opera browser? linux_dejan Linux - Software 5 03-06-2004 01:50 PM
Opera Browser -=DpG26=- Linux - Newbie 1 08-17-2003 04:46 PM
Opera browser skins bigjohn Linux - Newbie 11 04-12-2003 03:12 PM
Opera browser doodah Linux - Networking 1 05-25-2001 01:39 PM


All times are GMT -5. The time now is 03:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration