LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-26-2008, 09:43 PM   #1
pwabrahams
Member
 
Registered: Nov 2005
Location: Deerfield MA
Distribution: OpenSuSE, Kubuntu
Posts: 272

Rep: Reputation: 41
OpenSuSE online update: "Helper program returned: invalid xml"


When I click on the update notification icon in Open SuSE 10.3, I get the message Helper program returned: invalid xml. I saw one suggestion that the problem could be solved by refreshing all my repositories, but that didn't do the trick for me.

Does anyone know what the "helper program" is, and where it's looking for its xml? I'd think the best way to deal with this would be to delete whatever xml it's looking at and let it be regenerated, but for that I have to know where it's looking.
 
Old 05-28-2008, 07:29 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Which icon did you use in yast ? On the taskbar ?
What do mean by refresh using the refresh option ?
Or did you delete it all and ad it again ?
What url is mention in the software repositories?
What did you use kde3 kde4 Gnome
Using Beagle search with search argument helper program in my box gives 37 possible answers ?

all the best
 
Old 05-28-2008, 05:17 PM   #3
pwabrahams
Member
 
Registered: Nov 2005
Location: Deerfield MA
Distribution: OpenSuSE, Kubuntu
Posts: 272

Original Poster
Rep: Reputation: 41
More info as requested

Quote:
Originally Posted by ronlau9 View Post
Which icon did you use in yast ?
A yellow triangle with a bang in the middle.

Quote:
On the taskbar ?
yes

Quote:
What do mean by refresh using the refresh option ?
Under Online Repositories, clicking on Refresh Now for each one.


Quote:
Or did you delete it all and ad it again ?
I did that also.

Quote:
What url is mention in the software repositories?
There are too many to list here, but they all came from the Community Repositories option of YaST.

Quote:
What did you use kde3 kde4 Gnome
kde4


Quote:
Using Beagle search with search argument helper program in my box gives 37 possible answers ?

all the best
 
Old 05-29-2008, 02:07 AM   #4
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
In yast2>software update is also a option to update .You start it up manually is this one working
On the taskbar is a automatic update I never use this one , it works bad by me too I let it there to warn me that there is a update and if there is a quit the one on the taskbar and used the one in yast


all the best
 
Old 05-29-2008, 08:36 AM   #5
pwabrahams
Member
 
Registered: Nov 2005
Location: Deerfield MA
Distribution: OpenSuSE, Kubuntu
Posts: 272

Original Poster
Rep: Reputation: 41
Yast update does work

Quote:
Originally Posted by ronlau9 View Post
In yast2>software update is also a option to update .You start it up manually is this one working
yes

Quote:
On the taskbar is a automatic update I never use this one , it works bad by me too I let it there to warn me that there is a update and if there is a quit the one on the taskbar and used the one in yast
I'd prefer to use the one on the taskbar if I can, if only because it requires less intervention.
 
Old 05-30-2008, 12:38 AM   #6
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
I remember now that the icon was working in the beginning , but it stops working after I update
Maybe it gives a clue

all the best
 
  


Reply

Tags
helper, opensuse, xml


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Message from "Online Update Configuration" ed_homeLinux Suse/Novell 2 03-27-2008 05:57 AM
Yast Online Update (YOU) error "could not reassemble rpm from delta" RedBoot Suse/Novell 3 03-06-2006 12:23 PM
YaST Online Update "changed configuration files" warning Robhogg Suse/Novell 2 02-18-2006 01:22 PM
Yast Online Update (YOU) error "could not reassemble rpm from delta" RedBoot Linux - Software 5 02-15-2006 09:33 PM
The "right" way to use an XML file in a program. Travis86 Programming 3 09-26-2004 11:48 PM


All times are GMT -5. The time now is 10:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration