LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Openoffice Won't Accept Gnome - Help !!! (http://www.linuxquestions.org/questions/linux-software-2/openoffice-wont-accept-gnome-help-661561/)

taurusx5 08-09-2008 02:56 AM

Openoffice Won't Accept Gnome - Help !!!
 
Openoffice rejects any gnome theme. I had to uninstall the openoffice.org-gnome package in order to fully save a document without errors popping up. When I do have it installed, I get an error saying the following:

'Due to an unexpected error, OpenOffice.org crashed. All the files you were working on will not be saved. The next time OpenOffice.org s launched, your files will be recovered automatically.'

That's the problem, which is why I uninstalled the openoffice.org-gnome package. However, in so doing, I get a simple openoffice interface with small font in the menu. And, the menu is rendered in a pale blue color. I want to know how to enable the interface to match the same settings/color as my gnome theme. How do I do this?

.

PA_Dummy 08-09-2008 06:37 PM

I had problems with Openoffice with Gnome under Ubuntu. I had installed the community version, from OO.org, and had deleted the Ubuntu version.

I found I had to change the video driver (was an ATI type) and use a low (about 600 X 800) resolution.

In /etc/X11 if there is an "xorg.conf.failsafe" file, try that config file.

Needless to say save the working xorg.conf file under another name first.
Then copy the failsafe version to the name xorg.conf.

If things get messed up, BOOT in safe mode. When the colored text screen appears select rebuild the X11 file. This may work in a different way in your distribution.

Anyway it was a video problem !!

taurusx5 08-10-2008 01:50 AM

Quote:

Originally Posted by PA_Dummy (Post 3242155)
I had problems with Openoffice with Gnome under Ubuntu. I had installed the community version, from OO.org, and had deleted the Ubuntu version.

I found I had to change the video driver (was an ATI type) and use a low (about 600 X 800) resolution.

In /etc/X11 if there is an "xorg.conf.failsafe" file, try that config file.

Needless to say save the working xorg.conf file under another name first.
Then copy the failsafe version to the name xorg.conf.

If things get messed up, BOOT in safe mode. When the colored text screen appears select rebuild the X11 file. This may work in a different way in your distribution.

Anyway it was a video problem !!

PA_Dummy, you may be right because before updating to the most recent driver, I had no problem with openoffice. This problem ensued after installing to this driver. So, it's possible that this is the culprit.

One thing you mentioned that I want you to clarify is, you said that you had uninstalled the ubuntu version and installed the community one. THen, you said that you had to the video driver. Was it necessary for you to change the video driver after installing the community program? Didn't the community program solve the issue without you changing the video driver?

'

PA_Dummy 08-10-2008 07:27 AM

OK,

The video driver did not become an issue until the installation of the community (OO.org) version of OpenOffice.

It would start with the blue logo-screen, run a second and flash, blink and close. This left the blank document to be recovered.

I could run "office" at the command line. Get the blank open screen. Then select a document and it would work.

Resetting the video driver from an ATI type using the "quick and dirty" X11 reset allowed clean access to OO by the menu selections.

Note: Some boards say the new ATI (AMD merger) is doing better with Linux. Mine is an old RV100QY 7000/VE.

Also --- you have to remove the Ubunto distribution version in order to install the community version using "deb" format.

________

________

taurusx5 08-10-2008 10:03 AM

Quote:

Originally Posted by PA_Dummy (Post 3242521)
OK,

The video driver did not become an issue until the installation of the community (OO.org) version of OpenOffice.

It would start with the blue logo-screen, run a second and flash, blink and close. This left the blank document to be recovered.

I could run "office" at the command line. Get the blank open screen. Then select a document and it would work.

Resetting the video driver from an ATI type using the "quick and dirty" X11 reset allowed clean access to OO by the menu selections.

Note: Some boards say the new ATI (AMD merger) is doing better with Linux. Mine is an old RV100QY 7000/VE.

Also --- you have to remove the Ubunto distribution version in order to install the community version using "deb" format.

________

________

Hey, man. Yeah, I think I'll go ahead and uninstall oo and all traces thereof and try the community version. Hey, by any chance, did you ever try the new oo beta? I'm thinking about downloading and installing it just to test it out. Have you tried it?


.

PA_Dummy 08-11-2008 04:18 PM

Quote:

Originally Posted by taurusx5 (Post 3242607)
Hey, by any chance, did you ever try the new oo beta? I'm thinking about downloading and installing it just to test it out. Have you tried it?

.

YES:

I am using it under Windows NT Pro with NO problems !! Very snappy.

I attempted to install it under Ubunto 8.04 and had problems with the install.

________

taurusx5 08-11-2008 09:47 PM

Quote:

Originally Posted by PA_Dummy (Post 3244039)
YES:

I am using it under Windows NT Pro with NO problems !! Very snappy.

I attempted to install it under Ubunto 8.04 and had problems with the install.

________


Hey dummy... I've had no problems installing it in ubuntu 8.04 but I don't see a way for opening a new document without setting up a launcher on the desktop whcih annoys me. I want to be able to go into oo writer from my menu, not from a desktop launcher.

PA_Dummy 08-12-2008 08:27 AM

Quote:

Originally Posted by taurusx5 (Post 3244241)
I've had no problems installing it in ubuntu 8.04 but I don't see a way for opening a new document without setting up a launcher on the desktop whcih annoys me. I want to be able to go into oo writer from my menu, not from a desktop launcher.

OK

That is one of the problems.

If it is not a "transparent to the user" install --- we will never sell Linux to the average Windows user.

Good install scripts that help with a total install, with the attendant systems and GUI housekeeping will help sell Linux.

Check out some of the scripts on this site: http://www.stchman.com/
They are a very good start !!


_______

taurusx5 08-12-2008 01:19 PM

Quote:

Originally Posted by PA_Dummy (Post 3244784)
OK

That is one of the problems.

If it is not a "transparent to the user" install --- we will never sell Linux to the average Windows user.

Good install scripts that help with a total install, with the attendant systems and GUI housekeeping will help sell Linux.

Check out some of the scripts on this site: http://www.stchman.com/
They are a very good start !!


_______

Thanks man. I'll take a look at the website you mentioned.

.


All times are GMT -5. The time now is 09:33 AM.