LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-14-2003, 12:16 PM   #1
minoltaherbie
LQ Newbie
 
Registered: Jul 2003
Location: Oklahoma
Distribution: Mandrake 9.1
Posts: 9

Rep: Reputation: 0
OpenOffice won't open


I've installed Mandrake 9.1. When I go to the menu to open any OpenOffice program clicking on the icon doesn't do anything. When I go to console and type "oowriter" I get the following message:

[herbie@localhost herbie]$ oowriter
not well-formed (invalid token) at line 366, column 33, byte 19804 at /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/XML/Parser.pm line 185
[herbie@localhost herbie]$

If I change to root and type "oowriter", the program opens and runs just fine. It works for other OpenOffice programs, as well.
I've used the Mandrake Control Center to remove and reinstall OpenOffice, but still have the same problem.

What do I need to do?
Thanks!
 
Old 09-14-2003, 12:59 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
"What do I need to do?"

Open office can be installed as either root or user, but if you install it as user you often get problems like you describe. So I suggest trying the following steps to get rid of the problem:

log in as user and uninstall Open Office
log in as root and uninstall Open Office
install open Office as root
run oowriter as root (and initialized Open Office printing)
run open office as root (and initialize root Open Office)
log in as user
run Open Office (and initialize user Open Office)

This sequence works for me. If I install Open Office first as user things never seem to work out right.
 
Old 09-14-2003, 01:03 PM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
You most likely installed with only root privileges given. Did you follow the directions for install here: http://www.openoffice.org/dev_docs/i...ons.html#linux

At one point, you don't want to finish the install as root, thus that is your problem now at this point.

Hope this helps.
 
Old 09-14-2003, 04:41 PM   #4
minoltaherbie
LQ Newbie
 
Registered: Jul 2003
Location: Oklahoma
Distribution: Mandrake 9.1
Posts: 9

Original Poster
Rep: Reputation: 0
Actually, OpenOffice was installed from the Power Pack 9.1 DVD during the primary OS installation.
I later removed it using the Mandrake Control Center which requires you to sign in as root. After removing, I rebooted and signed into Mandrake Control Center, as root, and reinstalled it with all dependencies. The end result being, it still would not open except with root authority.
Thanks for your help, so far.
 
Old 09-14-2003, 10:04 PM   #5
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
this may be silly but does the command
sofice
work? I've had problems where I could not use oowriter but soffice worked just fine. Don't ask me why.

Also, it seems that at least the mandrake version of Oo.org is hyper-sensitive to locale settings. A slight change to the locale settings after installation of oo.org and it will no longer start. Check if you have a ~/.i18n and if you do if it has the same settings as /root/.i18n and/or /etc/sysconfig/i18n. There are also locale settings in Kde control center which you might checl out.
 
Old 09-14-2003, 10:45 PM   #6
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
The instructions that trickykid linked to are somewhat different different than the way I install it. One thing that the two sets of instructions have in common is that you first install Open Office as root and then do a setup or initialization in user. trickykid's instructions say do ./setup as user. I recall that user setup was what I got the first time I ran Open Office with the normal start command.

"# When the installer is finished, you should execute the user-setup for OpenOffice.org. To do so, make sure you are no longer root - i.e. become a regular user, then change into the program directory where you installed OpenOffice.org: cd /opt/OpenOffice.org1.0, and execute the following command: "./setup""

On my first install of Open Office I found that the printer setup had to be done as root. It would then work OK in user without any further setup.

" I've had problems where I could not use oowriter but soffice worked just fine."

I have let SuSE install Open Office as part of a Linux install and I have installed Open Office by compiling the tarball. I got different names for Open Office. I think that I got the soffice name back when SuSE installed the free version of Star Office before it forked into Star Office and Open Office.

So I advise you to use the which command to try all of the possible names and see what you have.

which soffice
which oowriter
which openoffice
which oo
which setup

Since setup is a common program name you might try:
find / -iname "*setup*"
and see if there is a setup in an Open Office directory.

Last edited by jailbait; 09-14-2003 at 10:53 PM.
 
Old 09-14-2003, 10:55 PM   #7
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
I'm not sure any of the instructions by jailbait and trickykid apply to the mandrake installation of openoffice from the cds. For one, there's no /opt/OpenOffice1.0 with the mdk rpm installation. OpenOffice in mandrake sits in /usr/lib/openoffice. thereis a setup in there but normally it's not necessary to run it. Might be worth a shot, though.

the trouble with oowriter not working is not that oowriter is not installed. it's a startup script and it would hang for this or that reason. using soffice, another script, doesn't have this problem - at least, I've never seen it hang, but oowriter hangs for all sorts of reasons that I don't all understand (I know it is *really* sensitive to changes in locale settings).
 
Old 09-15-2003, 04:35 AM   #8
haamann
LQ Newbie
 
Registered: Jul 2003
Posts: 20

Rep: Reputation: 0
I have had some problems running both StarOffice and OpenOffice as user. I got it working by logging in as root and gave the usr ownership to all the files in /usr/lib/Openoffice***.

#chown -R user:user /usr/lib/Openoffice***

use your own username instead of "user"

This works for a system with only one user. Haven't tried it on a server with multipul users
 
Old 09-15-2003, 04:42 AM   #9
Evilone
Member
 
Registered: Oct 2002
Location: UK
Distribution: Slack 9.1 (2.6.5)
Posts: 307

Rep: Reputation: 30
Ok i appologise first off... and i know i can't help you with your problem, but man

"Openoffice won't open" - Thats hillarious.

Sorry dood. Been fighting with mailservers all night and it cheered me up. Good luck man !!

 
Old 09-15-2003, 03:20 PM   #10
minoltaherbie
LQ Newbie
 
Registered: Jul 2003
Location: Oklahoma
Distribution: Mandrake 9.1
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for all of your suggestions! "soffice" doesn't work at the command prompt: user or root. Of the "which" commands only "which oowriter" scores. "oowriter" is located at /usr/bin/oowriter. Changing ownership via "#chown -R user:user /usr/lib/openoffice***" doesn't seem to make any difference either. The icon under the start menu still will not open any OpenOffice programs. A user command from a console is ineffective, as well. The only thing that works is a root command from a console. I still get the following comment when I execute "oowriter" from a console as user.

[herbie@localhost herbie]$ oowriter
not well-formed (invalid token) at line 366, column 33, byte 19804 at /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/XML/Parser.pm line 185
[herbie@localhost herbie]$

Thanks for you help, so far.
 
Old 09-15-2003, 07:33 PM   #11
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
you might want to reinstall perl. Maybe get a fresh and clean package from the net in case there's something wrong with your cds.

Also, when you look at the oowriter script, you'll see that after doing all kinds of things, it calls ~/.openoffice/soffice. You can actually go into ./openoffice and run soffice there by
./soffice
maybe this'll work.
 
Old 09-15-2003, 11:13 PM   #12
OldSarge
Member
 
Registered: Jul 2003
Posts: 56

Rep: Reputation: 15
I find in SuSe, that OpenOffice will not print correctly, no matter what is done. I have SuSe 8,2 with OpenOffice.org 1.0.2. What is really ridiculous is that Suse will not help unless you are willing to pay. I can see paying, but only if the software is not at fault! I can use the same problem in Windows and have NO PROBLEM WITH IT!!!
 
Old 09-17-2003, 09:32 AM   #13
minoltaherbie
LQ Newbie
 
Registered: Jul 2003
Location: Oklahoma
Distribution: Mandrake 9.1
Posts: 9

Original Poster
Rep: Reputation: 0
Issue resolved! I removed OpenOffice; went to the OpenOffice web site and downloaded the most recent stable release; installed according to instructions. I then created an icon link to "soffice" for the Start Menu and for the desktop. Both work like a charm. Everything appears to be functioning as it should. Thanks for everyone's assistance.
minoltaherbie
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenOffice Can not open documents across network awtoc123 SUSE / openSUSE 21 10-06-2009 03:10 PM
Can't Open OpenOffice in KDE 3.4 Remo Linux - Newbie 4 04-13-2005 12:25 AM
OpenOffice Writer won't save/open in kde 3.4 notregistered Linux - Software 6 04-02-2005 11:51 AM
openoffice writer file won't open knowerrors Linux - Software 7 01-03-2005 06:19 AM
OpenOffice Wont Open HELPPPP oakley Linux - Software 33 11-09-2003 10:58 PM


All times are GMT -5. The time now is 11:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration