LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-21-2004, 09:26 PM   #1
wpyh
Member
 
Registered: Jun 2004
Location: Beijing
Distribution: Slackware 9.1 but FUBAR with packages I compile myself, and OpenBSD (not exactly a distro) on QEMU
Posts: 153

Rep: Reputation: 35
Question OpenOffice.Org 1.1.2 + Linux2.4.28 = Invalid Pointer


This is weird: I just upgraded my kernel from 2.4.28-pre3 to 2.4.28 and OpenOffice.Org stopped working.

Symptoms:
~$ soffice
free(): invalid pointer 0x4112e2a0!
Aborted

And then the program just exits with an error value of 134 (I echoed $?).

But as root, it works just fine. At first I thought it was a problem with OpenOffice.Org 1.1.2, so I tried upgrading to 1.1.3. As root I have installed it fine, but as a normal user I keep getting the same error again.

I didn't remember doing anything serious to the system as root between reboots (before and after kernel upgrade). It looks like a permission problem, but I have set the permissions to the /opt/OpenOffice.Org1.1.2 directory correctly.

Anybody got the same problem? Please help. Thanks.
 
Old 11-25-2004, 09:32 AM   #2
wpyh
Member
 
Registered: Jun 2004
Location: Beijing
Distribution: Slackware 9.1 but FUBAR with packages I compile myself, and OpenBSD (not exactly a distro) on QEMU
Posts: 153

Original Poster
Rep: Reputation: 35
Red face

Well, I got no replies... did I post in the wrong forum?

Anyway, I have avoided the problem. I said avoided, not solved. I got OpenOffice.Org running by removing the modules sis and sisfb.I think those are related to DRI and framebuffer somehow, and I don't have much use for them, so wtf, I just removed them from the kernel config.

One thing: I noticed that this "regression" (if it's to be called a regression) happens during the upgrade from rc2 to rc3. But I can't see anything related to the sis and sisfb modules being modified in the patch.

Any ideas/possibilities of how the thing might have broken?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Glibc free() invalid pointer pierre-luc Programming 3 11-13-2005 08:04 PM
OpenOffice.org aznboi12321 Linux - Software 2 03-05-2005 08:34 PM
OpenOffice.org *** glibc detected *** free(): invalid pointer: 0x41481c94 *** Artanicus Linux - Software 2 02-19-2005 07:04 PM
OpenOffice.org big_syner Linux - Software 3 10-20-2004 01:52 AM
OpenOffice.org Jafar Linux - Software 8 05-27-2003 10:47 AM


All times are GMT -5. The time now is 04:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration