LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-06-2007, 05:04 AM   #1
edgjerp
Member
 
Registered: Dec 2004
Location: Trondheim, Norway
Distribution: kubuntu 10.04
Posts: 308

Rep: Reputation: 31
openoffice calc LOOKUP() returns wrong value


I have a document that among other things takes a string from one cell, looks it up in another sheet, and returns the corresponding number value. for some reason, some of the values seem to match incorrectly. the search vector is quite long, but there are no doubles. e.g. when searching for "molle05", the value for "marked20" is returned. I have sorted the search vector, and the function should be correct, since mostly the return values are correct.

the function looks like this: 'LOOKUP($D58;$priser.$A$3:$A$577;priser.C$3:C$577)'
 
Old 06-07-2007, 04:02 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,784

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
It's been a few years since I did spreadsheet lookups. My suspicion would be the use of absolute cell addresses may be causing the problem.
 
Old 06-08-2007, 08:23 AM   #3
edgjerp
Member
 
Registered: Dec 2004
Location: Trondheim, Norway
Distribution: kubuntu 10.04
Posts: 308

Original Poster
Rep: Reputation: 31
the problem is that the wrong returns only show up for certain items, most items work fine.
 
Old 06-20-2009, 05:08 AM   #4
bdt-rob
LQ Newbie
 
Registered: Jun 2009
Location: Cambridge, England
Distribution: Gentoo, Arch, (xandross), (Slackware)
Posts: 16

Rep: Reputation: 2
I'm also seeing something like this. It appears to be the behaviour described in https://bugs.launchpad.net/ubuntu/+s...rg/+bug/388803 and applies to oocalc at v2.4 (on EEEPC) and 3.0 (on Gentoo - binary package)

Anyone know if it's ever going to get fixed?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
logic in openoffice calc edgjerp Linux - Software 2 05-14-2006 08:13 AM
Openoffice calc dajomu Linux - Software 1 10-27-2005 05:56 PM
OpenOffice.org Calc Lookup question BorisMcHack Linux - Software 0 01-31-2005 11:49 AM
openoffice calc question buffed317 Linux - General 1 09-11-2004 03:27 PM
openoffice calc question... marsques Linux - Software 2 07-10-2004 04:30 PM


All times are GMT -5. The time now is 04:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration