LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-22-2005, 02:30 PM   #1
tongliu8
LQ Newbie
 
Registered: Apr 2005
Posts: 12

Rep: Reputation: 0
OpenOffice 2.0 is very slow to launch


I just installed OpenOffice 2.0. For most of the time, it takes 40sec to launch which is too slow. It takes only 6 sec to launch 1.1.3.

The CPU of my pc is a Intel P4 2.6GHz. It is running RedHat 9 (kennel 2.4.20). I use GNOME.

I notice for some times it can launch much faster (less than 5sec). And I cannot figure out what the patterns are.

During the 40sec that OpenOffice 2.0 is launching, I don't see too much hard disk activity and CPU usage is very low. Seems that it is just sitting there and doing nothing. Or it is waiting for some events. I do see some network activity. I suspect it silently connects some web sites.

Does anybody know the reason ?
 
Old 10-22-2005, 02:42 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,986
Blog Entries: 11

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Check your /etc/hosts ... have you got an entry
like:
127.0.0.1 localhost
?


Cheers,
Tink
 
1 members found this post helpful.
Old 10-22-2005, 02:58 PM   #3
tongliu8
LQ Newbie
 
Registered: Apr 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Yes, I can see this line in /etc/hosts
 
Old 10-22-2005, 03:20 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,986
Blog Entries: 11

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Do you have another line referencing localhost as well?
One that has the hostname your ISP assigned you?


Cheers,
Tink
 
Old 10-22-2005, 09:09 PM   #5
tongliu8
LQ Newbie
 
Registered: Apr 2005
Posts: 12

Original Poster
Rep: Reputation: 0
No. I can see only one line like
127.0.0.1 george localhost.localdomain localhost

george is the name I gave to my machine
 
Old 10-22-2005, 10:53 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,986
Blog Entries: 11

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Ummm. You may want to change that line to look like
ONLY this:

127.0.0.1 localhost


Cheers,
Tink
 
Old 10-23-2005, 12:55 AM   #7
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
tongliu8: Another thought, OpenOffice 2 opens very slowly if your system is having problems with DNS resolution. Apparently, OpenOffice phones home each time it starts.

Temporarily disable name resolution and see if OpenOffice then opens quickly.

This became a problem when I was running systems without a WAN connection, but with DNS server addresses configured. The systems acted just like what you described. Removing the name server addresses allowed OpenOffice to open quickly.
 
Old 10-23-2005, 01:18 AM   #8
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,986
Blog Entries: 11

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Quote:
Originally posted by WhatsHisName
tongliu8: Another thought, OpenOffice 2 opens very slowly if your system is having problems with DNS resolution. Apparently, OpenOffice phones home each time it starts.
Are you serious? If that's the case I definitely won't be
using it, being an RPM only distribution to start with :/


Cheers,
Tink
 
Old 10-23-2005, 01:36 AM   #9
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
About the DNS resolution/slow start? Absolutely. Misconfigure your name server addresses and see if you can replicate the problem.

For a DNS resolution issue to slow down a process, the process would need to be trying to resolve a name.

Later edit: The problem occurs the first time you start OpenOffice after a reboot. Subsequent starts (on the same boot) go quickly.

Last edited by WhatsHisName; 10-23-2005 at 01:42 AM.
 
Old 10-23-2005, 12:52 PM   #10
tongliu8
LQ Newbie
 
Registered: Apr 2005
Posts: 12

Original Poster
Rep: Reputation: 0
WhatsHisName, you are right. The DNS config has some problems. DNS server ip address is always reset to 192.168.2.1 which I guess is my ISP's modem address. This does not prevent me from connecting to the Internet. If I change to the real DNS addresses, OpenOffice 2.0 can start very quickly without any problem.

OpenOffice 2.0 's behavior makes me very uncomfortable. Is there a way to disable it finding the DNS server ? I'd like it to run like on a standalone machine. Or is there a way to set the DNS ip in the OpenOffice 2.0 ?

Last edited by tongliu8; 10-23-2005 at 01:00 PM.
 
Old 10-29-2005, 08:47 AM   #11
awtoc123
Member
 
Registered: Apr 2002
Location: China
Distribution: Suse 10
Posts: 225

Rep: Reputation: 30
Hi I like to add a line here, I have eight computers with Suse 10 installed two of the eight are P4 2.66 Mhz 64 Bit 1MB L2, that is to say that two computers are 64 bit both with 64 bit version of suse 10 installed, but one of the two 64 bit computers have SATA 120 GB and the other has PATA 60GB ( both computers has 1GB DDR400 RAM, now the computer with PATA 60GB disk loads openoffice 2.0 in two seconds, the computer with SATA 120GB disk loads openoffice 2.0 in 2.2 Min, like I said the two computers are identical apart from the hard disk, the computer which is mega slow loading open office 2.0 is on the other hand mega fast loading all the other programes.
I have checked /etc/hosts and it only contains 127.0.0.1 localhost and I have tried to disable the network, and which now runs DHCP, I'm ????????????????????

Any Ideas ??????
 
Old 10-29-2005, 09:41 AM   #12
tongliu8
LQ Newbie
 
Registered: Apr 2005
Posts: 12

Original Poster
Rep: Reputation: 0
The problem I had was related to the DNS. Did you check the DNS ?

Another thing I noticed was if I changed the content of /etc/hosts
from:
127.0.0.1 george localhost.localdomain localhost
to:
127.0.0.1 localhost
It would launch even slower.
 
Old 10-29-2005, 09:55 AM   #13
madluther
Member
 
Registered: Aug 2004
Distribution: LFS
Posts: 350

Rep: Reputation: 30
Quote:
Apparently, OpenOffice phones home each time it starts.
Where did you get this information ?

I see no evidence of network traffic when launching OOo 2.0, deliberately misconfiguring DNS had no effect on startup times.
 
Old 10-29-2005, 09:59 AM   #14
exit3219
Member
 
Registered: May 2005
Location: Moldova
Distribution: Kubuntu
Posts: 199

Rep: Reputation: 30
Quote:
Originally posted by WhatsHisName
Apparently, OpenOffice phones home each time it starts.
Does the Windows version do the same?
Why does it do so, anyway?
 
Old 10-29-2005, 02:49 PM   #15
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 964

Rep: Reputation: 34
Both changes involve going into the Tools and then options management sections. In the memory dialogue box, increase graphics cache to 64MB and memory per object to 8MB. It will take Open Office a few openings before this helps.

The other is to go to Java options and disable them. Apparently in the time it takes Open Office to open Java, you can go and make a cup off coffee, go to the loo, read the online newspaper on your thin and light and return to your desktop.

maybe this will help, i found it @ http://www.theinquirer.net/?article=27292
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenOffice.org QuickStarter - installed it... how do I launch it? Stevetgn Linux - Software 4 09-28-2005 12:22 PM
Slow name resolving _and_ slow konsole launch dangerbaby Mandriva 7 03-03-2005 06:11 AM
OpenOffice.org will not launch / start up hfinger Mandriva 2 09-15-2004 12:01 AM
OpenOffice.org will not launch hfinger Mandriva 2 11-30-2003 04:47 PM
Can't launch OpenOffice after installing graphic card bcarl314 Linux - Hardware 3 09-25-2003 05:27 AM


All times are GMT -5. The time now is 10:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration