LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-24-2003, 07:21 AM   #1
Cabs
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Rep: Reputation: 0
Open GL Refresh issues


Hi all

I am new to Linux and am having a terrible time trying to figure out how to get my refresh rate up to 120 in Quake 3 under Red hat 9.

I have installed NVidia drivers nad have Quake running but it only runs at 85 refresh. Under windows it ran perfectly fine at 120 refresh. I have scoured the internet and have yet to find a simple solution. A lot of people go on about modelines etc and it makes little or no sense to me. My XF86Config has no such definition.

I have a GF3 card with a Mitsubishi Pro 900 monitor and Red Hat has it all set up. I did try Suse 8.2 and that worked fine for refresh (it was 120 as it should be without any tweaking)

Can anybody please help

Kind Regards
 
Old 08-24-2003, 08:08 AM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Do you have it locked to the refresh rate?
 
Old 08-24-2003, 08:20 AM   #3
Cabs
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Apologies but I dont know how to do that in Linux..
 
Old 08-24-2003, 08:31 AM   #4
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Check in the Game Options Menu Under Sync Every Frame (You want this off).


Also check this page http://q3a.gamehelp.com/console/video_list.html

for some tweaks for Quake3.
 
Old 08-24-2003, 08:58 AM   #5
Cabs
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Original Poster
Rep: Reputation: 0
but having sync every frame will lock my framerate to the monitor hertz. I get 350 fps in Quake 3.. the problem is the monitor is locked at 85hz and so the game feels very juddery. I cap my frame rate at 120 and I like to have my monitor at 120 as well.. however sync every frame is guided by the monitor refresh. So unless I can get my monitor to refresh at 120hz in game (like it did fine under Suse ) then I am stuffed.

Thanks for all the replies so far.
 
Old 08-24-2003, 09:03 AM   #6
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Thats basically what I meant, if you want it higher that the refresh of you monitor make sure its NOT locked.

As for altering the refresh rate, Have you tried a modeline in XF86Config-4 file. (Do a google on it) This should help you.

Also check your drivers for options (look in the Nvidia readme). as ths may help you add Hz to your screen, if you dont want peak throughput.
 
Old 08-24-2003, 09:07 AM   #7
Cabs
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Original Poster
Rep: Reputation: 0
THanks.. thats the reply I always get.. about modelines but I dont understand what they do. I don't have an XF86Config-4 file.. just an XF86Config file and it has nothign about modelines in it.

The modelines are all gobbledegook to me
 
Old 08-24-2003, 09:16 AM   #8
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Heres could help you.
http://www.geocities.com/Athens/Part...9/monitore.htm

Also what version of XFree86 are you using?

It might be time for an upgrade.
 
Old 08-24-2003, 09:27 AM   #9
Cabs
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Original Poster
Rep: Reputation: 0
How do I know what version of XFree I am using? It's a fresh install of Red Hat 9 and I have updated everything it recommended me to.

XFree86 4 configuration created by pyxf86config <-- thats at the top of my XF86 Config

My monitor is...

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Mitsubishi Diamond Pro 900u (NFJ9905)"
DisplaySize 350 260
HorizSync 30.0 - 95.0
VertRefresh 50.0 - 152.0
Option "dpms"
EndSection

I am sorry to be a pain.. but I really don't want to have to spend the afternoon formatting to put Windows back on
 
Old 08-24-2003, 09:32 AM   #10
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
What GUI are you using? (KDE, Gnome)
 
Old 08-24-2003, 09:35 AM   #11
Cabs
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Gnome 2.2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethical Issues in Open Source firefly2442 General 26 05-18-2005 02:50 PM
Nvidia GeForce4 refresh issues slymer Linux - Hardware 0 02-25-2005 12:42 PM
Issues with open() (asm) vexer Programming 11 05-05-2004 10:44 PM
Refresh Rate + Resolution issues pureevil4 Slackware 6 04-16-2004 04:11 PM
Open GL issues ClayOgre Linux - Software 0 04-01-2003 04:16 PM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration