LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 01-14-2007, 01:14 PM   #1
jim0112
LQ Newbie
 
Registered: Oct 2006
Location: Brighton, UK
Posts: 18

Rep: Reputation: 0
One XP machine can browse to the Samba share, one cannot


I have two XP machines and one Ubuntu server running Samba.

One XP machine can browse to the Samba share and access files with no problems at all, and it always has been able to do so.

The other XP machine cannot browse to the Samba share, and it has never been able to do so:
- The Ubuntu box isn't listed in My Network Places
- I can't browse to it using Start -> Run -> \\ubuntu\samba
- I can't browse to it by typing \\ubuntu in the address bar of Windows Explorer
- I can't map it as a network drive
(These are all fine on the other XP box)

The problem XP box has the IP of the Ubuntu box as its WINS server, NETBIOS over TCP/IP is enabled, and it can ping the Ubuntu box's IP and hostname. The Ubuntu box is shown in nbtstat -c.

It can also log into the Ubuntu machine using SSH, for instance. I have tried to manually map the Samba share as a network drive by trying both \\ubuntu\samba and \\ip_address\samba via both Tools -> Map Network Drive and also using net use at the command prompt.

All three machines are on workgroup HOME and the problem XP machine can browse to files on the other XP machine with no problems. I have disabled the problem machine's firewall and restarted Samba using sudo /etc/init.d/samba restart, but this has not helped. I'm sure I'm doing something stupid - but what? If anyone has any ideas, please let me know.

Here is /etc/samba/smb.conf:

[global]
; General server settings
netbios name = UBUNTU
server string =
workgroup = HOME
announce version = 5.0
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192

passdb backend = tdbsam
security = user
null passwords = true
username map = /etc/samba/smbusers
name resolve order = hosts wins bcast

wins support = yes

printing = CUPS
printcap name = CUPS

syslog = 1
syslog only = yes

[print$]
path = /var/lib/samba/printers
browseable = yes
guest ok = yes
browseable = yes
guest ok = yes
read only = yes
write list = root
create mask = 0664
directory mask = 0775

[printers]
path = /tmp
printable = yes
guest ok = yes
browseable = no

[Samba]
path = /home/share
browseable = yes
read only = no
guest ok = no
create mask = 0644
directory mask = 0755
force user = mainusername
force group = mainusername

Last edited by jim0112; 01-14-2007 at 01:17 PM.
 
Old 01-14-2007, 10:16 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
My first idea is that one XP machine is using one type of authentication while the other is using another type of authentication. For example, one XP machine may be using workgroup/share level authentication while the other is using Active Directory authentication.
 
Old 01-15-2007, 12:59 AM   #3
uranid10t
LQ Newbie
 
Registered: Apr 2006
Distribution: DSL 1.4, Dreamlinux 2.0 (Getting ready to install 2.2), Still tinkering with FreeBSD
Posts: 14

Rep: Reputation: 0
I agree with Stress_Junkie, The problem you're seeing is with the Win XP box, it's not Samba. Check authentications on both boxes. The one that isn't working is probably using the Active Directory Authentication.
 
Old 01-15-2007, 05:58 PM   #4
jim0112
LQ Newbie
 
Registered: Oct 2006
Location: Brighton, UK
Posts: 18

Original Poster
Rep: Reputation: 0
Hi guys,

Thanks for the replies. I will compare the settings on the XP machines and report back!
 
Old 01-28-2007, 04:12 PM   #5
jim0112
LQ Newbie
 
Registered: Oct 2006
Location: Brighton, UK
Posts: 18

Original Poster
Rep: Reputation: 0
Well - I'm still stuck.

The machine isn't a member of a domain and doesn't use AD authentication. I looked up the commands that can be run from the command prompt to reset group and local security policies back to defaults - this didn't help either!

There is no physical problem that is stopping this from working - the problem machine dual-boots Linux and I was about to mount the share using smbmount with no problems.

However, when booting XP, it is as if the Ubuntu share doesn't exist!

I think a reformat is looming...
 
Old 01-28-2007, 04:33 PM   #6
wildar
Member
 
Registered: Jan 2007
Distribution: Mandriva 2008, Mandrake 2005, Ubuntu 8.04.1
Posts: 239

Rep: Reputation: 30
The XP system with the problem, is a firewall on? If yes, try it without the firewall.
 
Old 01-28-2007, 04:34 PM   #7
jim0112
LQ Newbie
 
Registered: Oct 2006
Location: Brighton, UK
Posts: 18

Original Poster
Rep: Reputation: 0
Yeah, it has ZoneAlarm - however I have tried disabling this and it doesn't make a difference.
 
Old 01-28-2007, 06:50 PM   #8
chrisortiz
Member
 
Registered: Nov 2005
Distribution: Slackware, and of course the super delux uber knoppix universal live recovery cd
Posts: 429

Rep: Reputation: 30
zone alarm blocks out going requests as well as incomming, first disable the firewall, if you are able to connect re-enable it and start googling for the ports used by windows file sharing and configure zone alarm accordingly
 
Old 01-28-2007, 07:08 PM   #9
wildar
Member
 
Registered: Jan 2007
Distribution: Mandriva 2008, Mandrake 2005, Ubuntu 8.04.1
Posts: 239

Rep: Reputation: 30
Quote:
Originally Posted by jim0112
Yeah, it has ZoneAlarm - however I have tried disabling this and it doesn't make a difference.
Try putting your LAN address in as trusted.
 
Old 02-09-2007, 04:29 PM   #10
jim0112
LQ Newbie
 
Registered: Oct 2006
Location: Brighton, UK
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by wildar
Try putting your LAN address in as trusted.
The 192.168.1.0/255.255.255.0 network was already trusted, so that wasn't the problem. Thanks though!

However - I do appear to have fixed it today! I uninstalled Client for Microsoft Networks and File and Print Sharing for Microsoft Networks from the properties of the adapter, rebooted, and then installed them again.

After another reboot the Linux machine popped up in My Network Places and I was able to browse the share as well.

I have no idea why this resolved the problem, because the problem machine was after all able to browse other Windows PCs with no problems. But I'm glad it's now working!
 
  


Reply

Tags
samba, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba - dont have permission to browse samba share. Scrag Linux - Software 4 11-28-2006 01:42 AM
LXer: Howto Browse a Samba or windows share securely over Internet LXer Syndicated Linux News 1 11-28-2006 01:35 AM
Samba share over diskless machine... amitsharma_26 Linux - Software 1 09-29-2005 09:30 AM
Process dies when i try to browse mounted SAMBA windows share poko Linux - Software 1 08-12-2004 11:40 PM
unable to browse samba share from windows 2003 kfloda Linux - Software 1 08-16-2003 07:14 AM


All times are GMT -5. The time now is 09:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration