LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-26-2006, 01:22 AM   #1
RemusX2
Member
 
Registered: Oct 2003
Location: Bozeman, Montana
Distribution: Gentoo 2010, Ubuntu 9.04
Posts: 175

Rep: Reputation: 30
Oggenc and Grip


I am trying to set up oggenc with grip and have been having a hell of a hard time.

This is my encode command-line input from within grip:

Code:
-m 128 -M 320 -a %a -l %d -t %n -d %y -G %G %w
Everything goes fine within grip (the encoding of the wav file to ogg seems rather quick) and when I open the ogg file via command-line or through xmms, the ogg file will not play.

While at the same time, I can encode the ogg file by hand issuing

Code:
oggenc -m 128 -M 320 -a artist -l disc -t trackname -d year -G genre 02*ogg
And this seems to work fine. I am wondering what I am doing different in the two? The % switches from within grip represent the current track, artist, ect. And the %w represents the file being encoded.

I appreciate any help/insight.

Thanks
Brandon
 
Old 09-26-2006, 05:07 AM   #2
cvt
Member
 
Registered: Jul 2004
Location: UK
Distribution: Slackware
Posts: 37

Rep: Reputation: 17
Hey RemusX2, don;t know if this would help, but here's my settings in grip.

Code:
Encoder Command Line: -o %m -a %a -l %d -t %n -b %b -N %t -G %G -d %y %w
Here's yours...
Code:
-m 128 -M 320 -a %a -l %d -t %n -d %y -G %G %w
Were you trying to set the bitrate using the "-m 128"?

Have a look at http://nostatic.org/grip/doc/ar01s04.html#mp3config
Look for a section titled "Configuration (%) switches".
The switches are different for grip. Grip will convert them for use with oggenc.
Yeah, I would have thought it differently too!

Edit: PS. You can set the bitrate under Config->Encode->Options.

Last edited by cvt; 09-26-2006 at 05:08 AM.
 
Old 09-26-2006, 11:11 AM   #3
RemusX2
Member
 
Registered: Oct 2003
Location: Bozeman, Montana
Distribution: Gentoo 2010, Ubuntu 9.04
Posts: 175

Original Poster
Rep: Reputation: 30
Ussing -m 128 and -M 320 would set the minimum bitrate to 128 and the maximum bitrate to 320. This works fine through the command line, but I'm not sure about grip. I'll compare our two command-lines and see if I can make something work

Thanks
 
Old 09-26-2006, 11:29 AM   #4
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Rep: Reputation: 81
You could try using -q 6 or something similar instead of -b bitrate. If you set the quality, the bitrate won't always stay the same, and then you can use the -m and -M flags to keep it in the range you want.
 
Old 09-26-2006, 11:32 AM   #5
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Rep: Reputation: 81
Try updating to the newest version if you don't already have it, or you could try the beta. Tell me if anything I said helps.
 
Old 09-26-2006, 07:24 PM   #6
RemusX2
Member
 
Registered: Oct 2003
Location: Bozeman, Montana
Distribution: Gentoo 2010, Ubuntu 9.04
Posts: 175

Original Poster
Rep: Reputation: 30
Still no luck, even with using -q 6. The thing that I am not understanding is why I can issue hte exact same command by hand through a console, it works fine. Grip must not be getting something accross to oggenc on my machine. I'll keep trying and see if I get any results ever.
 
Old 09-26-2006, 08:45 PM   #7
RemusX2
Member
 
Registered: Oct 2003
Location: Bozeman, Montana
Distribution: Gentoo 2010, Ubuntu 9.04
Posts: 175

Original Poster
Rep: Reputation: 30
I found out the problem with the hole thing was that ID3 tags were being written to the Ogg file after the encoding was done. Checking the option to ID3 tag only .mp3 files fixed everything. Thanks for everyone's help
 
  


Reply

Tags
encode, grip, ogg, rip, vorbis


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lame -vs- oggenc ubuntu-norm Linux - Software 10 12-30-2005 03:53 AM
oggenc GUI rickenbacherus Linux - Software 3 01-13-2005 04:12 PM
oggenc GUI eliasblanco Linux - Software 0 10-21-2004 01:41 PM
How to upgrade oggenc/libvorbis? colelinux Linux - Newbie 0 03-15-2004 08:38 PM
oggenc and mp3 rch Linux - General 3 03-06-2003 02:49 AM


All times are GMT -5. The time now is 07:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration