LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-12-2003, 10:25 PM   #1
LinuxDude
Member
 
Registered: Aug 2002
Location: the web
Distribution: Mandrake 9.0/FreeBSD 5.0 (Dual)
Posts: 49

Rep: Reputation: 15
Unhappy Odd Apache VHost Problem


Hey guys! I have a Mandrake 9.0 server with Apache 1.3.27 and PHP 4.3.1 running on it. For quite sometime, I have used a virtualhost configuration that has not needed modification. A few days ago, however, whenever I went to visit my main site (4life.ath.cx), all I got was a blank page. I have tried everything that I can think of - from changing the permissions/group/ownership to modifying the Apache & PHP config files and more without luck. I hoping that someone here can give me a few more suggestions. Oddly enough, my personal site (joesplace.mine.nu) is still up and running perfectly! Also, when I try viewing the main site using Konqueror I get a strange error message saying "The protocal http://4life.ath.cx/ has suddenly died unexpectedly". The browser that I normally try to view it with, though, is my favorite Mozilla.

Thank you guys in advance! If you need anything else, just ask....

P.S. - If you can not view either one of my sites, it is because I am not keeping this server up 24-7 just yet. I will be soon, though - hopefully.


Last edited by LinuxDude; 03-12-2003 at 10:26 PM.
 
Old 03-13-2003, 12:56 PM   #2
Burke
Member
 
Registered: Dec 2002
Location: Virginia, USA
Distribution: Fedora Core 3
Posts: 131

Rep: Reputation: 15
start off by placing an index.html file with a test message in the document root for that virtual host.. See if that comes up.

Then try different doc types -- see if that is any type of issue. This helps me determine whether or not a site is even getting to the correct directory.

You may also want to have a console window open with the following:
assuming /var/log/httpd/error_log is your error log (replace as necessary)

tail -f /var/log/httpd/error_log

See if any help shows up there when you try to access the site.
Then try the same with "access_log"
Note: these are default httpd logs in MDK.
 
Old 03-13-2003, 09:27 PM   #3
LinuxDude
Member
 
Registered: Aug 2002
Location: the web
Distribution: Mandrake 9.0/FreeBSD 5.0 (Dual)
Posts: 49

Original Poster
Rep: Reputation: 15
Thank you for replying, but I found the solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache vhost problem jelgavchik Linux - Software 4 04-27-2008 04:45 PM
Apache: Alias is working on ssl vhost but not on mass vhost jonavogt Linux - Software 0 06-07-2005 02:05 PM
vhost in apache jelgavchik Linux - Networking 3 02-07-2005 06:41 PM
apache 1.3 vhost z4Rilla Linux - Software 0 08-03-2003 06:44 AM
Odd Apache Problem cli_man Linux - Software 2 11-06-2002 06:46 AM


All times are GMT -5. The time now is 01:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration