LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-02-2002, 06:38 PM   #1
ollybolly
LQ Newbie
 
Registered: Jul 2002
Posts: 3

Rep: Reputation: 0
Nvidia + Xwindows Crash


Hello,

Can anybody help me please, i'am relatively new to linux and have a problem.

I just installed the NVIDIA driver for my Geforce 2 MX400 chipset. according to the instructions from nvidia.com. All went welll including starting x, i got the nvidia flash screen etc. so i thought all was fine. But after a while the screen went totally black, the only thing i could do was to reset. Everytime this happens again only the interval between starting x and the screen going black is different. I really have no idea what the problem is, i've looked everywhere.

Since i have installed the driver i also have the following errors:

gdk-error ** : x-connection to 0:0 broken
some gdk-warnings

xscreensaver: can't open display 0:0 (only as root)

At the end of the XFree86.0.log i get the following message

AUDIT :1804x : client 5 rejected from local host

Here some of the XFree86.0.log and some of my message log
(couldn't put it all into this due to the 10000 char max)

Hope you can help me out, thanx in advance !

Oh, i've got another thing, what does Tainted P means when looking if the module is loaded with lsmod ? Has this something to do with it ?

XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-8) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
Build Operating System: Linux 2.4.17-0.13smp i686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Jul 3 00:02:44 2002
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Anaconda Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "NVIDIA GeForce 2 MX (generic)"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "unix/:7100"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.5
XFree86 XInput driver : 0.3
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.3
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0

(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"

(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
06,01,00 hdr 80
(03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI: (0:10:0) BrookTree 848 rev 18, Mem @ 0xe7000000/12
(--) PCI:*(1:5:0) NVidia GeForce2 MX/MX 400 rev 178, Mem @
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
(II) Loading extension GLX
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
(II) Loading font FreeType
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
(II) Loading font CID
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.2960
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0

(II) NVIDIA XFree86 Driver 1.0-2960 Tue May 14 07:45:20 PDT 2002
(L
(II) Primary Device is: PCI 01:05:0
(--) Assigning device section with no busID to primary device
(--) Chipset GeForce2 MX/MX 400 found
(II) resource ranges after xf86ClaimFixedResources() call:

(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xE8000000
(--) NVIDIA(0): MMIO registers at 0xE6000000
(--) NVIDIA(0): VideoRAM: 65536 kBytes
(--) NVIDIA(0): Detected TV Encoder: Chrontel 7007
(--) NVIDIA(0): Display 0: maximum pixel clock at 8 bpp: 350 MHz
(--) NVIDIA(0): Display 0: maximum pixel clock at 16 bpp: 350 MHz
(--) NVIDIA(0): Display 0: maximum pixel clock at 32 bpp: 300 MHz
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.5
(II) NVIDIA(0): Monitor0: Using hsync range of 30.00-96.00 kHz
(II) NVIDIA(0): Monitor0: Using vrefresh range of 48.00-120.00 Hz
(II) NVIDIA(0): Clock range: 12.00 to 300.00 MHz
(II) NVIDIA(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
(
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(**) NVIDIA(0): Validated modes for Display Device 0:
(**) NVIDIA(0): Default mode "1024x768": 94.5 MHz, 68.7 kHz, 85.0 Hz
(**) NVIDIA(0): Default mode "1024x768": 78.8 MHz, 60.1 kHz, 75.1 Hz
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(--) NVIDIA(0): Display dimensions: (370, 270) mm
(--) NVIDIA(0): DPI set to (70, 72)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"

(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"

(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"

(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:

(II) NVIDIA(0): AGP 4X successfully initialized
(II) NVIDIA(0): Setting mode "1024x768"
(II) NVIDIA(0): Using XFree86 Acceleration Architecture (XAA)

(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-GLX
(II) Loading extension NV-CONTROL
(II) [GLX]: Calling GlxExtensionInit
(**) Option "Protocol" "PS/2"
(**) Mouse0: Protocol: "PS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 5
(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
SetKbdSettings - type: 2 rate: 30 delay: 500 snumlk: 0
SetKbdSettings - Succeeded
AUDIT: Wed Jul 3 00:02:51 2002: 1804 X: client 5 rejected from local host


HERE A PART of my messages log :


Jul 3 00:02:27 C1 gconfd (root-1335): Exiting
Jul 3 00:02:46 C1 kernel: NVRM: AGPGART: unknown chipset
Jul 3 00:02:46 C1 kernel: NVRM: AGPGART: aperture: 64M @ 0xf8000000
Jul 3 00:02:46 C1 kernel: NVRM: AGPGART: aperture mapped from 0xf8000000 to 0xd1a80000
Jul 3 00:02:46 C1 kernel: NVRM: AGPGART: mode 4x
Jul 3 00:02:46 C1 kernel: NVRM: AGPGART: allocated 16 pages
Jul 3 00:02:52 C1 gnome-name-server[1867]: starting
Jul 3 00:02:52 C1 gnome-name-server[1867]: name server starting
Jul 3 00:02:52 C1 gnome-name-server[1875]: starting
Jul 3 00:02:52 C1 gnome-name-server[1875]: name server was running on display, exiting
Jul 3 00:02:52 C1 gconfd (root-1876): starting (version 1.0.9), pid 1876 user 'root'
 
Old 07-03-2002, 05:50 PM   #2
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 47
I believe the tainted bit is to do with the fact that the driver is not GPL code. I think that anyway.

Did you install both the GLX and kernel parts of the driver. If I was you I would use the .tar.gz files to install the driver if you didn't do originally.

Have you tried to start up X as root?

The gdk warnings are normal (as normal as can be), I have them on my system, and nothing bad happens. You may want to upgrade your version of gtk and glib. What distro are you using?
 
Old 07-04-2002, 10:58 AM   #3
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Download and run nv_check.sh and remove any conflicting mesa opengl libs it detects.

Last edited by Aussie; 07-04-2002 at 07:54 PM.
 
Old 07-04-2002, 01:39 PM   #4
ollybolly
LQ Newbie
 
Registered: Jul 2002
Posts: 3

Original Poster
Rep: Reputation: 0
Thanx for the response,

I'm running redhat 7.3, kernel 2.4.18-3 on a Asus A7M266 1400, I did use the tar.gz files and did install both the GLX and kernel parts of the driver. However i have found out that the problem probably has something to to with AGP-bus instability. If i put agp support off with the the following line (Option "NvAgp" "0")in XF86Config-4 the problem is solved. But that's a stupid thing to do. So i'm now experimenting with the agp drive strength signal in my bios. It seems that with Nvidia cards the optimal strength is between EAh and EEh.

Mazzel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10 xwindows and nvidia problems nubsicle Mandriva 13 04-19-2006 04:51 PM
Bug / Xwindows / startx : xinit works but startx crash www.rzr.free.fr Linux - Software 4 10-17-2004 09:06 AM
fedora core 2 + xwindows + nvidia card dualhead problem Insurr3cti0n Fedora 1 06-04-2004 01:20 AM
Cant Exit Xwindows to install Nvidia Driver sendas4 Linux - Newbie 2 05-30-2004 09:52 PM
X11 Nvidia crash sh0 Slackware 5 11-18-2003 05:16 AM


All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration