LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   NVIDIA twinview + kernel 3.4.4-rt13 - GeForce 9400 GT (http://www.linuxquestions.org/questions/linux-software-2/nvidia-twinview-kernel-3-4-4-rt13-geforce-9400-gt-4175414902/)

MisterBark 07-04-2012 12:46 PM

NVIDIA twinview + kernel 3.4.4-rt13 - GeForce 9400 GT
 
Hi!

HARDWARE :
- Intel Core2 6400 2.13GHz (2 cores 64 bits)
- 6DB DDR2
- Nvidia GeForce 9400 GT on pcix
- Dual Screen LCD 22" BenQ vga

SOFTWARE :
- slackware 64 13.37
- custom kernel 3.4.4 patch realtime rt13
- X 1.9.5 (from slackware)
- openbox 3.5.0

-----

THE PROBLEM :

- Ubuntu was ok with kernel 3.0 and twinview 2x 1920x1080 - nvidia driver 280.13 (it was possibly not 64bit... not sure)

- Now, with nvidia 280.13, 295.59 or 302.17 :

*** either I have only CRT-1 (and the missing half of the desktop exists! I see only the right part) :
"Unable to read EDID for display device CRT-0 ... Unable to get display device CRT-0's EDID; cannot compute DPI from CRT-0's EDID ... Option TwinView is not used"

*** or, I tried the following things and the whole computer freezes immidiately when calling startx.

- saving the edid.bin of CRT-1 from nvidia-settings and use "Option CustomEDID CRT-0:/.../edid.bin" (the screens are the same)

- Force EDID options such as "UseEDID FALSE", "UseEDIDFreqs FALSE", "UseEDIDDpi FALSE", "ModeValidation NoEdidModes", and or course setting resolutions & freqs manually.

- try to use nvidia-settings to enable the second screen (freezes when pressing Apply) - BTW, CRT-0's resolutions are wrong, probably because EDID doesn't work with it.


PS: indeed, nouveau is disabled (and buggy)

There I am... I have no idea what else to try! :(
Any idea please?
THANKS!

heinblöd 07-06-2012 02:44 AM

Which nvidia driver are you using ? I mean from Ftp.nvidia or SBo? or the *.run file or build on your own ?,

MisterBark 07-06-2012 10:08 AM

Quote:

Originally Posted by heinblöd (Post 4720580)
Which nvidia driver are you using ? I mean from Ftp.nvidia or SBo? or the *.run file or build on your own ?,

As I wrote, I tried 280.13, 295.59 and 302.17.

heinblöd 07-08-2012 06:23 AM

Yes, but not which kind of packaging.

Quote:

... the *.run file or build on your own ?,
The message about "Unable to read EDID for display device CRT-0 ..." shouldn't be a problem.
Some displays don't get this straight. As long as it's marked (WW) and not (EE) it won't stop the xserver from starting.


as a guess you havn't disabled nouveau properly or you are missing some other important part like maybe xinerama.
(Yes it seems that even if you will disable xinerama in the xorg.conf it nededs to be present on the system.
I found this out with help from a nvidia technician to solve a similar problem)

Maybe you should try to :
- removepkg xf86-video-nouveau-*
- installpkg /extra/xf86-video-nouveau-blacklist-*
- then after a reboot install the binary drivers from ftp://download.nvidia.com/XFree86/Linux-x86_64/

maybe try NVIDIA-Linux-x86_64-295.40.run , that one would even work nicely with gnome3

And post the output of /var/log/Xorg.0.log please


All times are GMT -5. The time now is 01:04 PM.