LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-14-2010, 09:50 AM   #1
Fallhallen
LQ Newbie
 
Registered: May 2009
Location: Sweden
Distribution: Laptop: Slackware 4.0; Desktop: Slackware 12.2
Posts: 13

Rep: Reputation: 0
NVIDIA drivers garble sound quality


I've been having this problem for many months and I have finally isolated it to the NVIDIA-Linux-x86-190.53 driver (downloaded direct from the NVIDIA website).

I have an Asus A8N-E ACPI BIOS Revision 1013 Motherboard (which has a built in Realtek AC'97 soundcard).

My video card is NVIDIA GeForce 7900 GT/GTO

I am running Slackware 12.2, KDE 3.5, Kernel 2.6.27.31.


My problem is: Sound quality when only playing song files through xmms, songbrid, Amarok, etc... is garbled. Although games, Movies, DvD's, Video files, all sound through that media is perfect and clear.

I have already used Slackware 13, KDE 4.2.2 and I thought the problem was with KDE 4+ so I reinstalled to Slackware 12.2 and KDE 3.5. Everything was working great until I installed the NVIDIA-Linux-x86-190.53 driver so my video card works like it should and games work under Wine.

But I am at a loss on how I can get the soundcard working. I suspect something within the NVIDIA driver is conflicting with my soundcard. How can I isolate this problem and fix it?

Please be thorough in your help as I may not know how to execute the commands you want me to use. (Example, don't tell me to just chmod a directory, instead please tell me what command to issue and how to type it, as I am ever learning and may not know exactly how to do what you want me to do).

Thank you

Last edited by Fallhallen; 02-14-2010 at 09:52 AM. Reason: Added Video Card make/model
 
Old 02-14-2010, 10:32 AM   #2
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
see if the proprietary driver is ok with your kernel version

How many sound cards do you have?

see kde menu -->system settings ...

enable the correct ones

post out put of

#lspci -v
 
Old 02-15-2010, 06:11 AM   #3
Fallhallen
LQ Newbie
 
Registered: May 2009
Location: Sweden
Distribution: Laptop: Slackware 4.0; Desktop: Slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
I have just one soundcard.

Here is what #ispci -v printed out:

00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
Subsystem: ASUSTeK Computer Inc. A8N-E Mainboard
Flags: bus master, 66MHz, fast devsel, latency 0
Capabilities: [44] HyperTransport: Slave or Primary Interface
Capabilities: [e0] HyperTransport: MSI Mapping Enable+ Fixed-

00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
Subsystem: ASUSTeK Computer Inc. K8N4-E or A8N-E Mainboard
Flags: bus master, 66MHz, fast devsel, latency 0

00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
Subsystem: ASUSTeK Computer Inc. K8N4-E or A8N-E Mainboard
Flags: 66MHz, fast devsel, IRQ 255
I/O ports at e400 [size=32]
I/O ports at 4c00 [size=64]
I/O ports at 4c40 [size=64]
Capabilities: [44] Power Management version 2
Kernel driver in use: nForce2_smbus

00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2) (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. K8N4-E or A8N-E Mainboard
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 20
Memory at d3104000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [44] Power Management version 2
Kernel driver in use: ohci_hcd

00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3) (prog-if 20 [EHCI])
Subsystem: ASUSTeK Computer Inc. K8N4-E or A8N-E Mainboard
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 21
Memory at feb00000 (32-bit, non-prefetchable) [size=256]
Capabilities: [44] Debug port: BAR=1 offset=0098
Capabilities: [80] Power Management version 2
Kernel driver in use: ehci_hcd

00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
Subsystem: ASUSTeK Computer Inc. K8N4-E or A8N-E Mainboard
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
I/O ports at dc00 [size=256]
I/O ports at e000 [size=256]
Memory at d3103000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [44] Power Management version 2
Kernel driver in use: Intel ICH

00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2) (prog-if 8a [Master SecP PriP])
Subsystem: ASUSTeK Computer Inc. K8N4-E or A8N-E Mainboard
Flags: bus master, 66MHz, fast devsel, latency 0
[virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
[virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
[virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
[virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
I/O ports at f000 [size=16]
Capabilities: [44] Power Management version 2
Kernel driver in use: AMD_IDE

00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3) (prog-if 85 [Master SecO PriO])
Subsystem: ASUSTeK Computer Inc. A8N-E Mainboard
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
I/O ports at 09f0 [size=8]
I/O ports at 0bf0 [size=4]
I/O ports at 0970 [size=8]
I/O ports at 0b70 [size=4]
I/O ports at d800 [size=16]
Memory at d3102000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [44] Power Management version 2
Kernel driver in use: sata_nv

00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3) (prog-if 85 [Master SecO PriO])
Subsystem: ASUSTeK Computer Inc. K8N4-E or A8N-E Mainboard
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
I/O ports at 09e0 [size=8]
I/O ports at 0be0 [size=4]
I/O ports at 0960 [size=8]
I/O ports at 0b60 [size=4]
I/O ports at c400 [size=16]
Memory at d3101000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [44] Power Management version 2
Kernel driver in use: sata_nv

00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2) (prog-if 01 [Subtractive decode])
Flags: bus master, 66MHz, fast devsel, latency 0
Bus: primary=00, secondary=05, subordinate=05, sec-latency=128
Memory behind bridge: d3000000-d30fffff

00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
Subsystem: ASUSTeK Computer Inc. K8N4-E or A8N-E Mainboard
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
Memory at d3100000 (32-bit, non-prefetchable) [size=4K]
I/O ports at b000 [size=8]
Capabilities: [44] Power Management version 2
Kernel driver in use: forcedeth

00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
Capabilities: [40] Power Management version 2
Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable-
Capabilities: [58] HyperTransport: MSI Mapping Enable- Fixed-
Capabilities: [80] Express Root Port (Slot+), MSI 00
Capabilities: [100] Virtual Channel <?>
Kernel driver in use: pcieport-driver

00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
Capabilities: [40] Power Management version 2
Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable-
Capabilities: [58] HyperTransport: MSI Mapping Enable- Fixed-
Capabilities: [80] Express Root Port (Slot+), MSI 00
Capabilities: [100] Virtual Channel <?>
Kernel driver in use: pcieport-driver

00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
Capabilities: [40] Power Management version 2
Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable-
Capabilities: [58] HyperTransport: MSI Mapping Enable- Fixed-
Capabilities: [80] Express Root Port (Slot+), MSI 00
Capabilities: [100] Virtual Channel <?>
Kernel driver in use: pcieport-driver

00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: 0000a000-0000afff
Memory behind bridge: d0000000-d2ffffff
Prefetchable memory behind bridge: 00000000c0000000-00000000cfffffff
Capabilities: [40] Power Management version 2
Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable-
Capabilities: [58] HyperTransport: MSI Mapping Enable- Fixed-
Capabilities: [80] Express Root Port (Slot+), MSI 00
Capabilities: [100] Virtual Channel <?>
Kernel driver in use: pcieport-driver

00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
Flags: fast devsel
Capabilities: [80] HyperTransport: Host or Secondary Interface

00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
Flags: fast devsel
Kernel driver in use: k8temp

01:00.0 VGA compatible controller: nVidia Corporation G71 [GeForce 7900 GT/GTO] (rev a1) (prog-if 00 [VGA controller])
Subsystem: XFX Pine Group Inc. Unknown device 2211
Flags: bus master, fast devsel, latency 0, IRQ 18
Memory at d0000000 (32-bit, non-prefetchable) [size=16M]
Memory at c0000000 (64-bit, prefetchable) [size=256M]
Memory at d1000000 (64-bit, non-prefetchable) [size=16M]
I/O ports at a000 [size=128]
[virtual] Expansion ROM at d2000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [100] Virtual Channel <?>
Capabilities: [128] Power Budgeting <?>
Kernel driver in use: nvidia
Kernel modules: nvidia

05:07.0 FireWire (IEEE 1394): NEC Corporation uPD72873 IEEE1394 OHCI 1.1 2-port Host Controller (rev 01) (prog-if 10 [OHCI])
Subsystem: NEC Corporation uPD72873 IEEE1394 OHCI 1.1 2-port Host Controller
Flags: bus master, medium devsel, latency 32, IRQ 17
Memory at d3000000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [60] Power Management version 2
Kernel driver in use: ohci1394
 
Old 02-15-2010, 08:31 AM   #4
Shannon_VanWagner
LQ Newbie
 
Registered: Mar 2007
Posts: 19

Rep: Reputation: 1
@Fallhallen, I've had some sound issues with the nvidia chipset onboard sound in Ubuntu GNU/Linux 9.10. After a few months of suffering with "delicate-to-crunchy" sound, I finally found these tips:

1.) Update to the latest kernel.
2.) edit /etc/modprobe.d/alsa-base.conf to contain the following line and then reboot:
options snd-hda-intel model=6stack-dig probe_mask=1

Note: this particular file "alsa-base.conf" may be located in a different storage directory in Slackware... but the changes should have the same effect.

If you want to see the complete account of my suffrage, checkout this post:
https://bugs.launchpad.net/ubuntu/+s...ux/+bug/442748


Hope this helps.

Shannon VanWagner
humans-enabled.com | digg.com/users/bicep

Last edited by Shannon_VanWagner; 02-15-2010 at 08:44 AM.
 
Old 02-16-2010, 02:02 PM   #5
Fallhallen
LQ Newbie
 
Registered: May 2009
Location: Sweden
Distribution: Laptop: Slackware 4.0; Desktop: Slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
Hrm, alsa-base.conf file does not exist on my system. I do have a modprobe.conf file in the /etc/modprobe.d/ directory, but after doing a search of my system, it resulted in no matches for alsa-base.conf

but I have an alsa.conf file located in /usr/share/alsa

Here is the output of that file:

#
# ALSA library configuration file
#

# pre-load the configuration files

@hooks [
{
func load
files [
"/etc/asound.conf"
"~/.asoundrc"
]
errors false
}
]

# load card-specific configuration files (on request)

cards.@hooks [
{
func load
files [
{
@func concat

Is that the same information on your alsa-base.conf file?

There also exists another directory with alsa information located in /usr/include/alsa
 
Old 02-17-2010, 08:52 AM   #6
Shannon_VanWagner
LQ Newbie
 
Registered: Mar 2007
Posts: 19

Rep: Reputation: 1
I've attached my /etc/modprobe.d/alsa-base.conf for your perusal.

alsa-base.conf seems to work in concert with modprobe to load the appropriate sound settings in Ubuntu.

I thought maybe you could find something in /etc/modprobe.conf but after looking at an example of that file, I'm not sure.

Perhaps there is a hint in one of these commands:
aplay -l
alsamixer --version
alsactl -v
cat /proc/asound/card0/codec#0

I'll keep looking around and let you know what I find.

Regards,
Shannon VanWagner
Attached Files
File Type: txt alsa-base.conf.txt (2.4 KB, 6 views)
 
Old 02-18-2010, 08:32 AM   #7
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Rep: Reputation: 184Reputation: 184
Do you have a /etc/modprobe.d/sound file? either run alsaconf wich will create one or create the file manually.
 
Old 02-18-2010, 08:48 AM   #8
Shannon_VanWagner
LQ Newbie
 
Registered: Mar 2007
Posts: 19

Rep: Reputation: 1
@colorpurple21859 - I think you nailed it..

From the looks of this post, /etc/modprobe.d/sound in Slackware is the equivalent of /etc/modprobe.d/alsa-base.conf in Ubuntu.

Perhaps you can add "model=6stack-dig" to /etc/modprobe.d/sound

Regards,

Shannon VanWagner
 
Old 02-18-2010, 09:38 AM   #9
Fallhallen
LQ Newbie
 
Registered: May 2009
Location: Sweden
Distribution: Laptop: Slackware 4.0; Desktop: Slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
I tried to run alsaconf it said no legacy drivers are available (I ran it as root, before started KDE). Then alsaconf quits and does nothing. no file was created or anything. So I copied your alsa-base.conf file and renamed it to sound and rebooted....

That broke my kernel. I deleted the file then rebooted again. Kernel is still broken and I have no idea how to restore it or get it back, Slackpkg is not cooperating with me. I cannot boot into KDE. If I have to do another reinstall of evertying I am going to be very upset...
 
Old 02-18-2010, 09:55 AM   #10
Fallhallen
LQ Newbie
 
Registered: May 2009
Location: Sweden
Distribution: Laptop: Slackware 4.0; Desktop: Slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
whatever that conf file did, I am unable to connect to the internet or any network on that system. It completely murdered my kernel
 
Old 02-19-2010, 08:46 AM   #11
Shannon_VanWagner
LQ Newbie
 
Registered: Mar 2007
Posts: 19

Rep: Reputation: 1
Bugger. Sorry to hear about that.

Was there an /etc/modprobe.d/sound file at all to begin with?
My suggestion was only to add "model=6stack-dig" to /etc/modprobe.d/sound as opposed to making the alsa-conf.base become the sound file.

According to that other post I mentioned here, this is an "example only(I'm not suggesting to load it, as the model is different for one)" contents from /etc/modprobe.d/sound
$ cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel index=0 model=hp

So apparently the alsa-base.conf is definately not the equivalent of the sound file, as the alsa-base.conf obviously does way more, in terms of inserting modules and such, than the basic sound file shown at the other posting.

From the looks of the alsa-base.conf file, it loads various modules into the kernel. Can you provide the output from lsmod ? Please also provide the output from dmesg and perhaps even tail /var/log/messages

I know rmmod removes a module, so perhaps some incorrect modules loaded from the alsa-base.conf file need to be removed. But I'm not exactly sure(NOTE: doing something like this would be completely experimental in my case). If it were me, I might start removing some of the modules that were loaded by the alsa-base.conf, but I would keep a very detailed list of what I did in case any were needed to be put back. This post suggests some sound setup steps.

As for your networking, does your network adapter even get an ip address if you check with ifconfig ?

I'm going to load up slackware in VirtualBox on my Ubuntu GNU/Linux machine so I can see how it sets up the sound.

Regards,
Shannon VanWagner

Last edited by Shannon_VanWagner; 02-19-2010 at 08:58 AM.
 
Old 02-19-2010, 02:21 PM   #12
Fallhallen
LQ Newbie
 
Registered: May 2009
Location: Sweden
Distribution: Laptop: Slackware 4.0; Desktop: Slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
I restored my Kernel from the Slackware 12.2 install CD set. And well, something in that file of yours worked. I am not sure what, but it must have loaded some sound module. When I reloaded the factory Kernel, it did not unload any of my modules. And now the sound works. I am unsure which command in that file did the trick, but the (sound) file that i created, I had deleted after it broke the system. So whatever it did, the changes stayed and now my sound works perfectly fine.

I have no idea how to figure out what it did, if you can tell me where to look, what log files and such, I can post that and maybe someone can figure out what it did, and what command I need to remember incase i ever have to do that again.

Also incase someone has the same problem they can see the fix and easily apply it.
 
Old 02-22-2010, 12:02 PM   #13
Shannon_VanWagner
LQ Newbie
 
Registered: Mar 2007
Posts: 19

Rep: Reputation: 1
Very good to hear you are back online and with sound working!

As for what fixed the problem, I can only guess that either inserting modules (as noted in the alsa-base.conf file) or setting the model for snd-hda-intel did the trick. Not sure.

Cheers!
Shannon VanWagner
 
Old 02-23-2010, 12:02 AM   #14
Fallhallen
LQ Newbie
 
Registered: May 2009
Location: Sweden
Distribution: Laptop: Slackware 4.0; Desktop: Slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
So there is no log file anywhere to check what happened?

Also, I was hoping these modules would have cleared up this other annoyance, but it didn't. I also get some sound disturbance when moving the mouse, or when other processes are running. I'm assuming it is just an issue of having some open channels that are not being used. So how do I probe these channels and figure out which ones I don't need turned on, and turn them off? I have no idea how to do this.
 
Old 02-23-2010, 11:32 PM   #15
Shannon_VanWagner
LQ Newbie
 
Registered: Mar 2007
Posts: 19

Rep: Reputation: 1
Have you tried booting to the 9.10 LiveCD and testing it that way?

Another thing you might try is loading the Ubuntu PPA for the newer sound drivers.
See
https://launchpad.net/~ubuntu-audio-dev/+archive/ppa

and
https://help.ubuntu.com/community/SoundTroubleshooting

I'll let you know if I find something else.

Cheers!
Shannon VanWagner
 
  


Reply

Tags
alsa, gateway, nvidia, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound gone after installing NVIDIA Drivers uskomaton Linux - Hardware 1 06-23-2009 07:34 AM
nVidia MoBo sound drivers? lewismetoo Linux - Desktop 3 10-07-2006 07:57 PM
Proprietary nvidia drivers vs. generic intel sound and ethernet drivers vharishankar Linux - Hardware 2 02-22-2005 05:32 AM
Very Poor Font/Image Quality after installing Nvidia Drivers Please Help DYNO Linux - Hardware 1 12-25-2004 02:17 PM
Problems recording high-quality sound with an NVidia chipset jrbiochem Linux - Hardware 0 05-31-2004 01:31 PM


All times are GMT -5. The time now is 06:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration