LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-05-2004, 05:46 AM   #1
deft
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Ubunto 7.10
Posts: 122

Rep: Reputation: 15
Nvidia Driver - X86 Problems ( RH9)


Hi All,

I recently downloaded the Nvidia driver for Linux A32. Upon Installing I find that it works alright, no problems. Until I reboot a few times, then that's when the problem starts. This seems to only happen sometimes? I can reboot and all is fine, get the Nividia splash screen, can run Bzflag and so on. But then I will turn the computer off and on and find that I have no X ? ? ?. It just resorts to the old X86. I have no idea what is going on Can anyone help.....

Many thanks in advance.........


deft.
 
Old 04-05-2004, 07:48 AM   #2
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
This is very strange, are you sure you do not have multiple XF86Config files in /etc/X11 and in your /root or /home/users directories.

X will look for a XF86Config file in your home directory then revert back to the default /etc/X11/XF86Config file, which is the one that should be being edited for global use.

Perhaps the nvidia driver setup did not write the file to /etc/X11 ?
 
Old 04-05-2004, 07:49 AM   #3
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
What do you mean it resorts to the old X86?
 
Old 04-05-2004, 07:58 AM   #4
deft
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Ubunto 7.10
Posts: 122

Original Poster
Rep: Reputation: 15
After not finding the "Nvidia driver" It starts the X86 config tool and with that it somehow resorts back to another X86 file. When I open the /etc/X11 X86config file the "driver" has went back to "nv". But since reading AutOPSY's reply, I have noticed that there is 2 X86 files, the X86config and X86backup? is this correct or should I remove it from that directory.

Thanks 4 the help All

deft
 
Old 04-05-2004, 08:02 AM   #5
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
you should remove all XF86Config files except /etc/X11/XF86Config.

Add the right driver to THAT file.
startx,
make sure its right, then save that file as XF86Config.backup somewhere.

So that any occurences of XF86Config, or Config.backup have the right driver in it.
That way it will never be wrong.

That is still strange that it sometimes wont find the nvidia driver.
Make sure your /etc/X11/XF86Config file is only writable by root.

maybe the driver isnt loading with a normal user and XF86 is getting re-written by a norm users.

Last edited by AutOPSY; 04-05-2004 at 08:04 AM.
 
Old 04-05-2004, 08:34 AM   #6
deft
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Ubunto 7.10
Posts: 122

Original Poster
Rep: Reputation: 15
Thanks AutOPSY, I have now moved the backup file elsewhere and rebooted, all seems fine, I have a feeling that is it solved. Although that statement will probably come back and bite me on the ass.

Many thanks..


deft.......
 
Old 04-12-2004, 12:17 PM   #7
deft
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Ubunto 7.10
Posts: 122

Original Poster
Rep: Reputation: 15
It's happened again ?

Hi All, ( AutOPSY )

I am still having reoccurring problems problems with my Nvidia driver.. AutOPSY I moved the back-up X86 file to my home directory and ensured there was no other X86 file in the /etc/X86 directory. What is happening is that when I reboot my machine it fails in booting X. It then takes me through the RH utility that deals with X, it does not find the "nvidia" driver and it then creates the new X86 file upon probing my Graphics card ( I think ). Here is the /etc/X86/X86config file:


# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Flatron915FT"
DisplaySize 360 270
HorizSync 30.0 - 107.0
VertRefresh 50.0 - 200.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv" <------ ###### I usually change this to nvidia !!!!!!
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 GTS (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


In the secton I have marked above, I replace the "nv" with "nividia" which works fine when I reboot The problems start maybe once or twice in shutting down and restarting. I am at a total loss on this.... Help!

Many thanks for your help..


deft...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RH9 Nvidia driver upgrade from 5336 to 6106, GLX problems ZeeMan Red Hat 2 08-25-2004 11:13 AM
help with nvidia driver x86 config on mandrake10 theconfused Linux - Newbie 3 07-03-2004 09:35 PM
Persistant Nvidia X86 Problems deft Linux - Software 3 04-13-2004 09:41 AM
kernel 2.6.3--bk8 and NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia zdenkod Linux - Hardware 2 03-09-2004 05:38 AM
Big problems installing NVIDIA-Linux-x86-1.0-4349.run ludwig W Linux - Software 4 04-19-2003 05:35 AM


All times are GMT -5. The time now is 12:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration