LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 12-06-2009, 02:14 AM   #1
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Rep: Reputation: 15
Unhappy nvidia cards


Greetings


I have a machine with 2 monitors and 2 Nvidia Grafics cards of Quadro FX 5600 and the driver version is Nvidia 190.42.


My redhat version is RHEL 4.7

When i login to the mahcine it logs me as two different users ,i cannot drag windows from one monitor to the other.


Can any please help me in making the two Grafics card to act as one Grafic card.



Regards
 
Old 12-06-2009, 05:25 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
You are using xorg multi-head by default. You need to edit the xorg.conf file so it works differently. There are a lot of threads on this sort of thing, like this one. It features ATI cards but the approach is going to be the same as it does not involve driver specific tricks.

Your differences will ba that the driver is nvidia, and your busIDs will be different - you get them off lspci.
 
Old 12-08-2009, 12:34 AM   #3
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Original Poster
Rep: Reputation: 15
I tried the links sent by you...But nothing worked.



below is my Xorg file please look in to it ....Your help will be highly appreciated.



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder58) Tue Oct 20 21:26:01 PDT 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Tue Oct 20 21:25:04 PDT 2009
# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "0"
EndSection

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"

# Load "GLcore"
Load "dbe"
Load "extmod"
Load "fbdevhw"
# Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Option "AutoRepeat" "500 5"
# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:nocaps"
#Option "XkbOptions" ""
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
#Option "XkbVariant" ""
EndSection

Section "InputDevice"

# Modified by mouseconfig
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL 1907FPV"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 76.0
ModeLine "1400x1050" 129 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 151 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 162 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 184 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
Option "dpms"
# -- 1400x1050 --
# 1400x1050 @ 60Hz, 65.8 kHz hsync
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "DELL 1907FP"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 76.0
EndSection

Section "Device"

# no known options
####
Identifier "NVIDIA GeForce 4 (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 4800"
BusID "PCI:2:0:0"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 4800"
BusID "PCI:1:0:0"
EndSection

Section "Screen"

# Removed Option "TwinView"
# Removed Option "MetaModes" "1280x1024,1280x1024; 1024x768,1024x768"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "SecondMonitorHorizSync" "31.0-107.0"
Option "SecondMonitorVertRefresh" "50.0-160.0"
Option "Overlay" "on"
Option "TwinView" "0"
Option "metamodes" "1280x1024 +0+0; 1024x768 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1280x1024_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
 
Old 12-08-2009, 12:49 AM   #4
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 12.04
Posts: 1,289

Rep: Reputation: 42
Do you have nvidias own nvidia X server settings software??

I use Ubuntu, and I had problems. But with nvidias software installed, it works ok.

Start nvidia x server settings. Go to the second menu choice at the top: X server display configuration.

Make sure the other monitor is plugged in and on. Click detect displays. The second monitor will appear. It always appears to the right of your monitor. I click the position box and go to absolute, then drag the new monitor over the other one. Then I have two showing the same thing. I've never got it to work as a separate screen, but I only need it to display to class, so that is enough.
 
Old 12-08-2009, 01:13 AM   #5
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Original Poster
Rep: Reputation: 15
I installed Nvidia driver version
[root@localhost ~]# cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 190.42 Tue Oct 20 20:25:42 PDT 2009
GCC version: gcc version 3.4.6 20060404 (Red Hat 3.4.6-10)
[root@localhost ~]# cat /proc/driver/nvidia/cards/0
Model: Quadro FX 4800
IRQ: 177
Video BIOS: 62.00.25.01.02
Card Type: PCI-E
DMA Size: 40 bits
DMA Mask: 0xffffffffff
Bus Location: 01.00.0
[root@localhost ~]# cat /proc/driver/nvidia/cards/1
Model: Quadro FX 4800
IRQ: 185
Video BIOS: 62.00.25.01.02
Card Type: PCI-E
DMA Size: 40 bits
DMA Mask: 0xffffffffff
Bus Location: 02.00.0

when i run the command nvidia-settings i see two screens but i want them to be act as twin view.
Now they are acting as two different desktops.i cannot move the windows between the two monnitors.

Please advise.
 
Old 12-08-2009, 01:20 AM   #6
alunduil
Member
 
Registered: Feb 2005
Location: San Antonio, TX
Distribution: Gentoo
Posts: 684

Rep: Reputation: 62
As Pedroski mentioned use nvidia-settings to configure your screens the way you like. It will give you the option to write out the xorg.conf file as well. Easiest way to configure nVidia screens the way you like.

Regards,

Alunduil
 
Old 12-08-2009, 01:55 AM   #7
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Original Poster
Rep: Reputation: 15
As i mentioned earlier i have two Nvidia cards and two monitors i want both the monitors to be acted as one i.e TWIN VIEW.

in Nvidia-settings command the option for twin view is disabled.


PLease advise how to enable the twinview option.
 
Old 12-08-2009, 02:35 AM   #8
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 12.04
Posts: 1,289

Rep: Reputation: 42
Yeah, disabled is default: go to the button configure, you should get a little window, with three choices: disable, separate screen and twinview. Click the check button, close, then click apply. X restarts, and you should have two screens working. It goes funny if you don't put one on top of the other. Position Absolute, then drag it on top of screen 0, your ordinary screen.
You have 15 seconds to accept, or it reverts!
What do you mean you have two cards?? You only need one!
 
Old 12-08-2009, 02:39 AM   #9
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 12.04
Posts: 1,289

Rep: Reputation: 42
If you leave the new screen at the right, you effectively have a desktop equal to the width of say, mine is 800 plus the other one 768, which is wierd! But then you can drag things off of your screen 0 onto screen 1. A big ol' desktop!
 
Old 12-08-2009, 03:00 AM   #10
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Original Poster
Rep: Reputation: 15
i tried all but the option for twin view is disabled ...i cannot check ...

Please find the attachments....

Regards
Attached Images
File Type: png snapshot2.png (183.2 KB, 2 views)
File Type: png snapshot3.png (146.7 KB, 2 views)
File Type: png snapshot5.png (158.6 KB, 2 views)
 
Old 12-08-2009, 03:15 AM   #11
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 12.04
Posts: 1,289

Rep: Reputation: 42
click on screen two, the one on the right, so that it is active. (Has a highlighted frame around it, like the one on the left in your fotos. It must be highlighted to interact with it!
You should then be able to activate twinview.
Works for me!
 
Old 12-08-2009, 03:20 AM   #12
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 12.04
Posts: 1,289

Rep: Reputation: 42
screen 0 is active at boot, but screen 1 needs to be activated, at least for me. I think it should start of its own accord on boot. Save the X config ( there is a button near the bottom) You may need to be root to do that. I just start up nvidia settings when I want it, and set it up, as the screens I use vary!

Set the resolution to Auto, if you don't know the res of your screens. If they are the same, no problem, but if they aren't you will lose bits of the larger in the smaller!
 
Old 12-08-2009, 03:26 AM   #13
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Original Poster
Rep: Reputation: 15
Its disabled.......PLease check the attachment.
Attached Images
File Type: png snapshot6.png (158.9 KB, 1 views)
 
Old 12-08-2009, 03:30 AM   #14
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 12.04
Posts: 1,289

Rep: Reputation: 42
Wierd, but not unusual for Linux! Have you tried booting with the screen plugged in?
Or run nvidia-settings as root? It took me ages to get things working. I know how you feel!

I would guess you are having root problems! Do it as root!
 
Old 12-08-2009, 03:31 AM   #15
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 12.04
Posts: 1,289

Rep: Reputation: 42
you have two identical screens? Maybe the computer is confused!? Try a different second screen!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia cards settings rehan999 Linux - Software 1 11-03-2009 03:51 AM
Overclocking Nvidia Cards raffytaffy Suse/Novell 3 10-06-2006 10:06 AM
nvidia make their own cards? cjae Linux - Hardware 8 05-16-2005 11:44 AM
Mandy 10.1, Nvidia cards 900i Mandriva 2 11-28-2004 06:15 AM
Those with NVidia Cards might want to.... Black_iCE_mdk Mandriva 1 06-09-2004 04:56 PM


All times are GMT -5. The time now is 05:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration