Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 04-04-2007, 03:39 AM   #1
LQ Newbie
Registered: Mar 2007
Posts: 12

Rep: Reputation: 0
Numpy installation help

Hi guys,

I've install python on my linux, Mandrake 10.1, and now I want to get Numerical Python on
my computer, but, everytime i type the installation command,
> python install (like the README says)

this error pops up:

Running from numpy source directory.
Traceback (most recent call last):
File "", line 89, in ?
File "", line 59, in setup_package
from numpy.distutils.core import setup
File "/home/timtune/Downloads/numpy-1.0.1/numpy/distutils/", line 24, in ?
from numpy.distutils.command import build_ext
File "/home/timtune/Downloads/numpy-1.0.1/numpy/distutils/command/", line 16, in ?
from numpy.distutils.system_info import combine_paths
File "/home/timtune/Downloads/numpy-1.0.1/numpy/distutils/", line 159, in ?
so_ext = distutils.sysconfig.get_config_vars('SO')[0] or ''
File "/usr/lib/python2.3/distutils/", line 472, in get_config_vars
File "/usr/lib/python2.3/distutils/", line 356, in _init_posix
raise DistutilsPlatformError(my_msg)
distutils.errors.DistutilsPlatformError: invalid Python installation: unable to open /usr/lib/python2.3/config/Makefile (No such file or directory)

Can someone help me plz?
Old 04-05-2007, 11:57 AM   #2
Senior Member
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
is libpython2.x-devel installed? i'm guessing not.
Old 04-06-2007, 07:50 AM   #3
LQ Newbie
Registered: Mar 2007
Posts: 12

Original Poster
Rep: Reputation: 0
I did a ln from /usr/lib/ to /usr/lib/python2.3
The same error still pops up.

I just got rid of python2.3 and got python 2.5. There is no config directory with 'Makefile' in my python2.3 but there is one in my python2.5.

However, when i try to install Numpy, it still looks for 'Makefile' in python2.3 and complaints.

thanks for your reply!



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat/Linux Installation Support??? Is It Red hat installation problem??? wanux Red Hat 1 08-01-2006 11:32 PM
Installation doesn't recognize Red Hat Enterprise Linux ES installation cd bizkut Red Hat 2 08-15-2004 09:57 AM
Mandrake 9.2 installation program crashes in the final step of the installation iqbala Mandriva 0 12-03-2003 02:59 PM
Visual Python/Numpy uranologist Linux - Software 0 09-28-2003 11:08 PM

All times are GMT -5. The time now is 06:02 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration