LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-12-2005, 06:32 PM   #1
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Numlock turns off while swtiching console to GUI


I'm getting annoyed by the numlock light not being on after switching from tty1-6 (console) to GUI. It turns on when it first runs GUI. I tried using numlockx and using LFS setnumlock. Both does not work while switching from console to GUI. If I switch from GUI to console, the numlock for console (lets say tty1) stays on. I tried everything that I can think of. Though it seems that the numpad works but light will not show.

I'm using Gentoo 2005.0 and KVM switch.

Please throw some suggestions.
 
Old 06-13-2005, 12:32 PM   #2
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
One might use setleds in /etc/rc to define the initial and
default state of NumLock, e.g. by
INITTY=/dev/tty[1-8]
for tty in $INITTY; do
setleds -D +num < $tty
done

from the man pages
 
Old 06-14-2005, 12:01 AM   #3
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Original Poster
Rep: Reputation: Disabled
I already have that for the consoles.

What I mean is when I go from the console to GUI, numlock light turns off, but the numpad works anyways.
 
Old 06-14-2005, 07:03 PM   #4
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
If your in kde goto the control center find the option to turn on the numlock. gnome or any other wm use numlockx or setnumlock. google works wonders.
 
Old 06-14-2005, 09:49 PM   #5
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Quote:
...setleds ... kde control center ... numlockx ... setnumlock ...
From what I've read about the issue, all these things work for some people and not for others. Not worth the hassle. Only reason it's bothersome at all is because we've all been brainwashed by Windows. Doesn't take long to get used to turning NumLock on manually when you boot Linux.

You say your problem is not that the numberic keypad being disabled, but the light turning off. My solution would be to disable the keypad ... the light's already off ... Presto! One keystroke solves two problems.
 
Old 06-14-2005, 10:47 PM   #6
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Original Poster
Rep: Reputation: Disabled
I use Xfce4.

I rarely create any threads because I always search the internet using Google.

Quote:
You say your problem is not that the numberic keypad being disabled, but the light turning off. My solution would be to disable the keypad ... the light's already off ... Presto! One keystroke solves two problems.
I have been doing this from the very start I installed Gentoo. I'll just include a log option when I start up X Window Server and then check the logs.

I tried putting it in ~/.xinitrc and other xinitrc files.
 
Old 06-15-2005, 02:06 AM   #7
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Get numlockx and install it. Then, in your ~/.xinitrc , place this line before your WM/DE line:
Code:
numlockx
 
Old 06-16-2005, 05:20 AM   #8
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Original Poster
Rep: Reputation: Disabled
scuzzman, did you skim my post?

I already said that I put it in ~/.xinitrc and others.
 
Old 06-16-2005, 06:04 AM   #9
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Re: Numlock turns off while swtiching console to GUI

Quote:
Originally posted by Electro
I'm getting annoyed by the numlock light not being on after switching from tty1-6 (console) to GUI. It turns on when it first runs GUI. I tried using numlockx and using LFS setnumlock. Both does not work while switching from console to GUI. If I switch from GUI to console, the numlock for console (lets say tty1) stays on. I tried everything that I can think of. Though it seems that the numpad works but light will not show.

I'm using Gentoo 2005.0 and KVM switch.

Please throw some suggestions.
Funny, I see no mention of your ~/.xinitrc here...
There is a mention though in a few posts down, but "I tried putting it in ~/.xinitrc" isn't really all that descriptive to me. My apologies if my suggestion didn't work, better luck next time.
 
Old 06-17-2005, 01:24 AM   #10
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Original Poster
Rep: Reputation: Disabled
I added the code below in /etc/X11/xorg.conf and it worked. If I press capslock, its light gets an reminder to stay on when switching from the console to GUI. Both numlock and caplock work.

Code:
Option      "Xleds"      "1 2 3"
Several months ago, I tried the above in Slackware 10, but it did not work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't get from gui back to console nutbag Slackware 11 07-24-2005 08:16 AM
Swtiching APs using ndiswrapper in FC2 ranceramos Linux - Wireless Networking 2 10-23-2004 09:22 AM
NOT X (GUI) no Console - Help! tripweed Fedora 3 03-25-2004 11:32 AM
swtiching citrus Linux - General 1 01-21-2004 03:14 AM
using gui browser with samba turns up empty shared folders wlfdgcrkz Linux - Software 1 04-25-2003 01:56 AM


All times are GMT -5. The time now is 05:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration