LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-08-2010, 06:51 PM   #1
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Rep: Reputation: 34
ntp off by one hour


Hey there are other threads that address this but none of them fix my problem. I know it's an issue with daylight savings time but my time is exactly one hour behind. I've tried changing timezones to -4 and even -3 instead of -5 but it always syncs to exactly the same time no matter aht timezone I change to. I've also tried several different servers. Maybe there's a way to just bump your time by one hour or something -- like outside of ntp.
 
Old 05-08-2010, 07:08 PM   #2
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
The system clock in all *nix systems, including Linux, uses UTC internally. The time zone is only used to present the time to humans. Try running

Code:
date -u
and see if it displays the correct UTC time.

It also might be useful to let us know what distro you are using.
 
Old 05-08-2010, 09:14 PM   #3
jefro
Guru
 
Registered: Mar 2008
Posts: 11,539

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Any setting for follow/use daylight savings time?
 
Old 05-08-2010, 10:37 PM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,530

Rep: Reputation: 238Reputation: 238Reputation: 238
apt-get install tzconfig

or old-school it.

/etc/timezone
/etc/localtime
/usr/share/zoneinfo/*
 
Old 05-09-2010, 12:42 PM   #5
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Original Poster
Rep: Reputation: 34
UTC time is correct. I'm using gentoo. I even tried setting my timezone to Japan/Tokyo and my clock still remains at exactly the same time. If I never run ntp my clock is off by a lot but that's cause my motherboard clock is wrong... It's like ntp is ignoring my timezone. What other options are there?
 
Old 05-09-2010, 01:27 PM   #6
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Original Poster
Rep: Reputation: 34
Ah /etc/localtime needs to be correct as well. It was just generic EST somehow. tzconfig doesn't configure that file btw, I was doing it both ways each time to see if anything different would happen.
 
  


Reply

Tags
ntp, time


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cron job issue - every hour works, but specific hour fails lunarleviathan Linux - Newbie 6 11-20-2009 12:19 AM
ntp drift file in /etc/ntp instead of /var/lib/ntp - suggestion for a patch in Slack niels.horn Slackware 16 05-07-2009 07:35 PM
ntp time off by 1 hour schneidz Linux - Software 8 03-16-2008 10:30 PM
NTP cron job runs every 5 min instead of hour OlRoy Linux - Networking 17 02-28-2008 10:51 AM
Time updated by ntp is 1 hour behind jon1591 Linux - Newbie 2 06-21-2004 02:34 PM


All times are GMT -5. The time now is 11:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration